Attention: The forums will be placed on read only mode this Saturday (Oct. 20, 2018)

During this outage (6:30 AM to 8 PM PDT) the forums will be placed on read only mode. We apologize for this inconvenience. Click here to read details

Browsers, E-mail, & Web Apps forum


Removing CNet en Espanol pop up

by reneuriza / October 14, 2013 6:08 AM PDT

I have been trying to access the main CNET site page since CNET en Espanol went live and have been unable to do so. A pop up appears which I cannot close or block or delete which directs me to the Spanish language site. While I speak Spanish, in Brazil where I live we speak Portuguese and I would prefer to gain access to CNET in English. Does anyone have the same problem? How do I gain access to in English once again?

Discussion is locked
You are posting a reply to: Removing CNet en Espanol pop up
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Removing CNet en Espanol pop up
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Clarification Request
I have a few question for you.
by Lee Koo (ADMIN) CNET staff/forum admin / October 14, 2013 7:26 AM PDT

Thanks for reporting this to us. Hopefully I can get to the bottom of this, but I do need some details from you.

Can you tell me what browser you use?
Do you clear/delete your browser cookies often or after a browsing session?
When you go to are you saying you get redirect to the CNET Spanish site?

Just so it's clear, we do not have any URL redirects in place. So if you are on the CNET English site you should remain on the English site and you should not be redirected to the Spanish site--even if you are living in a Spanish speaking country. While these two sites are somewhat similar, they are different sites. The URLs are as follows:
CNET in English:
CNET in Spanish:

As for the popup window to invite you to check out the CNET Spanish site, if you close the popup window a couple of time or check the box to not show this again, it should not persist to show you this invitation, because we di set a cookie in your browser to tell our site not to bother you again. However if you often delete or always delete your browser cookies, it will display that popup window.

If you can provide us with some of these answers to the questions above and specifically give some more details as to what exactly happens, I will do my best to figure this out.

Thanks for your time and sorry for the inconvenience!

CNET Community

Collapse -
CNET en espanol
by reneuriza / October 14, 2013 1:50 PM PDT

Answering your questions:
I use the Chrome browser.
I delete browser cookies often but not after every browser session.
No, I do not get redirected to the CNET Spanish site. I get a pop up window that does not go away. I tried closing it. I tried telling it not to bother me again. I tried blocking pop ups but nothing seems to work.
Also, we speak Portuguese in Brazil and not Spanish.
I look forward to hearing from you.

Collapse -
Thanks for that information and...
by Lee Koo (ADMIN) CNET staff/forum admin / October 15, 2013 1:58 AM PDT
In reply to: CNET en espanol

sorry about the mistake about Spanish vs. Portuguese in Brazil.

Now when you say it "does not go away," does it open again every time you visit another CNET page and even in the CNET forums here?

So say you start out on and the window pops up, you close it or tell it to not bother you again, and when you start navigating through other CNET pages does it appear again? Or is it only when you start a new browser session visiting CNET again?

The pop window if closed or when you tell it not bother you again, out site will set a cookie to let our site know not to show you the pop window again, but if you delete your cookie, our site won't see that specifically set cookie and will pop the window again.

Can you try some for me?

Go to, if the pop up window appears, close it or tell it not to bother you again.
Now don't delete your cookies and close out the browser completely.
Open a new browser and go to again.

Does the pop up window appear again?

Also are you allowing cookies to be set?

Sorry about the inconvenience of asking you all these question and trying things out, but I'm working with my team to investigate this issue so that we can get to the bottom of this.

I really appreciate your help!

Collapse -
Removal of CNET en Espanol pop up
by reneuriza / October 15, 2013 4:33 AM PDT

Answering your questions:
I went to and the CNET en Espanol pop up appeared as usual.
I asked that it not bother me again.
I closed the Chrome browser .
I reopened the browser and tried CNET.Com again.
CNET en Espanol pop up was there again.
I allow cookies to appear but clear them out frequently.
I use ABINE Do Not Track Me software but I am allowing CNET to track me.
I look forward to hearing from you.

Collapse -
Thanks for that info, Rene....
by Lee Koo (ADMIN) CNET staff/forum admin / October 15, 2013 6:29 AM PDT

It looks like ABINE Do Not Track Me software maybe the culprit as it is considering the cookie set by our site to be a tracking cookie--which essentially it is because its job is recognize your preference on our site to not show that window. So if the DNTMe, is continually deleting or not accepting that cookie, it will persist to display that window to you each time you visit

One way to see if DNTMe is a culprit is to turn it off completely and repeat the steps that I posted above to see if you still see the popup window.

Also is there any preference setting in DNTMe, that would allow all CNET cookies to be set and not delete those CNET cookies?

Sorry about all the troubles and I appreciate you working with me.


Collapse -
Removal of CNET en espanol pop up
by reneuriza / October 15, 2013 7:01 AM PDT


DNTMe was indeed the culprit. I turned it off and now I can navigate the site in English without CNET en Espanol pop ups. The problem is that it leaves me open to being tracked by everybody. To give you an idea of what it means, DNTMe blocked about 500,000 cookies for me in < 1 year and the alternative of switching it off whenever I want to navigate CNET is a hassle. And, yes, there is a preference setting that allows me to ok tracking by CNET but it does not seem to work properly.

In sum, we now have a solution but it is not completely satisfactory. Any other ideas?

Collapse -
Thanks for that info...
by Lee Koo (ADMIN) CNET staff/forum admin / October 15, 2013 11:07 AM PDT

Hmmm I'm not sure what to do if DNTMe is not working correctly when you set it to make an exception for Does the program allow you to specifically make cookie exceptions? If I gave you the cookie name, can you tell DNTme, to not delete it or block it?

If that can't be done, I'm at a lost as what more can be done.

Anyone who has more experience with ABINE Do Not Track Me software and how we can help Rene with this issue is more than welcome to chime in. We'd appreciate it.

Thanks in advance,

Collapse -
Same happens to me
by marcusbacus / February 17, 2014 12:48 PM PST

The same happens to me in Firefox, and I'm not using any kind of blocking other than the Adblock Plus. It's very very annoying and frustrating. It happens in every article page. Even if I don't want to accept cookies from you or if I block any kind of tracking, it would be fairly simple to just make the "close" command in the popup work as it should, making the popup close. It's not the spanish popup appearing all the time that is more annoying, it's the inability to close it. If it's not accepting the simple close command, it's not working, and it's not a tracking or cookie fault.

Collapse -
Irritating popup won't close in Safari
by appledogx--2008 / December 5, 2013 11:00 AM PST

This irritating popup about CNET en espanol won't close in Safari. I've even tried blocking it with popup blockers, but the screen then turns dark gray. I live in a Spanish speaking country, but I speak and prefer English and there is no way to stop this thing. I may stop viewing all Cnet pages that pop this annoyance up as you can check the box, but not close the window on Safari. Unfortunately, there is content I really wan't to read. It is much better for there to just be a way for the user to change the language preference without being harassed by this irritation every time a CNET page pops up. I tried to report it several weeks ago, but apparently the popup code didn't get fixed, and still plasters over my screen in a most intrusive and annoying way. It's like a plague!

Collapse -
Spanish Pop Up
by robertnarmstrong / January 12, 2014 12:52 AM PST

All Answers

Collapse -
Re: CNET site.
by Kees_B Forum moderator / October 14, 2013 6:20 AM PDT

I've alerted this for the forummanager (Lee Koo) to look into and answer.


Collapse -
Same problem with Spanish popup
by sailfree / December 31, 2013 2:27 PM PST
In reply to: Re: CNET site.

I have the same problem. I am currently in Panama and when I go to I get an annoying popup saying (in Spanish) that CNET is available in Spanish. The close button (X) does not work and there is no way to make the popup disappear except to close the page in the browser. I use Firefox and Win 8.. I tried using a VPN to avoid the Spanish crap but the popup still appears and refuses to be closed.

Collapse -
Same problem
by alojcg / February 28, 2014 1:22 PM PST

Same problem here.

I do speak Spanish but I want to stick to CNET in English.

In Chrome I check the "Never show this again button" and click "close". Nothing ever happens. Same in Safari and Firefox. Only in Camino I can get the popup to go. But I don't want to switch to Camino every time I check something on CNET.

A fix to this would be awesome.

Collapse -
Same here...
by Angelopsy / March 14, 2014 6:22 AM PDT
In reply to: Same problem

I am having the same problem right now, using Chrome on Windows 8 in Brazil.

A quick workaround I've fount is pressing the "Esc" key to prevent the page from completely loading. It worked for me after trying a few times. Timing is important here. Try pressing "Esc" right after clicking the link to the page you want to see.

Also, there is an option within Chrome that enables something like "do not track me" or whatever. I haven't turned it off, but maybe it is affecting this situation somehow. I am using Adblock plugin.

I hope it helps.


Popular Forums

Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions


Your favorite shows are back!

Don’t miss your dramas, sitcoms and reality shows. Find out when and where they’re airing!