General discussion

Removed WindowsXP Component From Add/Remove Programs - HELP!

Please can someone HELP me!

I am using a ThinkPad R61i Windows XP Pro Version 2002 SP2

In an attempt to install the problematic update MS KB979906 for .NET Framework 1.1 SP1, I accidentally Removed Windows XP SP2 component which connects to:
- NetWork Connections Wizard,
- NetWork Connections Icons
- My SysTray is missing Icons e.g. computer monitor-like icon that you can Right-click on to see "Available Networks" "Repair Network Connections" ?Change/Add NetWork Connections? and flashes bright blue when you are connected to the internet; it also tells how many bars you have for your connection
- Unable to launch Anti-Virus program AVAST

Since I had this accident every time I boot up I receive the following error messages:

- Rescue & Recovery Back-up Service unable to run
- Netwk.exe error

I?ve tried installing these in hopes of fixing the problem ? but to no avail:

- Tried to download the following but got error message - NDP1.1sp1-KB979906-X86 has encountered a problem and needs to close. We are sorry for the inconvenience.

- Then I tried downloading Microsoft .Net Framework 2.0 SP2 and received the following error message - "this product is not supported on X86 operating system"

- Then I tried installing .NET Framework 4 Setup got error message "Installation Did Not Succeed because Windows Installer Service Could Not Be Accessed"

- Then I tried to install Windows Installer 4.5 Redistributable, and received the following: EXTRACTION FAILED - .update.exe is not a valid Win32 application

Discussion is locked

Follow
Reply to: Removed WindowsXP Component From Add/Remove Programs - HELP!
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Removed WindowsXP Component From Add/Remove Programs - HELP!
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Re: Help

This seems one of situations System Restore is meant for. Use it to go back to before you made this error and be more careful next time.

Kees

- Collapse -
System Restore

I promise to be more careful the next time. But please Help me!

I tried doing first a system rejuvenate via ThinkVantage System Rejuvenate and there were no dates to restore back to. So I tried doing system Recovery/Restore via ThinkVantage Restore my data and I keep getting a error messages e.g. WIZRR MFC Application encountered.
I have been oogling fixes for the last 24-hours with no luck.

Please I really promise to be more carefuful, but can you help me fix this problem.

Many Thanks!

- Collapse -
Re: System Restore

I don't have any idea what the ThinkVantage System Rejuvanate is, nor the ThinkVantage Restore, so I can't help you with that. My only suggestion was (and still is) to run the standard Windows system restore, as discussed in
http://support.microsoft.com/kb/306084

But, if it works, it should only undo the premature deletion of network components and system tray. I doubt if it's a solution also for all your apparent troubles with .Net and the Windows Installer. For that, it begins to look like a more radical solution like a clean install of the OS might be necessary.

Kees

- Collapse -
Odd.
- Collapse -
Unable to do a System Restore

Hi Bob,

Yes, I keep getting "Installation Did Not Succeed because Windows Installer Service Could Not Be Accessed" when I try to do a .NET Framework 4 install, or if I try to access my System Recovery and Restore Program.

Any Help you can give will be greatly appreciated.

Many thanks,
Michelle

- Collapse -
Since this is a new error messaage.

I think you should ask Microsoft about this one. Are you translating this from another language? I looked in my knowledge base and can't find this error.
Bob

- Collapse -
Microsoft indicates this error is NTFS-specific

Thanks Bob! Here is what I found at microsoft - http://support.microsoft.com/kb/319624
"Windows Installer Service could not be accessed" error message when installing application - The Windows Installer Service could not be accessed. This can occur if you are running Windows in safe mode, or the Windows Installer is not correctly installed. Contact your support personnel for assistance.

This behavior can occur when either of the following conditions exist:

* In the DCOM permissions, the default authentication level is set to None, and the default Impersonation level is set to Anonymous.
* The system account does not have Full permissions on a folder or registry key that the Windows Installer is trying to access. This is NTFS-specific.

Depending on the issue, use one or all of the following methods:

* Method 1: Unregister and re-register Windows Installer.
* Method 2: Verify the DCOM permissions.
* Method 3: Give Full Control permission to the SYSTEM account.
* Method 4: Verify the registry permissions.
* Method 5: Fix the broken security key for the MsiServer service.


Then I tried Method#4 - to verify the registry permissions - but I've not found out how to do this.

Any suggestions are greatly appreciated - thanks!

- Collapse -
Reinstall MsiServer service for WinXP

According to Microsoft my Error Message is "NTFS-specific." However "This behavior does not occur in the following products:
? Microsoft Windows XP
? Microsoft Windows Millennium Edition
? Microsoft Windows 98

Please, does anyone know where I can download and reinstall Win XP?
- Windows Installer
- Security Key for the MsiServer service

BTW - I checked Lenovo's website but could not find anything there.

Grateful for all responses. Thanks Happy

CNET Forums

Forum Info