Question

Realtek audio driver dynamic compression problem (pls help)

so my Realtek audio driver is causing the audio on my computer to become extremely compressed, loud, and terrible sounding after around 10 seconds of silence... so if no audio is playing on my computer for about 10 seconds, then i decided to play something, it makes my ears bleed and it's just terrible sounding. as a music lover and YouTube junkie this is extremely aggravating. i know that it is Realtek because when i uninstall the driver the problem simply goes away, but Realtek re-installs itself after a short period of time.. i've even gone into the computer's settings and told Windows not to install **** for me, but it is disobedient and does it anyway. please help me, my life is crumbling beneath me.

Discussion is locked

Follow
Reply to: Realtek audio driver dynamic compression problem (pls help)
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Realtek audio driver dynamic compression problem (pls help)
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Clarification Request
nothing?

still have this ******* annoying problem

- Collapse -
Answer
re: driver

Maybe it's just the wrong driver? Where did you get it from?

- Collapse -
Answer
Driver

Realtek audio driver you downloaded it from? reviews of other users of the driver that like?

- Collapse -
Answer
Realtek compression issue

I am using Realtek's driver without an issue. Listed below is what I would try. Some of these suggestions may seem elementary and moot so please bear with me.

1.) Go get an accurate meter. I use VU Meter v1.2. It's free at vuplayer.com. It is "VU" as opposed to "Peak", but any recording that's worth it will play just fine if you keep the levels "in the black". The other advantage of this program is that it truly monitors your levels after all the processing you may have in front of your audio card.

2.) Open your favorite playback app, i.e. VLC Player, MS Media Player, etc. Disable all audio compression in the app. (With VLC, that would be Ctrl+E>Audio Effects>Compressor. Not sure about WMP. Have not used it in a long time.)

3.) Open VU Meter, right click on display and choose "Always On Top". Adjust audio level, at the player app, so that meters read in the black. I've found that on my system, I can hit +3 with no problem. Any thing over +3 and you will run into digital compression. That's an infinity to 1 ratio as all the bits turn to one's and there's no where else to go. If this is your problem, then you're done. If not read on:

4.) Open Volume Mixer from the quick launch area. choose your output and click on it. I'm just using speakers so I click on "Speakers". In the "Enhancement" tab, check "Disable all sound effects".

Different source materials will have different volume levels (even from one video/audio file to the next) depending on a variety of factors, therefore for the best results I always consult VU Meter when opening a new file. If it interferes with viewing a video, simply close or minimize it after setting levels. Once again, as a rule of thumb, you'd want to keep it "in the black", but do not reduce the level excessively. Too low a level and you will loose audio resolution. Minor excursions "in the red" is acceptable unless you're a studio engineer.

-Glenn Odagawa
Audio Engineer
1974-present

- Collapse -
no fix still

i downloaded vu meter and disabled any compression effects within any and all playback apps, and did #4, but it's still compressed and terrible. regular playback is well within the black portion of the meter, but proceeding moments of silence it is completely maxed out without adjusting the volume. it's not that it's distorted, it's just very compressed and very loud.

the driver just says realtek high definition audio, version 10.0.10586.0. it was installed by microsoft automatically last october. the solution would simply be uninstall the driver but windows is apparently inclined to enforce specific drivers akin to a corrupt digital tyrant

- Collapse -
Your post makes me think
- Collapse -
yep

done this and it continues to reinstall

- Collapse -
This does not stop the reinstall

Only the fetching from Microsoft. If you have installed a newer or such driver you have to install the one you want now.

CNET Forums

Forum Info