Peripherals forum

General discussion

Razer Naga won't move cursor?

by ryanmcarlin / January 26, 2011 5:21 AM PST

Hey guys, I recently bought a Razer Naga and it worked fine for a month. I just tried to use it today but it won't move the cursor at all. All the lights are on and all the buttons seem to work. Any suggestions to fix movement?

I've tried uninstalling and re-installing the driver and using different usb ports.


OS: Windows 7 Ultimate 64 Bit (fully updated)
Razer Naga Driver v3.00

Discussion is locked
You are posting a reply to: Razer Naga won't move cursor?
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Razer Naga won't move cursor?
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
For a test.
by R. Proffitt Forum moderator / January 26, 2011 11:56 AM PST

Try this on another machine.
Try another mouse on your machine.

Collapse -
Razer Naga fix
by iphonepunker / December 8, 2013 4:28 AM PST

Hey i Just got my razer Naga 2014 last week and was working fine till a friend of mine wanted to try it out on his machine. when i got home it was driving me nuts that everything was working but the lazier i new it was that because the scroll wheel was dim so I figured out that in the razer synapse 2.0 there is a option to calibrate to mouse pad or your razer mouse pad i chose my mouse pad which is a razer galiathus speed edition and everything was up and running again so im not sure if that will fix your issue but its worth a try

Popular Forums
icon
Computer Help 51,912 discussions
icon
Computer Newbies 10,498 discussions
icon
Laptops 20,411 discussions
icon
Security 30,882 discussions
icon
TVs & Home Theaters 21,253 discussions
icon
Windows 10 1,672 discussions
icon
Phones 16,494 discussions
icon
Windows 7 7,855 discussions
icon
Networking & Wireless 15,504 discussions

REVIEW

The most beautiful phone ever has one wildly annoying issue

The Samsung Galaxy S8's fast speeds and fantastic curved screen make it a top phone for 2017, but the annoying fingerprint reader could sour your experience.