Question

Random freezes on new PC build

I recently built my own custom pc with Ryzen 2700k, however since the start it freezes randomly. I have changed the Motherboard, graphic card, SSD and power supply and it is none of them. I am really clue-less.
Settings for CPU on motherboard are all stock, so voltages etc are all on automatic and they are in sensible range. Even when I don't use XMP profile for my RAM it freezes so it shouldn't be ram either..

What happens is: it randomly freezes in applications like league of legends or firefox. It also happens more often when I use VPN, the application doesn't matter, I tested windows built in and vyperVPN. Also when I don't login into windows it also ALWAYS freezes. For example if I go eat something ~30 minutes.

The kind of freeze: Just screen freeze, no hanging sounds/ no sound at all. I don't get a BSOD too so I can't debug it.

System specs: https://valid.x86.fr/1zp1lg

I hope someone has more experience about these kind of problems.

Post was last edited on March 25, 2019 10:02 AM PDT

Discussion is locked
Answer
Follow
Reply to: Random freezes on new PC build
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Random freezes on new PC build
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Answer
More details???

A lot more details would be helpful... like the model of motherboard and PSU, detailed specs like RAM amt, ddr type, graphics card model etc.

but from what I gathered so far its a possibility of a RAM issue. Open tase manager, select RAM and see how much is allocated to system reserved. (shouldn't be more than 1 GB)

You can also check in event viewer, in system tab and see for any errors regarding the freezing.

- Collapse -
Answer
Only your newest tech would write it's not the RAM.

I'm not writing what it is either as I'm not there to check out if the BIOS is current and more. Some motherboards just are terrible and you RMA it for another model.

Try the motherboard and RAM noted for the Ryzen builds at https://www.reddit.com/r/PCMasterRace/wiki/builds

Do not select your own CPU, board and RAM. Copy what thousands are building. Unless you like finding out what's troublesome.

- Collapse -
Memtest reveal

I tested my RAM upon receiving, it was fine. But now I just got skeptical and tested it for an hour and already got some errors... Not sure if its the RAM related but it looks like the addresses don't match. Which could be a RAM issue I guess?
See this image

About the MOBO + RAM combo, my ram was selected from the supported list of Gigabyte. I think I spent at least 8 hours on the combination CPU + MOBO + RAM.
https://valid.x86.fr/1zp1lg

also @JayTheTechGuy ,if you mean hardware reserved it is 54 MB.

Post was last edited on March 25, 2019 9:11 AM PDT

- Collapse -
MEMTEST is

If MEMTEST fails, then it failed. If MEMTEST passes you can still have memory issues.

I am NOT going to repeat the Internet about this area. Also I think you are asking me to explain addresses and data on that screen. I'm going to write that it shows the address of the failure then the data it expected and then what was read.

ANY MEMTEST FAILURE IS A FAIL!

You did not tell me the BIOS was current. Some folk skip that and lose months of time over that. For RYZEN and AMD systems I consider this NOT OPTIONAL. I've worked far too many over the years and will return the system to the client if they deny us the work to update the BIOS. Some are adamant about this and we can't waste time on that.

Try it with the BIOS current, the BIOS defaults and be aware that some motherboards just never work right. This is why my view is narrow and I stick with the PCMR boards. You are free to do whatever you want and learn why PCMR and folk like me are such pains.

- Collapse -
I guess its a RMA

Everything is updated, I have the latest bios and drivers. Tried different combinations of them too, but my question is an error in memtest a memory failure or CPU?

One of my backgrounds is in Electrical engineering, so I know a bit about computer architecture, compilers, memory yadayada. However, a adress failure doesn't tell me its a RAM issue per se...

- Collapse -
I'm not seeing an address failure.

I'm reading that at address ..... the data expected was .... and data read didn't match.

The failure can be BIOS related. BIOS settings, a CPU or CPU socket issue or just a motherboard that has issues and they are still working it out.

I'd hinted the BIOS SHALL BE CURRENT and changing the motherboard is what I do last. Motherboards do not arrive with current BIOS versions so you as the builder get to deal with that.

-> READ https://www.reddit.com/r/Amd/comments/8r8f5k/gigabyte_x470_fail_to_run_ram_at_xmp/

It is a nice overview of XMP profiles and more.

- Collapse -
But my post excludes those

Lets repeat what I have posted, my bios is CURRENT, as well RAM is NOT on XMP settings and I still get the same freezes.
to quote: "I have changed the Motherboard, graphic card, SSD and power supply and it is none of them. "

However, indeed I misread and the data appears to be corrupted, atleast one bit. Tricky issue as it looks like only the first few LSB are written.

Post was last edited on March 25, 2019 10:18 AM PDT

- Collapse -
Read my link to the Reddit post.

I did not check your BIOS version and waited for you to write you did.

Go read that Reddit as it appears to be a version of your mainboard and try the settings that appear to be working for them. If that fails, you are looking at a RMA. BUT HERE'S THE THING. If you get the same board you may repeat your findings.

These builds are known to be troublesome. I do not like seeing them because it can be too much for the builder to figure out the memory settings. In my opinion the system SHALL function with defaults or it's going to be trouble for years EVEN IF you find setting the BIOS fixes it. If you can fix it with BIOS settings then in the years ahead someone, maybe the new owner or you resets the BIOS and has forgotten the settings. Or a BIOS comes out and you get to repeat all this.

Yes, not a fan of such builds. They end up costing a lot of folk more money at repair counters. This is why I give the nod to PCMR often.

-----> BEFORE the RMA. Try a single stick in each slot and see if that helps. Sometimes you get a bad stick or slot. All the above in this thread does not tell us what it is but the one hope I have here is the RAM is OK but the BIOS needs tweaking as you read in the Reddit thread.

- Collapse -
TL;DR ?

Test each stick on its own. Use the settings from the Reddit discussion.

- Collapse -
Memtest

You must get memtest to run error free.
Setup your ram so as to run single channel....test with memtest
If it still fails use one stick of ram and walk it through each slot....test with memtest.
If that fails use the other stick of ram....test with memtest.

I see you have the latest bios.
Do you have the latest chipset drivers?

- Collapse -
Good idea but.

"MemTest86 is a stand-alone program that does not require or use any operating system for execution" so drivers weren't on my list yet.

Post was last edited on March 25, 2019 12:13 PM PDT

- Collapse -
The chipset question

Had nothing to do with memtest.
The entire area of bios/drivers goes over the head of most users.

- Collapse -
You're right.

Memtest can't have failures or you'll have a bad day.

- Collapse -
Answer
Testing

Currently tested with DRAM calculator for Ryzen, I got hundreds of errors in span of minutes. Tried all settings the program gave, so thats a no go.

It should be noted my X470 gaming 7 + DDR4 MODEL NUMBER is QVL noted and supports the XMP profile according to gigabyte.

I tested with 2933MHz and still got errors, so I have no idea :/
I also tested on 2133 MHz which is the non XMP profile, just JEDEC and also no cigar got also errors.
Next up is testing with single sticks, and check for bad stick. If that doesn't work either I will RMA it I guess.

Post was last edited on March 25, 2019 1:39 PM PDT

- Collapse -
The XMP is for Intel (I think you read that in my link above

And for AMD boards it's well known that it's hit and miss.

Test one stick at a time. Could be a bad stick in the mix.

- Collapse -
Answer
Win10 freezes with Ryzen CPU

Hey.

I had random freezes with my Ryzen CPU as well. 2700X and Vega 56 GPU. If you are experiencing issues with some Games with Launchers or Google Chrome not working also, then the problem is caused by Cryptsvc.dll. Took me a whole lot of time to figure it out after freezes didn't go away, even with a fresh Win10 install.

To find out if this is the issue, create a bat-file on your desktop with the following content:
SC Stop CryptSvc

save it as Crypt.bat and run it as administrator. If this fixes the crashes for a while (service will restart itself), you can go ahead and do the following:

Set the Cryptographic Services under Windows Services to run locally. Right click on preferences of the service, set it to run in local mode and save it. After this, go to registry (regedit in command prompt) and set the value "EnableLUA" in "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System" to "0".

That's it. Will mess a bit with your windows User Account Control, but it's the only possible fix, except you want to keep the batch-file solution as permanent solution.

CNET Forums