karma,

I assume you're talking about the drop down "Address" bar in Internet Explorer?

Turning off "Autocomplete" should do it. In addition to the procedures you've already performed...Check these settings. While in IE, click on "Tools" in the upper left, choose "Internet Options", choose the "Content" tab, then select the "Autocomplete" button. UNCHECK the box next to "Web Addresses" and anything else you want. Click on "OK", Apply, OK, etc.

Hope this helps.

Grif