..have you installed all the service packs for your version?

Are you creating the text in a text box? If so, using my Publisher 2003 SP3 as an example, I can get two text boxes to overlap correctly as long as a turn off all "Text Wrapping" in both boxes and make sure one is "Sent to Front" and one is "Sent to Back". I click once on the back text box, then click on "Arrange" in the upper left corner, choose "Text Wrapping", then select "None".. I do the same for the front text box.

Hope this helps.

Grif