Peripherals forum

General discussion

PS/2 mouse, Windows vs. Linux

Hello, I have a PS/2 optical Logitech mouse that works in Linux (Ubuntu 8.04), but not in Windows (XP Pro SP2). It's plugged in when I start the computer, so what's the deal?

I've attempted the following to get it to work:
*Check Device Manager: no yellow or red devices
*Try to use "Add Hardware" - it found nothing
*Tried to use "Add Hardware" manually - no mouse in the selection


Suggestions on getting the thing to work? It's slightly annoying when using some programs to not have a mouse.

Discussion is locked
You are posting a reply to: PS/2 mouse, Windows vs. Linux
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: PS/2 mouse, Windows vs. Linux
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
If you or anyone EVER installed...

In reply to: PS/2 mouse, Windows vs. Linux

Collapse -
Logitech drivers

In reply to: If you or anyone EVER installed...

No, I haven't used the Logitech drivers, it was a mouse I received from a friend after my last mouse stopped working consistently (I think it had a short in the wire). I just shut the computer down, plugged the mouse in, and turned the computer on. I can't remember, but I think the first time, or first couple times, the mouse may have worked in Windows ... though maybe not.

Aside from Logitech drivers, any other suggestions?

Collapse -
Spyware.

In reply to: Logitech drivers

The same filters can be installed by spyware and other maker's drivers. It's a common failure and unless the PS2 port or mouse is dead which your Linux test shows it's not then this is the registry tree I check then I delete that and the files it points to. I consider this just above average user repairs so not everyone survives this one.
Bob

Collapse -
wow, it works without doing anything

In reply to: Spyware.

So ... I booted back into Windows today, expecting the PS/2 mouse not to work, or my wireless mouse to work (dead battery, I thought). To my surprise, they both work, and I haven't done anything to actually fix the situation.

But hey, I'm not complaining. Grin

Just figured I'd let you all know that this computer is magical, or something. That, and that it works again.

Popular Forums

icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

SMART HOME

This one tip will help you sleep better tonight

A few seconds are all you need to get a better night's rest.