Windows Legacy OS forum

General discussion

Programs stay running in memory after closing, slow start up

by pmachete / December 1, 2008 1:10 PM PST

My computer could run the most cpu and graphics intensive programs on highest settings 2 weeks ago. Now it takes me half an hour to google something.

Picture example of the types of things that happen to me about every 30-60 seconds (that is, I stall for 2-5 minutes, then everything runs free and normal for 30-60 seconds, till another 2-5 minute stall): http://xs234.xs.to/xs234/08491/why942.jp...

Programs take 2-5 minutes to start up as well (firefox). I notice when watching them in taskmanager, they show up as soon as I click on them, however instead of starting off at 100k memory usage and going up to say a standard 120,000k in a second or two, they start off and grow super slow. The seconds turn to minutes. 1 minute after opening firefox is at 7k memory usage. Then 3 minutes, it's at 90k, then it opens after another minute or two.

I've waited for 30 mins for a game to load, just staring at a loading screen which used to complete in less than two minutess. I didn't wait any longer, but the point is nothing loads at an appropriate speed.

I ran a virus test, last week. I had 7 harmful files. I deleted them all. But then my computer did not improve at all. I rescanned, the files are gone (they didn't look too scary or serious anyway), but the slowness remains. No spyware, besides tracking cookies which get deleted every once and a while.

I can't think it's a hardware issue because if I wait 20 minutes for the only game i can stand to wait the loading screen out I get smooth same as always great performance. It's just loading things that takes FOREVER.

In that picture example up there i gave: http://xs234.xs.to/xs234/08491/why942.jp... the program highlighted is msiexec.exe...Well I ran that install and it completed at least ten minutes before i took the screen shot. All my programs stay after I close them taking up memory and just doing nothing until i manually end process them.

Sad help?

Discussion is locked
You are posting a reply to: Programs stay running in memory after closing, slow start up
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Programs stay running in memory after closing, slow start up
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
bad picture url extension
by pmachete / December 1, 2008 1:14 PM PST
Collapse -
Suggestions...
by Grif Thomas Forum moderator / December 2, 2008 3:06 AM PST

First, if you haven't used both of the free scanning tools below, please do so. The find and remove a number of types of malware that others don't clean up.

Malwarebytes Antimalware

SUPERAntispyware Removal Tool

If neither of the tools download or install, then your malware infection still remains and you'll need to rename the installer files so they can install correctly. In some cases, you'll also need to rename the program executable after installation, so the program can run correctly.
__________________

After running the tools above, if performance hasn't improved, then try the procedures in the link below to confirm that DMA is correctly enabled on your computer. Be sure to toggle off, then on, even if things look correct:

http://www.microsoft.com/whdc/device/storage/IDE-DMA.mspx

If performance has not improved, then please run a complete "Error Checking/Chkdsk" using the instructions in the link below:

How To Run 'Error Checking/Chkdsk' On Win2000/XP

If that doesn't help substantially, then it's possible there are damaged system files.. In such a case, try reinstalling SP2 or SP3 for Windows XP, depending on which service pack you're currently using. Use the full downloadable installer file from the link below.. It should repair Internet Explorer and replace some of the potentially damaged system files.. The full SP2 or SP3 installation files are large (316 MB) so you'll need a broadband connection to download it.. (If your machine won't perform the download, it's also possible to download it on a friend or family member's computer, then burn it to a CD, then run it on your computer.)

Windows XP SP2 Download
http://www.microsoft.com/downloads/details.aspx?familyid=049C9DBE-3B8E-4F30-8245-9E368D3CDB5A&displaylang=en

Windows XP SP3 Download
http://www.microsoft.com/downloads/details.aspx?FamilyID=5B33B5A8-5E76-401F-BE08-1E1555D4F3D4&displaylang=en

Hope this helps and let us know how it goes.

Grif

Collapse -
What I noticed.
by MarkFlax Forum moderator / December 2, 2008 4:30 AM PST

In addition to Grif's good advice, I noticed a couple of things in that JPG image.

1] Your Desktop looks incredibly busy. I see Installer.exe files, a Plugin.ini, (what's that?), many .exe files, a .bnk file, wav, mid, mp3 files .jpg files. Are you installing software to your Desktop?

If so, you may want to reconsider your strategy here. Most software installations default to the C:\Program Files folder, and usually that's the best place for them. Music files can be stored in any folder, the My Documents\My Music folder is a good place, but doesn't have to be the only one. The same with image files, in My Documents\My Pictures. Installer.exe files are OK on the Desktop temporarily until the software is installed. Then, as soon as the install process is done, move the installer files to a separate folder, for example I have a folder called Downloads and I move my installer files to there.

Why do all this? You complain your computer is slow, but with all that content on the Desktop, it all has to be loaded into memory at startup and that slows bootup down, and also uses up RAM.

2] Your anti-virus definitions are out of date. That's a sure way to miss the new virus strains that appear every day.

3] I see you use uTorrent. Your choice here, but we see the horror stories all the time in these forums of people using such P2P to download virus infected files that they have not bothered to check meticulously for viruses, and then start losing system performance, files, personal data etc. I won't mention the copyrighted and pirated files that are normally downloaded through P2P. We will not discuss problems caused by those in these forums.

Mark

Collapse -
thank you..but
by pmachete / December 5, 2008 3:14 AM PST

Thanks guys so much

I decided to just buck up and do a fresh reformat and clean install. My new problem is that installing my graphics drivers crashes my computer.

I was having this problem before. See, my gfx card had no problems (ATI HD radeon 4850) on my original install. When my system started getting slow (which sparked this thread), I tried reinstalling XP twice without reformatting, just installing into a new windows folder. In both cases, installing my graphics drivers crashed the machine. I figured it was an issue with multiple OS file folders, but right now I have a clean HD and I still get it. Here is what happens:

I install the drivers from the cd that came packaged with the card, then the setup prompts the restart, and when I restart I get a blank screen and no video signal as soon as XP's start up screen loads. I install the drivers from their website, same thing. I use Windows automatic install, same thing. I also tried Omega drivers, third party drivers, but windows doesn't even recognize that they are installed.

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

CNET FORUMS TOP DISCUSSION

Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?