Windows Legacy OS forum

General discussion

Procedure Entry Point Not Found.....

by flistr8 / November 25, 2004 6:16 AM PST

Happy Thanksgiving, Everyone.

I performed a system restore to a date after the date I downloaded SP2 for Windows XP Home Edition on my Dell 4600. On reboot, I got the following error msg:
The procedure entry point AssocGetPerceivedType could not be located in the dynamic link library SHLWAPI.dll.
After enter, I get: The logon user interface DLL msgina.dll failed to load. Contact system administrator to replace dll or restore original, retry. This loop is all I can get. Now I am trying to do a repair reinstall using Dell's OEM disc with Dell tech support. The process goes as far as 32 mins remaining during setup and stops. Dell says I must do a reformat. Is there not another repair option available?

Thanks in advance for your help.

Discussion is locked
You are posting a reply to: Procedure Entry Point Not Found.....
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Procedure Entry Point Not Found.....
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Re: Procedure Entry Point Not Found.....
by Yew / November 25, 2004 7:44 AM PST

Any repair options would be considerably more work than reformatting. Ask anyone who's tried to sort out a DLL problem with Windows, and I'm sure they'll agree.

Besides, you shouldn't be running a pre-SP2 version of XP anyway. There are a number of security fixed ONLY in SP2, some of which are actively being exploited. Only XP SP2 users are protected, so it would be folly to leave yourself open to attack like that.

Collapse -
Re: Procedure Entry Point Not Found.....
by flistr8 / November 25, 2004 8:04 AM PST

Thanks for responding. Let me be a little more clear. XP was working normally after the SP2 download except for the WordPerfect 11 program, it stopped loading. So I tried a system restore prior to the date I downloaded SP2 and everything, including WP11, worked fine. It was when I tried to restore to a date after the date I downloaded SP2 that the error msg began. Now, I just want to get the system back up. I would use the SP2 again.

I may need information on how to save info on my hard drive without being able to boot Windows. Can I use another computer to boot up and then just access the info files on my corrupt system, save them to the other computer, reformat and then bring the files back?

Many Thanks

Collapse -
Re: Procedure Entry Point Not Found.....
by David Chan / November 25, 2004 8:45 AM PST

Yes. You can easily remove the HDD from the DELL PC. It slides out on the green plastic rails from the cage.

Then attach it to another PC which has to have XP or W2K installed so you can retrieve your files.

Or you can boot with KOPPIX CD (Linux OS) and copy over your files to CD-RW.

The likely reason your repair installation failed is because your original DELL XP CD had SP1a while your current XP has SP2.

The DELL XP CD allows you to create several partitions on your HDD so this is a good opportunity for you to create a C & D Drive.
Then setup XP + Programs on the C Drive and store all your data on the D Drive.

Next time your XP crashed your data is quite safe on the D Drive.

But you must always backup your data onto CD-Rs as your HDD can also quit on you!

Collapse -
Re: Procedure Entry Point Not Found.....
by flistr8 / November 25, 2004 10:47 AM PST

Thanks, David. I would add that Dell tech support walked me through a delete procedure to get rid of SP2 prior to the repair install. Would it help to do it again? Perhaps you know of a link that would take me through the steps.

Thanks for the partition suggestion. I will definitely do that.

Collapse -
Re: Procedure Entry Point Not Found.....
by David Chan / November 25, 2004 11:27 AM PST
Collapse -
Re: Procedure Entry Point Not Found.....
by flistr8 / November 25, 2004 11:38 AM PST

Many Thanks!

I'll let you know how it works out.

Collapse -
(NT)Good luck & Keep us posted.
by David Chan / November 25, 2004 11:44 AM PST


Collapse -
Re: Procedure Entry Point Not Found.....
by flistr8 / November 27, 2004 4:30 AM PST

Hi All

Success has been achieved but unfortunately, the reason seems rather capricious. While going one last time through the drawer with all my program cd's, I stumbled upon the actual restore disk Dell included with the computer. They had recently sent me another one because I couldn't find the original. When I tried to boot with the new disk, the OS loaded smoothly with the exception that Device Installer Error occured for SDHost and for Bluetooth. Otherwise, everything appears normal.

My next purchase will be a second hard drive to act as a repository for all my backup when, not if, this happens again.

I'm very grateful for the help given on this website.

Collapse -
Glad to see you've succeeded! (NT)
by David Chan / November 27, 2004 9:32 AM PST


Collapse -
It's a windows update
by rescuefire / July 13, 2006 9:04 AM PDT

I have found after much research that numerous folks are getting this "The Logon User Interface DLL Msgina.dll failed to load. Contact your system administrator to replace DLL or restore the original DLL" error and it is due to a recent Microsoft update. GRRRRRRRRRRRRRRR

MS suggestions don't work although you can view them here

I personally tried a few things:
1. F8 into the restore screen and tried "Last know good configuration" - didn't work

2. Tried to boot from XP Pro CD, skipped the "repair" and went to the install screen, then picked repair at that point - didn't work

3. Tried the regular repair once - didn't work.

4. I am in the process of re-installing and have gotten many dll errors. I guess my next step will be a total reformat. UGHHHHHHH

Popular Forums
Computer Help 51,912 discussions
Computer Newbies 10,498 discussions
Laptops 20,411 discussions
Security 30,882 discussions
TVs & Home Theaters 21,253 discussions
Windows 10 1,672 discussions
Phones 16,494 discussions
Windows 7 7,855 discussions
Networking & Wireless 15,504 discussions


The most beautiful phone ever has one wildly annoying issue

The Samsung Galaxy S8's fast speeds and fantastic curved screen make it a top phone for 2017, but the annoying fingerprint reader could sour your experience.