Windows Legacy OS forum

General discussion

Problems with Windows update...

Hey everyone. This is a pretty vague issue, so forgive me. I've been researching this for a couple of days on my own though and have gotten nowhere...

System info - Compaq Presario 6430nx w/ AMD Athlon XP 2600 running WinXP SP1. This is networked through a Linksys router to my second PC for internet, printer, and file sharing.

I ran the Compaq system recovery a few days back, which I had never done before on this machine, and just recently noticed that the recovery must have rolled me back to SP1 and IE6. Not sure why my automatic update didn't notify me, but I proceeded to MS updates site anyway to get... well... updated!

Microsoft scanned my machine for the latest version of their update software, then asked me if I wanted to install the new version of Windows update. I agreed, and all went well until the install got to the registration portion. Registration reached 100%, but never managed to actually complete (it didn't proceed to the actual updates page). I gave it a good hour, and then decided to restart and revisit the site. Now MS Updates opens and hangs on the initial page ("Checking your computer for the latest version of updates software"). I also noticed that windows firewall is not running. When I try to open it in the CP I get the message "Firewall settings cannot be displayed because the associated service is not running...", and Security Center does not show Firewall, Updates, or my AVG antivirus options. It just displays "Manage security settings for:" followed by empty space. I've tried rolling back and retracing my steps, but got the same results.

Is this all due to how I chose to set up networking after the system recovery? I do remember telling it that I receive internet connection through a network router (which is true - two machines in my home office).

Any suggestions? Thanks a million...

~J

Discussion is locked
You are posting a reply to: Problems with Windows update...
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Problems with Windows update...
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
My Compaq computers had a trial AV Suite

In reply to: Problems with Windows update...

which reinstalled when the Compaq recovery system was used (please note I did the recovery system about 6 years ago and Compaq/HP may not do it the same way anymore). This had to be removed before installing the AV program I wanted to use. Is it possible that you did not get the Trial version of the AV completely removed and now have the system confused as to which AV to use?

Did you try deleting your cookies, clearing the temp files and then try the update again? Sometimes MS update just messes up. Clearing cookies and temp files may reset it but it does sound like your problem is much deeper.

Collapse -
Try this

In reply to: Problems with Windows update...

Validate your version of Windows

http://www.microsoft.com/genuine/

Re-register the Windows Update DLL with the commands below

Click Start, click Run, type cmd, and then click OK.

Type the following commands. Press ENTER after each command.

regsvr32 wuapi.dll
regsvr32 wuaueng.dll
regsvr32 wuaueng1.dll
regsvr32 wucltui.dll
regsvr32 wups.dll
regsvr32 wups2.dll
regsvr32 wuweb.dll

Attempt to run Windows Update

Also try the Windows Installer link for Non-Vista machines from Microsoft.

http://support.microsoft.com/kb/315346


Rick

Collapse -
Great!

In reply to: Try this

Thanks Rick! Everything's back to normal!

Collapse -
Glad you got it fixed

In reply to: Great!

Thanks for posting back.


Rick

Popular Forums

icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

SMART HOME

This one tip will help you sleep better tonight

A few seconds are all you need to get a better night's rest.