Mirza, if you're running XP Pro you might also want to check local security settings. Type secpol.msc in the run dialog box. In the left pane click Security Options and locate Devices:Restrict CD Rom... in the right pane. Dbl-click it and make sure it's disabled.