Hi.
Since you have already mentioned that you tried forwarding ports to your PC, I will assume you know how to forward ports within the router.

The ports associated with JumiMouse are not explicitly mentioned. However I found the following tip that may help you.

PC should have a different listening port (e.g. 5720 & 5721). Set these in the Jumi Controller & enter the same port numbers in the "Connection Settings" in the Jumi App.

Finally forward these ports in the Router.

I hope that works.
Take care.