Question

Problems Using NET Framework

Apr 3, 2018 11:45PM PDT

I was running MS NET Framework 3.5 smoothly under Windows 7. For no good reason, I decided to update to a more recent version. That’s when all my problems began. I now can’t open some key programs that use NET Frmk to work.

I’ve removed NET Framework a number of times with an uninstaller. As far as I can tell, I purged all files and registry entries. I’ve done this in Safe Mode and Normal Mode.

I tried installing older and newer versions. Always problems. I now have v4.5 installed.

- When I start some programs, I get a message that NET Framework will not load. Other times, I get a .NET Framework Initialization Error [Please
set registry key - HKLM\Software\Microsoft\.NETFramework\InstallRoot to the .NET Framework install location]. I have entered this into the registry manually, but no luck.

- I have tried turning on the feature in Control Panel. I get a message that “An error has occurred. Not all the features were successfully changed.”
- If I check ‘Services’ in MSCONFIG, it shows the 64 & 86 versions are both Stopped.
- I have tried “NetFxRepairTool’, but it “is unable to resolve the installation issues”.
- I ran “NetFxSetupVerifier” and it was also unsuccessful.

Any suggestions as to how I get back on track?

Regards,
John

Windows 7 SP1 (64 bit)

Discussion is locked

Follow
Reply to: Problems Using NET Framework
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Problems Using NET Framework
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Clarification Request
I did run into this on a client a few years back.
Apr 6, 2018 4:39PM PDT

They were under the misimpression that Net 4.0 was a newer version of Net 3.5. Sorry no. I'm not going to reproduce the web here.

If you need 3.5, then you install 3.5.

- Collapse -
Answer
Also getting same problem
Apr 4, 2018 6:00AM PDT

hi buddy...im also facing same problem with my and not able to complete my work with my newly build site Routerlogin Net


Note: Moderator disabled link as off topic. No site promotion allowed here.

Post was last edited on April 4, 2018 6:51 AM PDT

- Collapse -
Answer
Have You Seen This?
Apr 4, 2018 10:02AM PDT

See the fix in the link below. Although your computer is Win7 and the other is Win8, the install location should be the same. I don't have a Window 7 machine to check right now but Windows 10 shows the same registry entry as mentioned in the article.:

https://www.download3k.com/articles/Fixing-Please-set-registry-key-HKLM-Software-Microsoft-.NETFramework-InstallRoot-to-point-to-the-.NET-Framework-install-location-error-on-a-64-bit-Windows-PC-01947

If this doesn't get it done, then your best bet is to perform a reinstall of Windows 7.

Hope this helps.

Grif

- Collapse -
Problems Using NET Framework
Apr 5, 2018 10:34PM PDT

Thanks for replying. As I said in my initial post, I already tried the suggested registry fix that the article recommends.

I know that the best option is to wipe my drive and start fresh, but that's painful.

Does anyone have any other ideas?

- Collapse -
Answer
.Net
Apr 6, 2018 9:29AM PDT

What happens if you start these services?

- Collapse -
Problems Using NET Framework
Apr 6, 2018 4:36PM PDT

Please check my original post.

CNET Forums

Forum Info