I would try turning the ASC feature off and changing the audio mode with the Dolby Pro Logic II button on your remote. I know if its in "Stereo" mode the rears will not work. After you find a setting you like you can turn the ASC back on.