The answer to your problem depends on whether the cause is software (system settings or drivers) or hardware (actual usb ports themselves).

It always helps to specify the operating system being used.

All work done as administrator only.

For the former, depending on your operating system (say XP Home 32-bit SP3) check Device Manager and open all instances of usb devices listed. What we are looking for is a setting in 'Power Management' Tab after right-clicking 'Properties'. Untick the box for "Allow the computer to turn off this device to save power if it is checked off. Close the dialog box by clicking OK.

Repeat for all usb devices listed with the "Power Mangement' Tab. Some will have this listing and some will not.

This step alone may solve your problem. A caveat is that the power used by these devices can drain your battery sooner when running the laptop w/o ac power cord.

Wireless mice can be kind of tricky to fix. Try uninstalling the program that came with the mouse, rebooting, and then use the install cd to reinstall the needed drivers. If it is Logitech, you would use the Logitech cd.

For the latter, if it is a hardware issue, and re-installing the driver does not help, it is possible the port(s) you use is (are) defective or broken. To inspect, look inside the ports themselves (w/o opening the laptop case) for broken parts or broken insulators or plastic. It is also possible the usb port itself has broken the connection it has with the motherboard. This is more likely to be the case if the port moves excessively when the usb receiver is inserted or removed.

Try using a PS2 mouse and always seat and plug in or remove only when the computer is off. (PS2 devices only)
Check in Device Manager to be sure PS2 mouse is enabled, if not, check in the system bios to enable it. Reboot your laptop to get into the bios, usually F1 or F2. Begin tapping the key before the operating system logo appears and while the Dell logo is still showing. Be careful here, only make the one change to the PS2 mouse port if it is disabled in bios save and reboot.

Does your touchpad still work?

Let me know how you get on.

mchainmchain