Computer Newbies forum

General discussion

Problem with my WesternDigital 160GB Passport (black)

by myncknm2 / February 15, 2008 9:27 AM PST

When ever i connect my WD 160GB Passport Portable (black) I am unable to access it through My Computers, while the device manager does. I am running Windows Vista on a HP Pavilion DV6000. The same thing happens when i connect it to a HP Desktop running Windows Vista (media). Also, I was able to access it before. Any advice?

Discussion is locked
You are posting a reply to: Problem with my WesternDigital 160GB Passport (black)
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Problem with my WesternDigital 160GB Passport (black)
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Kind of same...
by Dawg Monitor / February 16, 2008 3:11 AM PST

Sometimes I leave my WD(Same as yours) and decided to go to My Computer, it doesn't load up but when I hear a clicking sound from it, it loads up. Maybe if you wait for a few moments(Maybe a minute) then it will solve the problem. Also, I found out using a extension cord for my USB can cause problems.
Wolf

Collapse -
WD Passport 120 GB
by Parsifal1973 / February 16, 2008 2:49 PM PST
In reply to: Kind of same...

I plugged the passport into my desktop, it did not work. I plugged it into the other USB port; it did not work... I plugged it into the back USB Ports, one by one; it still did not work. Plugged it into my laptop running Vista Home Premium... It worked (after the usual installation things that one must do with Vista --> system 32 anyone). Went to my friend's house, plugged it into his system, IT WORKED INSTANTLY!! (runs XP Pro just like my desktop)

Got home all pissed and went through the same steps on my desktop, the thing still would not work! I was about to chuck it, since I need to be mobile with it from desktop to laptop to work etc... I then read this post and others like it. I plugged it with the 2 inch cord only (just like at my friend's and on my laptop)... IT WORKED IMMEDIATELY!!!

I tried it with a longer cord, the more powerful one which came with my Blackberry, it did not work. I tried it with many other USB cables I have, different lengths, thickness blah blah blah,IT DD NOT WORK. At this ppoint I can only say ***! It works with the short 2 - 3 inch cable the thing came with ONLY!!!

I get my exercise bending over to plug it at home and at work... Thank you C-Net for having useful forums....

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

CNET FORUMS TOP DISCUSSION

Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?