Samsung forum

General discussion

Problem with Internet Setup with LED Series 7

by ramsdesk / August 15, 2009 11:14 PM PDT

I bought a Series 7 Samsung LED TV recently. I am trying to setup the LAN and hence the Internet Connectivity..

I am using Netgear WiFi Router with Broadband connection. My desktop is conneted via Cable and my laptop is via Wireless.. both working fine.

I connected the LAN port in the TV with one of the ethernet ports on the router using a LAN cable. I also set up the Network in the TV with 'Manual' and input the ip address as below

The Network test showed all were right..

But when I pressed the 'Internet@TV' button in the remote, the 'Connecting..' message came but errored out with 'Service not supported'.. Not sure what this means.. nor am I sure when this setup is correct.

Please help.

Discussion is locked
You are posting a reply to: Problem with Internet Setup with LED Series 7
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Problem with Internet Setup with LED Series 7
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
by _jr_ / August 16, 2009 1:42 AM PDT

Looking at your IP addresses, my first guess is that the DNS entry is wrong.
Even though Network Test went through OK, your router is not a DNS server, and your TV will have trouble getting out of LAN.

DNS IP has to be a *real* IP. In your Router setup (, look for DNS or DNS 1 field. Usually under Status (although I am not familiar with your brand of routers) or something like that. If you have DNS 1 and DNS 2, take note of the first IP. That's your DNS IP that needs to be put into the TV Network Setup...

Hope this helps,

Collapse -
Didnt help
by ramsdesk / August 16, 2009 11:50 AM PDT
In reply to: DNS

I tried as you suggested.. but no help.

There is also an 'Auto' setting in the TV which is supposed to detect the Network connection.. the Network test on the TV also seems fine..

But when I press the 'Internet@TV' in the TV, it shows 'Connecting..' but eventually errors out with 'Service not supported' message.

Interestingly, the 'Attached Devices' link in the Router setup shows the TV's MAC address which means it is connected fine..

Pls help.. Any Samsung Technical Engineers???

Collapse -
Didnt help
by Samsung_HD_Tech Samsung staff / August 17, 2009 6:17 AM PDT
In reply to: Didnt help


Is it possible that there's a firewall or added security settings enabled on the router? I'm not familiar with the "Service not Supported" message, and I'm going to see if there's something one of our specialists might be aware of.


Collapse -
by DimitrisKS13 / August 17, 2009 8:11 AM PDT
In reply to: Didnt help

Same tv, similiar ip design as you, haven't tried Internet@TV but the message that you get doesn't seem to have anything to do with the IP configuration

I also have a WiFi Netgear router. So, suggestion, opening up the port in the routers firewall?
I'm not talking about port forwarding or anything, just making sure the port that the TV uses can be routed through netgear

Collapse -
by ramsdesk / August 17, 2009 11:03 AM PDT
In reply to: idea?

There is no firewall setup in the router.. and am able to see the TV ip and MAC address settings in the router setup screen.

Interestingly, am also able to ping to the TV ip ( from the desktop..

I also checked that the LAN cable is working otherwise, by connecting my laptop to the router.. it works. but not in the TV.

Pls help.

Collapse -
by DimitrisKS13 / August 17, 2009 11:18 PM PDT
In reply to: Nope

Pinging the TV and seeing the MAC have to do with your LAN.
For example, are you able to stream videos from the PC to your TV using DLNA?
I believe that you can, your LAN seems fine, the problem is with WAN, with what happens when you are trying to access the "outside world"
My LAN is working ok at the moment so I'll try accessing Internet@TV services in a couple of hours to see what happens for me and come back with more feedback

Collapse -
by DimitrisKS13 / August 17, 2009 11:25 PM PDT
In reply to: networking

On another note,far fetched but worth a sho, are you sure the gateway IP(that's the router IP, not the desktop) is, as it appears by the info that you provided in the first post??
If this is wrong, then you might have the problems due to routing misconfiguration

In any case, the presented error seems to me as not network-related but service related

PS. Can we edit our own posts?I don't want to write multiple posts every time I forget something

Collapse -
by DimitrisKS13 / August 18, 2009 4:33 AM PDT
In reply to: forgot

Ok, got news, tried the Internet@TV button, although I stopped my country settings missing, I got all the updated downloaded and installed and accessed the widget page so it's safe to assume that the feature works, so I guess it is something on your network/service configuration

Collapse -
I am getting "Service Not Supported"
by samali786 / September 2, 2011 4:29 AM PDT
In reply to: Didnt help

My Internet@TV was working until today when I started getting "Network interference.." message, I did the factory reset and now I am gett "Service not Supported"... And help will be highly appreciated.
I have tried the options given in this thread..
Pls help.......

Collapse -
Also be sure of what country this is in.
by R. Proffitt Forum moderator / September 2, 2011 5:42 AM PDT

I read reports this does not work in some countries. There appears to be some confusion as they fix it to block a country and no one tells you they fixed it.

Collapse -
I am getting "Service Not Supported"
by Samsung_HD_Tech Samsung staff / September 5, 2011 11:52 AM PDT


Collapse -
connection problems
by buffet8495 / June 17, 2011 10:57 AM PDT
In reply to: Didnt help

had the same issue. i wen into options and selected factory reset and everything worked fine.

Collapse -
Same problem here
by neltis01 / September 7, 2009 8:59 PM PDT


i have exactly the same problem. Slightley stranger: 6 weeks ago it worked. Then i went on a prolonged holiday and when i come back, it doesn't work anymore!

My network setup:

Cable modem - switch 1 - (wireless) router - switch 2 (connected to the router via a lan cable) - samsung TV

The first switch is only placed to accomodate the feedback cable of my digital TV decoder. The second switch is placed to accomodate both my PS3 and the samsung TV.

The digital TV feedback works fine. The PC's i connect wireless to either one of the switches or the router work fine. The PS3 works fine and can go online perfectly.

I can ping the TV, no problem. I see the TV in my routers diagnostic page, no problem. The network test of the TV works, no problem.

But when i try to go online via the internet@tv button, the tv tries to connect and i get an error "Connection failed due to network interference. Only the Setup menu is enabled.".

Any ideas on what else to try? I tried everything i know, there is only one thing i can imagine: a problem with the internet@tv service that is located at the server side???

There is one other strange thing in my network: the content of my DLNA network hard disk (connected to the router via a cable) doesn't show up on the tv anymore and also not on the PS3. I have had no time however to investigate this any further up to now!


Collapse -
by neltis01 / September 7, 2009 9:38 PM PDT
In reply to: Same problem here

In a small update, i connected the tv straight to the cable modem, still no result, however a different error.

"Unable to connect" (instead of the "network interference occured")

And when i try the network test, it times out on "domain ping". Anybody any idea what is meant by this domain ping? What does it means when it fails?


Collapse -
Network issues
by jw650 / September 8, 2009 12:21 AM PDT
In reply to: Same problem here

Perhaps you have an IP address conflict ("network interference"?) Try resetting all addresses, or use the manual configuration.

Collapse -
Service not supported
by aesanch / December 10, 2009 7:42 AM PST
In reply to: Network issues


I got the same problem. I get the "service not supported" message. I have tried using cable and wireless connection. In both cases I get a succesful conection test, though once I try to run internet@tv I get the message.

Has anyone solved this problem? BTW I have disabled all the firewall settings from my router which is a Linksys WRT54G.

Collapse -
Same problem
by michaeljpconlon / December 11, 2009 6:23 AM PST
In reply to: Service not supported

I'm having the same problem. Has anyone got this resolved.


Collapse -
Samsung tech Department
by aesanch / December 11, 2009 8:20 AM PST
In reply to: Same problem here

I wonder if Samsung technical dept. is doing anything about this issue. I am very dissapointed they have not posted any response!!

Collapse -
Resloved this issue
by michaeljpconlon / December 14, 2009 7:32 AM PST

Hi Guys

I downloaded and installed the latest firmware and it appears to have resolved this problem



Collapse -
Not solved
by aesanch / December 14, 2009 8:36 AM PST
In reply to: Resloved this issue


I tried that a week ago. I have ver 1013 which appears to be the latest firmware update and still having the problem.

Collapse -
Unplug dongle
by michaeljpconlon / December 14, 2009 8:40 AM PST
In reply to: Not solved

Initally it didn't work for me, however I unplugged the dongle and changed my country on the tv to UK rather than Ireland, then plugged the dongle back in and it seemed to work

My only problem now is that there are only three widgets available, doesn't seem to be any sign of the yahoo widgets gallery that was demonstrated in store.

Collapse -
Country change
by aesanch / December 14, 2009 8:20 PM PST
In reply to: Unplug dongle


Where do you change the country? I have gone through every menu and have not found it. The manual does not say anything either.

Collapse -
by svraravind / June 22, 2010 1:36 PM PDT

Purchased a Samsung LED 7 Series Sound Quality is very poor i think it is only 200 watts and also internet is not working. Think we have to buya samsung adapter only for internet to work and costs about 5000 Rs. Think it should come bundled along with the package when some is buying a samsung LED 7 series which is costing in lakhs and neither the support executive explain about the features fully they do not have full knowledge. Today will be going to the shop where i purchased the TV and find out if there is only adapter (usb type) for it work and will post again.

Collapse -
by Xavier21358 / July 18, 2010 5:54 PM PDT

Ok, to start with, I had the same problem as a few hundred people have had here: Samsung LA40B650, perfect LAN connection, Wireless and Cable connections working fine, but for one thing: Connection failed due to network interference, when trying to connect to Internet@tv. And I'm sure you guys have all got into the setup menu to change the infolink type thing. But there's one more step you've missed. I'll go over the whole thing again.

For Europe/Asia users:
Turn TV off (wait till the red light stays on)
Input INFO, MENU, and MUTE from your remote. The red light on the TV should blink each time you press the buttons. After that, press the power button. This should all be done in quick succession.

For US users:
I dont know the combination. Look around and you'll easily find it, no problem.

When the TV turns on, there should be a blue setup menu on the left corner. Enter into the option menu, and change the Medialink option to INFOLINK ON. Right.

Press Return till you get back to the main menu. Go into Control, then Sub-option. You'll see a huge list of options here, but the very last(or second last) option says INFOLINK COUNTRY. Go in that and change it to any country, I chose Vietnam.
NOW WAIT. THERE'S ONE MORE OPTION TO CONFIGURE. In that same Suboption menu, look through all the options till you find INFOLINK SERVER TYPE. Change it from "error" to operating.

Return, then turn the TV off. Turn it back on. You will notice the text font is a little different. Make sure your network options are correct, then press internet@tv. It should work.

I also forwarded some ports, though I don't think it really did much. To do that, visit this site, select your router and open ports 80 to 443, on the IP address of the TV (which you can find in the manual TV network settings) the MAC address is also available during the network test. Good luck everybody.

Collapse -
Problem Finally Solved
by aesanch / December 30, 2009 12:19 AM PST

Well, finally after looking into several forums, I figure it out. My TV came configured for S.America from factory. It is necessary to change this setting from the "service menu", it turns out to be something like the bios configuration in a PC.

The service menu is a tool employed by Samsung techs for special configurations. I must warn that entering into this menu will void your warranty. Also, any change in this menu can severly damage your TV. So it is better if you just change what you need and nothing else.

According to my search in forums I found two ways of enetering into the service menu, from which only one worked with my TV. Apparently TVs manufactured for Europe/Asia use the following sequence of key pressings to enter the service menu,

Turn TV off
Press Info
Press Menu
Press Mute
Turn TV on

For America, the key sequence is,

Turn TV off
press mute
press 1
press 8
press 2
Turn TV on

The TV will turn on with a menu on the left side. I have to insist that any bad change in this menu can seriously mess your TV, so be cautious!! (use the up and down arrows to navigate and ENTER to enter into an option. Use the left and right arrow to select within options to change.

Once in the menu

Go into "Options"
Change Medialink Type = America
Press return until you reach the main menu
Go into "Control"
Go into "Sub Option"
Change infolink Country = to the country you wish except for NONE
Turn TV off, turn TV on

Press Internet@TV and voila.

Collapse -
samsung tv 40" 8000
by / January 13, 2010 3:10 AM PST
In reply to: Problem Finally Solved

Hi, everybody, I did finally got on here user names are in short supply,Yep I have also got a problem connecting my tv to a network, i connected a lan cable to the tv from my router D-LINK 2640R, set to auto and domain ping came up with a cross on it, contacted Samsung support they said contact my service provider, TalkTalk,tried that they said never heard of of a domain ping , well I think thats what they said it was a bit of a job understanding them did try again next day spoke to an another technician he said i need to open some ports no 443 and 80 but he said he did not know how to do it he said tel D-Link so I did, they told me they dont give any support for thet model router, you know that feeling you get when it might be time to throw in the towel, so im a bit stuffed, I would appreciate it if someone could offer advice to resolve this problem. Thanks

Collapse -
wireless dongle and samsung t.v infolink connection
by alyking2 / February 19, 2010 11:26 AM PST
In reply to: Problem Finally Solved

okay the name of my T.V is samsung LA40B650T1R 40"....its beiong used with wireless adapter dongle WIS09ABGN..i have pinged and ensured wireless setup is connected perfectly because i get a tick in all 4 checks of IP, Gateway etc all those are fine but when i try to connect now it tells me "connection failed due to network interference"..i dont know what to do and i paid so much for the wireless dongle?? i am in Malaysia and i did exactly what you requested

"Go into "Options"
Change Medialink Type = America
Press return until you reach the main menu
Go into "Control"
Go into "Sub Option"
Change infolink Country = to the country you wish except for NONE"

still no results and i am sure my internet connection is just fine ....what next ???

Collapse -
wireless dongle and samsung t.v infolink connection
by aesanch / February 19, 2010 8:56 PM PST


Your problem seems different. The solution described is for the problem when you get the message "Service not supported". Your message "network interference" is new.

Will have to look into it.


Collapse -
by alyking2 / March 3, 2010 1:17 PM PST

I have got my LA40B650 working now with info link and widgets but question i have is if i change region in the menu to another country instead of Malaysia or Asia will i be able to get more widgets instead of just the three i have now which are youtube, weather and news?? any work around methods to get more widgets

Collapse -
Let's start a revolt against Samsung !
by Armylax7 / May 8, 2010 9:34 AM PDT
In reply to: Widgets

I too have the same issue. I built my own wireless network and have every possible network device hanging off my network (printers, xbox, MAC, PCs, etc., etc.). Samsung thinks that they can be in the wireless internet TV space and not provide any support. Vote with your dollars ladies and gentlemen....Help them lose market share....this company is not ready for this space nor ready to support wireless users. Send it back. Return it. This is my last reply on the topic...I've already lost my Friday and Saturday. Sending this product back!!!!!!!!! The sad part is Samsung could publish a very quick tech bulletin resolving the issue in minutes. Instead it's a bunch of users trying to solve their problems. I guess it's true. Asian companies make great hardware....horrible at software and integration.

Popular Forums
Computer Help 51,912 discussions
Computer Newbies 10,498 discussions
Laptops 20,411 discussions
Security 30,882 discussions
TVs & Home Theaters 21,253 discussions
Windows 10 1,672 discussions
Phones 16,494 discussions
Windows 7 7,855 discussions
Networking & Wireless 15,504 discussions


Want to see the future of car technology?

Brian Cooley found it for you at CES 2017 in Las Vegas and the North American International Auto Show in Detroit.