HolidayBuyer's Guide

Browsers, E-mail, & Web Apps forum

General discussion

Problem opening some links (slickdeal/cashback links, etc)

by vkw104 / January 27, 2008 2:06 AM PST

Hi everyone,
I'm at my wits end in regards to how I can fix an innocuous but pretty annoying problem. I frequent slickdeals and fatwallet (deal sites) quite often, and I often use the Citi Merchant Network (cashback rewards on your Citicard), but I'm having problems clicking on some links on those sites. It takes me to what I'm told is an affiliate page first, (click-serve, bmpte, etc), and it stalls there. The only way I can open that link is by copy and pasting the link, and manually deleting the first part which contains the affiliate link.

I've read everywhere that it's my hosts file, but I've changed my hosts file back to the default one.
I run Kaspersky and Firefox Adblock, but I've disabled both of those and tried, but it still doesn't work.

This doesn't work on Internet Explorer either.

Any ideas?
Thanks!

Discussion is locked
You are posting a reply to: Problem opening some links (slickdeal/cashback links, etc)
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Problem opening some links (slickdeal/cashback links, etc)
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
reply to: Problem opening some links....
by caktus / January 28, 2008 3:43 PM PST

Try contacting the Webmasters or support teams at the sites regarding the problem. Going directly to the source as you are doing to avoid the problem may actually be providing a more pleasent shopping experience. Because if the Affiliates' sites are not working properly then purchasing through them may also be problematic. And if the Affiliates are not properly maintaining thier sites, they simply may not be reliable.

Charlie

Collapse -
I think it's my computer
by vkw104 / January 28, 2008 3:49 PM PST

Hi,
Thanks for the response. I think it's an issue with my computer more than anything else. For example, there was a deal thread on slickdeals that had over 40 posts saying how great a deal it was, but I wasn't able to open the links.

Collapse -
Try this.
by MarkFlax Forum moderator / January 28, 2008 7:26 PM PST

It may be some temp or Temporary Internet File that is preventing your access.

I would run Disk Cleanup, (Start > All Programs > Accessories > System Tools > Disk Cleanup). When started, Disk Cleanup may pause for a while as it checks your compressed files.

If that doesn't work then go for a more heavy duty file cleaner like CCleaner from http://www.ccleaner.com and allow it to delete all the temp and TIF files stored on your computer. If you install CCleaner, watch out during the install process for any add-ons like toolbars and decline to install them.

Mark

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

HOLIDAY GIFT GUIDE 2017

Cameras that make great holiday gifts

Let them start the new year with a step up in photo and video quality from a phone.