Windows Legacy OS forum

General discussion


by er_paez47 / October 2, 2007 6:53 AM PDT

I just installed a USB Hitachi video camera that has an internal hd and also record direct to a mini dvd integraded to the camera, i just install the software and everything is ok but when i was trying to safely remove as you know from the system tray, i got this mesage "THE DEVICE 'HITACHI DZ-USBHDD USB DEVICE CANNOT BE STOPPED RIGHT NOW. TRY STOPPING THE DEVICE AGAIN LATER., SO i have to shut down the computer cause if i disconnected then i will get a blue screen, also i have and external usb dvd burner wich i tried to do the same and i got the same error, none of these devices show me the tab under their properties to select policies and check for optimize for quick removal, so i cannot use this , also i realized that when i trying to remove the dvd i am not using any application reletaed with it, neither with the camera , probably there are some under the task manager, i tried a few but still get the same error, i am wondering if there is any fix for this, or do i need to upgrade the bios for it, i tried the camera on another computer running win 2000 pro and the removal was ok, but on this win xp pro spk2 machine this is not happening, this machine is a custom machine with an intel celeron 2.6 ghz fsb 533 mhz, 2 gb memory ram pc 3200 400 mhz 120 gb hd, it seem very comomn problem, cause i googled it and a lot of people having this issue, anyone can guide me on this
Thanks a lot

Discussion is locked
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: PROBLEM EJECTING USB MASS STORAGE DEVICE
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
"a custom machine"
by R. Proffitt Forum moderator / October 2, 2007 6:57 AM PDT

Does it work on other machines proper?

A recurring thing I run into are "a custom machine" without current bios and drivers since Microsoft doesn't do this for us.


Collapse -
What I think is they missed a driver.
by R. Proffitt Forum moderator / October 3, 2007 12:48 AM PDT
In reply to: "a custom machine"

I encounter too many "custom" or machines where the person who installs the OS skips installing motherboard and other drivers. They are in a hurry or don't know about such things. They get it to work and move on.

Little things like your issue happen next.


Collapse -
Reply of problem ejecting USB Mass storage
by VISHNU THAKOR / October 2, 2007 2:16 PM PDT

I think your system is infected with virus or spyware. I had the same problem with my pen drive but after formatting my hard-disk, this problem was vanished.

Popular Forums
Computer Help 51,912 discussions
Computer Newbies 10,498 discussions
Laptops 20,411 discussions
Security 30,882 discussions
TVs & Home Theaters 21,253 discussions
Windows 10 1,672 discussions
Phones 16,494 discussions
Windows 7 7,855 discussions
Networking & Wireless 15,504 discussions


The most beautiful phone ever has one wildly annoying issue

The Samsung Galaxy S8's fast speeds and fantastic curved screen make it a top phone for 2017, but the annoying fingerprint reader could sour your experience.