Windows Vista forum

General discussion

Problem connecting to the Internet wirelessly

by RoboChemE / February 26, 2007 11:53 AM PST

I?ve recently upgraded from Windows XP to Windows Vista Home Premium. Prior to the upgrade, the wireless card on this desktop PC was connecting flawlessly with my wireless router.

With Vista, the wireless card also connects to the router, but not to the Internet. Let me explain. In the Network and Sharing Center view, it show that the computer is connected to multiple networks, but the multiple networks are not connected to the Internet. (There?s a big red X between the multiple networks icon and the Internet.) When I click the red X and ask for a diagnosis, it says ?There is more than one active network connection on this computer?.

There are in fact two networks identified below the link diagram that I described above. One is to my private network and the other is to a public network. When I try and disconnect either one, both disappear. Is there a way to get rid of this public network, but leave my private network connection working?

Based on the diagnosis, I think that this extra network is the problem, but could the problem be something else?

By the way, I know the router is working because I can access the Internet wirelessly through my laptop.

Please help me get rid of the ugly Ethernet cable now connecting this computer.

Thanks for your help,

Discussion is locked
You are posting a reply to: Problem connecting to the Internet wirelessly
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Problem connecting to the Internet wirelessly
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
WiFi
by RadarNav / March 1, 2007 11:41 AM PST

Did you try the Connect To optio on the startup menu? YOu may have the Lan instead of the Wan selected.

Collapse -
how do I get rid of the "unnamed network"?
by RoboChemE / March 2, 2007 1:34 PM PST
In reply to: WiFi

I clicked the Connnect To command and saw two wireless network. How do I tell whether they are LAN or WAN?

Collapse -
Public vs Private
by stan1213 / March 2, 2007 8:48 PM PST

I originally had all kinds of problems with wireless & vista & 3 computers. Disable Private in the network sharing center. Allow public only. Public in Vista means that all your computers connect via the same gateway. It has nothing to do with security. Your wireless should be WEP or WPA for that.

Collapse -
how do I remove the private network?
by RoboChemE / March 2, 2007 10:54 PM PST
In reply to: Public vs Private

Thanks for the tip.

Right now, I've got two networks that my wireless card sees. The private network with my network SSID and a public network labeled "unamed network". When I delete either network, both disappear. When I tried you tip and tried to reconnect from scratch, I didn't see any choice of private or public.

I also looked at reconfiguring my wireless router. Again, I didn't see a choice between public and private.

Collapse -
LAN and WAN
by RadarNav / March 3, 2007 7:21 AM PST

If you have not named your wireless router, it will have the name of the ventor, i.e., Compact, Netgear, D-Link. Select that wireless router in the Network setup menu. If you named your router; by changing the default SSID, use the name you used.

Collapse -
Two wireless networks; one has to go
by RoboChemE / March 3, 2007 9:50 AM PST
In reply to: LAN and WAN

Thanks again for your help.

When I connect to my network, I end up with two networks connected to my wireless card. The first is a private network connected to the SSID that I created. The second is a public network called "unnamed network".

Stan1213's suggestion was to delete the private network. When I try to do that, both the private (connected to my SSID) and the public ("unnamed network") disappear. When I try to reestablish the wireless connection, it asks for my SSID and then it recreates the same two networks mentioned above. It never ask if I want a private or a public network. I went to my wireless router setup and I didn't see a choice between a private and a public network there either.

Following up on Stan1213's advice, how do I create a public network that has my SSID's name? Changing the SSID name is no problem by the way.

Thanks,

Collapse -
Connection to two wireless networks - same old problem
by RoboChemE / March 3, 2007 1:53 PM PST

I managed to stumble across the way to change the network from private to public. Unfortunately, I still have the same problem.

Connection to two public networks, one with my SSID and another called "unidentified network". I need to delete the latter without deleting the former. Sigh, this is getting old.

Thanks in advance for your help

Collapse -
Vista network, IE7 and email periodically disconnect
by stodare / March 6, 2007 2:25 PM PST

I'm having similar troubles... I found that I had 3 networks. In the Network and Sharing Center you will find across from the network you're connected to, the option "customise." Select that and you will find the options for "public" and "private" along with the option to delete and merge your locations. I deleted one of the locations that made no sense to me, merged the other network that was identified as the router vendor with the personalized network I created.

Well that merging and deleting worked, but it hasn't cleared up the lost connection issue. For whatever reason, intermittently I lose either my email(Outlook 2002 or Vista Windows Mail) or web browser (IE7) connection periodically, and either have to wait or reboot. Also connected to the network is another computer and Xbox live.

Collapse -
Forget "public" "private"
by stodare / March 7, 2007 1:24 AM PST

The previous suggestion regarding "public" "private" certainly didn't correct my internet connection issues either, in fact it was made worse. After changing the setting from private to public, it wouldn't identify. I had to change back and reboot the system. If you read MS defs in the help section, public is used for public access areas - that certainly isn't what you want in an office/home environment. So back to square one to figure out why I experience a no connection with Internet Explorer or email periodically, even though I have a connection and am receiving packets.

Collapse -
Tried merging the two networks
by RoboChemE / March 9, 2007 11:53 AM PST

Well, I tried merging the two networks, but everytime I tried only my SSID network showed up and the merge box stayed grey (inactive). It didn't matter if both were public, both were private or one was private and one was public.

Please keep you suggestions coming.

Collapse -
same problem here
by Jamesb42 / March 8, 2007 7:03 AM PST

I have the exact same problem. I've been searching around the internet for the last few hours trying to get more information but I haven't found any solutions.

I posted on the linksys forum
http://forums.linksys.com/linksys/board/message?board.id=Wireless_Adapters&message.id=5050
but don't have a reply yet. I doesn't really seem like its linksys's fault anyway. Vista is probably the guilty party.

Right now i'm thinking buying a new router/adapter and resetting up the network might solves things but thats kinda expensive. I don't know what else I can do though.

I couldn't find any information about his on microsofts help sections either.

Collapse -
Power Options
by stodare / March 8, 2007 7:24 AM PST
In reply to: same problem here

What router are you using. I upgraded to the Linksys N, and installed the wireless N adapter. I agree,that this doesn't appear to be a router issue. In fact, this morn upon booting I was receiving packets when I went to the "view status" in Network Center. But I had no internet connectivity for email or IE7. I had to reboot 3 times before that corrected. I finally deleted the connection, and created again. So far this afternoon I haven't experienced an issue (that'll change now I said that) with network connection or IE7/email.

I did find in MS Knowledgebase (believe in Vista networking area) a mention about the power plan in Vista influencing mobile computers with wireless adapters. This isn't a mobile computer, but I thought I'd make sure that I changed the adapter power plan to maximum performance anyway. You can do this in the Control panel select Power Options and advanced.

I have been at this for weeks with no resolve, checking a number of different forums.If you find a solution make sure to post, and I'll do the same.

Collapse -
receiving packets?
by RoboChemE / March 9, 2007 4:56 AM PST
In reply to: Power Options

Stodare,

What do you mean by receiving packets?

Collapse -
Firewall
by gk200852 / March 9, 2007 12:32 PM PST
In reply to: receiving packets?

I had to uncheck the wireless settings in my firewall, then I could connect to my router.

Jerry

Collapse -
Packets
by stodare / March 9, 2007 4:25 PM PST
In reply to: Firewall

I suppose I should have said bytes received. Go to Network and Sharing Center - view status, and it will show you that you are receving from the internet. Which I continue to do , when my browser or email won't connect.

Unfortunately, I wish I had something good to report, but everything I've tried has resulted in failure. In deed, I thought as of my last post that I had resolved my issue, but alas! Tried disconnecting cable modem/router for 30 secs. before booting up this morn hoping that it would reset, but nothing.

So far it doesn't appear that my problem is caused by any firewall. I'm not using Vista's firewall, I have Norton Internet Security 2007, and turned all of it off to be sure it wasn't interfering. However, my intermittent drop of my browser/email happens when the Gateway just disappears from the network list. Every once in a while there is this glitch, and the network flashes very quickly that it found multiple networks, but then it disappears and I'm back to my private network. That began to make me wonder if somehow either the bluetooth keyboard/mouse might be interfering, or the cordless phone on the desk, or perhaps the Verizon broadband EVDO system to my pda, that it senses these signals as another network and is causing my glitch? Maybe I'm really grasping now...

Jerry, what settings did you change/located where? Are you using Vista's firewall?

Collapse -
Misery loves company?
by RoboChemE / March 10, 2007 9:09 AM PST
In reply to: Packets

Somehow it's somewhat reassuring that others are in the same boat that I'm in.

The only reason why I upgraded to Vista was that everything was running slow as molasses in XP. I'm tempted to switch back to XP, but I have to remind myself how slow things were.

It amazing how many things don't work in Vista. For example my printer doesn't work and of course there's no available Vista drivers. My Quicken software is ultra slow now. And I had to reset the preferred folder for iTunes. But the topper is this wireless connection problem. I'm sick of this blue Ethernet cable running down the hallway.

Sorry for the vent.

Collapse -
hope this helps
by cancelallow / March 10, 2007 11:43 AM PST
In reply to: Misery loves company?

This linked helped me after several hours of cursing and hair pulling.

http://forums.pcper.com/showthread.php?t=436850

What worked for me was unchecking the TCP/IPv6 under my wireless connection properties, enabling Netbios over TCPIP in the TCPIP IPv4 properties > advanced options under the WINS tab and statically assigning an IP address in IPv4. Do an ipconfig/all in command prompt and make note of your DNS servers while connected through the ugly wire. Make sure you do not use an IP address already in use by another pc.

Of course all the latest updates, drivers, patches, router firmware were applied.

Collapse -
The Big Red X is gone, but still no Internet connection
by RoboChemE / March 10, 2007 1:40 PM PST
In reply to: hope this helps

cancelallow,

Thanks for your tips. Unfortunately, I was not able to follow what they were talking about.

I was able to follow your advice up to a point. I did "unchecking the TCP/IPv6 under my wireless connection properties, enabling Netbios over TCPIP in the TCPIP IPv4 properties > advanced options under the WINS tab"

I still ended up with my two wireless connections, but the big red X between the multiple networks icon and the Internet disappeared. That was pretty encouraging, but when I tried some browsing, it couldn't find the sites.

Back to the rest of your advice -

How do you do the following?

"statically assigning an IP address in IPv4. Do an ipconfig/all in command prompt and make note of your DNS servers"

Sorry for my ignorance at this. I just used to how easy it was in XP and on my Mac laptop.

Collapse -
Misery and all that
by stodare / March 12, 2007 6:15 AM PDT
In reply to: hope this helps

I have always waited a minimum of 6 months before changing to a new OS, but it just didn't make sense when I was rebuilding this computer. It certainly is disappointing that so many companies have been chasing their tails with no drivers, upgrades etc. Don't get me started on QuickBooks, I just purchased 2007 Pro to get that back and running... can't wait to discover what goodies I may have to look forward to. In fact, decided that I would try to run it on an older system and network it. You don't want to know what I'm going through with Outlook 2002. It has copied all of my recurring appointments dozens of times, and prevented me from deleting the duplicates! In the meantime it transferred all of those dups to my pda... and while we're on my pda, this is a real goody,Verizon notified me that I had to make an upgrade to the firmware before April 1st or no more service. So I follow the instructions and bam, no more pda. You'll never believe... turns out that the new software isn't written to run on Vista. They did replace my pda, but I'm still waiting for a solution.

I will definitely try the TCP/IPv6 solution. In the meantime I've discovered that whenever I lose connection with my email web browser, the gateway has disappeared - but will mysteriously reappear after a while. In the Network Sharing Center, sporadically it has go through re-identifying the network, while that's happening it has multiple networks, but when I check there is only one network.

As for the firewall, that doesn't appear to be my issue. I have turned it off and antivirus, but still have the same problem.

Collapse -
Great site
by stodare / March 12, 2007 9:28 AM PDT
In reply to: hope this helps

Thanks,seems like good info. I followed everything. I have pinged before with good results, but tried again and no prob there. I've eliminated IPV6, and will try manually setting my DNS.

I did find mention in the Linksys manual of a "Keep Alive and Redial Period. This option keeps your internet access connected indefinitely, even when it sits idle. If you select this option, the Router will periodically check your internet connection. If the connection is down, then the router will automatically re-establish the connection." Not sure if this is an option that might help.

I also turned off media sharing, to see if that might be causing issues, since it's not something I'm currently using. So far I've been stable all day.

Collapse -
Keep alive
by stodare / March 12, 2007 9:59 AM PDT
In reply to: Great site

Apparently this feature is only for DSL... so unless that's your connection. Oh well!

Collapse -
firewall
by gk200852 / March 10, 2007 12:26 PM PST
In reply to: Packets

I'm at work (again), but I thing I just did a search from the Vista Start Tab, entered Firewall, and all the settings came up. At the bottom I unchecked all the one that said Wireless. I think there were about 5 in the Incoming, and 4 in the Outgoing. It did do the trick. Now I can watch TV AND have the laptop on my lap.

Collapse -
Duplicate network recognition
by gmeller / March 12, 2007 2:21 AM PDT
In reply to: Firewall

I am having the exact same problem. Two networks recognized, both the same. Can't delete or merge. Only difference is that I am using the Linksys wireless USB adapter. I have downloaded the new driver from Windows Vista, but that didn't solve the problem. I have just found a newer driver from Ralink (the manufacturer of the chipset) and will try that.

This appears to be a Laplink/Vista compatibility problem. So much for "connectivity".

G

Collapse -
Linksys
by stodare / March 12, 2007 6:25 AM PDT

As I recall the wireless G adapter (don't know if that's what you are using) didn't have a driver to work on Vista, so that's why I upgraded to an N router and adapter. I've been very satisfied with the connection speed and signal quality, which is "Very Good" (4 bars) and varies between 216 to 270 Mbps. Keep us posted on the new driver and your model.

Collapse -
wireless network duplication
by gmeller / March 12, 2007 8:29 AM PDT
In reply to: Linksys

Tried the new driver from Ralink. It didn't work. Vista still sees two public networks which are the same. Downloaded the Vista 32 driver from Linksys, not working either.

When I click on the red X Vista tells me that I am connected to 2 networks and have to disconnect from one. But when I disconnect from one, they both go.

Frustrated in Vistaland.

Collapse -
Merge
by stodare / March 12, 2007 11:25 AM PDT

Have you tried the merge function? If you go to the Network Sharing Center and select the "customize" on the line of the network. That will open a second window that will allow you either merge of delete networks. When you select that you should see both of your networks and be able to decide what's appropriate. Perhaps that will clear up the "identifying" problem.

Collapse -
Can't merge
by RoboChemE / March 12, 2007 12:08 PM PDT
In reply to: Merge

I tried the merge option, but only one of the networks showed up and the merge button stayed grey (inoperable).

Collapse -
Yes, we have the same problem
by RoboChemE / March 12, 2007 12:10 PM PDT

I'm the guy who started this thread and we definitely have the same problem so if you come across a solution, please, please post it.

Thanks,

Collapse -
A solution
by gmeller / March 12, 2007 10:15 PM PDT

Ok, I have a solution. But not an explanation.

I updated the driver (from Linksys). Then I followed the suggestions from Cancelallow above. Go to Adapter properties and:

"unchecking the TCP/IPv6 under my wireless connection properties, enabling Netbios over TCPIP in the TCPIP IPv4 properties > advanced options under the WINS tab"

I didn't manually assign an IP address.

That didn't work, but then I went back and checked TCP IPV6, and restored the Netbios setting to the default, and, lo and behold, when I connected to my network, I was able to access the internet. The duplicate network was gone!

So, I am not sure why this worked, I suspect is has something to do with sequence of permission in the new TCP V6 protocol, but I won't argue with it.

Let us know if it works for you.

G

Collapse -
Giv'n it a try
by stodare / March 13, 2007 8:50 AM PDT
In reply to: A solution

Okay, I followed the instructions about disconnecting/connecting IPV6 and Netbios (I had disconnected IPV6 for the past day and hadn't seen a change).

So this is where we differ with our problem I think:

My internet connection is intermittent. When I can't use email/browser my listing for the network no longer shows a gateway. Yesterday I had 2 gateways listed "Internet Gateway Device" and "Residential Gateway Device." When one or both disappear my map on the first page of Network Sharing Center continues to display a connection to the internet globe, but I have no connection with IE7 or email. As soon as the gateway reappears I can connect with software again. I thought it strange that I had 2 gateway listings!

I decided to also install the latest version of firmware for WRT300N, 1.3 I believe. I also found in the Linksys Vista section a suggestion to change the RTS Threshold on the adapter to 2304, so it doesn't collide I guess with the router. To do this go to Device Manager and select your network adapter and right click/select properties and the Advanced tab and RTS Threshold.

After all of that I rebooted, clicked on the house icon in Network Sharing Center and watched the screen as it brought up Admin-Pc, Admin-Pc:admin: (this is not present if I don't select media sharing), Internet Gateway Device, and WRT300N Linksys Device (which has disappeared but I remain connected). So I guess all that's left is to wait and see again.

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

The Samsung RF23M8090SG

One of the best French door fridges we've tested

A good-looking fridge with useful features like an auto-filling water pitcher and a temperature-adjustable "FlexZone" drawer. It was a near-flawless performer in our cooling tests.