PC Hardware forum

General discussion

Problem adding a second hard drive

by kimmoke / February 23, 2005 11:30 AM PST

I upgraded my pc by installing a second hard drive(New 80g old 40g) and made it an extended partition and formatted it. When booting up, BIOS recognizes the new partition and the right size and when I check by using FDISK I can see that the right letter (E) has been allocated for it and everything looks ok but Windows doesn?t find it at all. I tried computer management rescan for disks but nothing happens.
Does anybody have any ideas why this is happening and how to fix this.
Thank you!

Discussion is locked
You are posting a reply to: Problem adding a second hard drive
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Problem adding a second hard drive
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
more info
by kimmoke / February 23, 2005 11:36 AM PST

I forgot to say that I'm using XP pro

Collapse -
Second Hard drive
by larrybell / February 23, 2005 4:00 PM PST
In reply to: more info

I would have to ask: Did you check the jumper settings on the back of the second drive to make sure that it is set to be the "SLAVE" ??

If the 40gig is the master, and the 80gig is not set to be the slave drive (presuming that they are on the same ribbon cable), then windows won't see the 80 gig drive. (sometimes it is the simplest things we forget Wink )

And of course be sure that the ribbon cable is plugged in all the way on the second drive.

Collapse -
Jumpers
by kimmoke / February 24, 2005 6:20 AM PST
In reply to: Second Hard drive

Yes jumper settings are ok, 80gig is set as slave and 40gig as master and they are in the same ribbon, and like I said when pc boots up(POST) I can see the 40gig as master and 80 gig as slave, so it's seems to be ok, but when I check it from my computer or disk management there is no second hard drive at all.

Collapse -
Slave jumper?
by R. Proffitt Forum moderator / February 24, 2005 6:34 AM PST
In reply to: Jumpers

If I check most install notes, I don't read that. Today's 80 conductor cables use the CABLE SELECT jumper and the slave is determined by which connection is used.

The older 40 conductor cables use a different rule.

Bob

Collapse -
What file system is on the boot drive??
by Ray Harinec / February 24, 2005 6:39 AM PST
In reply to: Jumpers

And what on the slave??? If boot is FAT 32 and slave NTFS, FAT32 cannot read NTFS.

Collapse -
file system
by kimmoke / February 24, 2005 8:19 AM PST

The boot is FAT 32 and so is the slave.

Collapse -
What did you use to format the slave??
by Ray Harinec / February 24, 2005 8:38 AM PST
In reply to: file system

Using XP would have limited you to 32 GB max for FAT32 partition.

Did you use FDISK or an overlay program???

Just trying to get the complete detailed scenario, and as Robert says, why not use Cable Select jumpering and the 80 conductor cable to help eliminate some stupid questions on my part.

Collapse -
I used FDISK
by kimmoke / February 24, 2005 11:35 AM PST

I tried cable select with the same result. When I boot POST tells me that I have 40gig Master and 80gig slave.
But Windows can only find only one Hard Drive, 40gig disk with my C and D drives.
The new 80gig Hard Drive didn't come with a floppy,was it sopposed to have one?

Collapse -
Grasping for straws, but did you use
by Ray Harinec / February 24, 2005 12:11 PM PST
In reply to: I used FDISK

the latest FDISK?? The one that supports that size drive??? If you did, when you formatted it did it say that it was formatting the correct amount???

My experience with the new FDISK is that when formatting, it shows the incorrect amount on the format screen, it shows the incorrect numbers and off by one decimal place number of digits, although when done, it has properly formatted the drive. Seems that MS didn't update Format after coming out with the new FDISK.

I have no idea if, not using the latest FDISK could cause your problem.

Simply downloading the latest FDISK, DOES NOT place it on a newly created bootdisk. That must be done manually.

Collapse -
Did you use the floppy disk that
by TONI H / February 24, 2005 8:41 AM PST

came with the 80GB harddrive to actually set it up and format it? If so, there is a possibility that you installed ezdrive/ezbios on it without realizing it. Ezdrive/ezbios is a BOOT manager and can't be put on the slave drive unless the BOOT drive also has it installed on it.....Windows won't see the slave at all if the program is installed on only that drive.

You can check this by booting up with that boot floppy disk again, and after switching to the second harddrive (the slave one) within the program itself, see if there is an option to 'uninstall ezdrive/ezbios' and then do that. It won't hurt the drive by removing only that program and it will still be partitioned and formatted.

Some of the bootdisks didn't let you get to the uninstall feature until you actually chose 'install ezdrive/ezbios' first and then the option to uninstall would show up at the next screen. So if you don't see 'uninstall' at any of the main menu options, go that extra step to see if it shows up.

TONI

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

CNET FORUMS TOP DISCUSSION

Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?