General discussion

prob with asus o!play air

i purchased a o!play air so i could stream video files, music etc from my pc to my tv, the problem is when i try to connect to my pc i keep getting a screen asking for "net user id, password etc" i have no problems connecting to my router as i can use the online media things, does anyone have a solution.


Discussion is locked

Reply to: prob with asus o!play air
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: prob with asus o!play air
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
- Collapse -
asus play air

hey. can you tell me please whats the OS you are using? so i can guide you.

- Collapse -
prob with asus o!play air

I too am having this issue. Windows 7 Ultimate 64 bit machine.

- Collapse -

Create a new user on you pc with an easy password and username and give it full privelages.

Then select the folder on your hard drive you want to share, right click, sharing, say share this folder with everyone or just that user.

After you have connected to your router on the oplay go to folders then network, your computers workgroup should show.

Click on it.


At the login window type in the username and pass you created and press ok it should say save to my shortcuts then you should be able to see your partition structure on the oplay screeen and click the folder you said you want to share and away u go.

- Collapse -
not work for me

I did it but with no result, still asking the ID e password!

Any other idea?

- Collapse -
What I do.

What did u do exactly?

My oplay is connected wirelessly to my modem which is wirelessly connected to my computer. as my modem is also a 4port wireless router.

I turn on the PC connect to the modem, And then turn on the Oplay. Press setup, go to network, and go to AP then manual. Enter the SSID of your modem. press enter, and then go to WPA key (I dont know what would happen if you had a wep or wep2 key).

Enter the Passkey and press ok. It should take about 30sec but eventually the loading icon disappears and it comes up connection details. IP address etc. Press back on the remote or the home key then go to all media.

Then click on folders/network

here you should see my shortcuts, my neighbours, Workgroup. Click workgroup and it should show your pc name. Click on the PC and then enter the username and password as per the previous post (dummy one you created) it should then say login accepted then you can browse to the directory you have shared.

- Collapse -

Ok fellas here it is:

2 things you need to do:


with windows 7 you need to go to network and sharing center, click on advanced sharing settings and in the home and public profiles you need to turn off password protected sharing.


there is a problem when you have installed on your pc the "Windows Live ID Sign-in Assistant". this software causes the asus device to ask you for user and password so you will need to remove it in control panel > programs and features > and probably it appears as: "Windows Live ID Sign-in Assistant" IF NOTHING APPEARS: then you need to uninstall all the programs that use it like msn messenger and Windows Live Essentials.

then it should work. let me know what happens

- Collapse -

This works great, I uninstalled the "Windows Live ID Sign-in Assistant" and my o!play stop asking for user id and password.

Many thanks.

- Collapse -
this works but you need to edit registry

This works in windows 7 tested MACHINE\System\CurrentControlSet\Control\Lsa\ . On the right side Double Click on everyoneincludesanonymous and in
the window that pops up, change the value data from a 0 value to a 1

2. Double Click on NoLmHash and in the window that pops up, change the
Value Data from a 1 value to a 0

3. Navigate to the following location in the registry editor??


1. Double Click on restrictnullsessaccess and change the 1 value to a 0?

NOTE: There is no need to "save" these changes, as you make changes to
the registry it is saved automatically.

2. Close the registry editor and restart
the computer.
3. Once the PC restarts don't forget to update your available network
shares on your o!play by using your remote to navigate the onscreen menu
to Refresh, once Refresh is selected press enter.

fond one one of the forums.. worked for me on both win7 machines with opay live.. remember to turn off and turn on your oplay

- Collapse -
The solution is not a solution anymore

Problem is that with windows life essencial 2011, Windows Live ID Sign-in Assistant was included in a way that is not avaible for parcial uninstall. You must uninstall the all package to get the o play running again with win 7 shares... so or you have messenger or o!play...

Any solutions? Please?

- Collapse -
Try using another client

use trillian instead.

- Collapse -
did you get the internet tv working


I am connected through my router and can watch movies etc streaming wirelessly from the shared folder but cannot play internet tv or internet radio channels. The flicker stocks and video pod casts however work fine.

Any Ideas?


- Collapse -

Remove MSN messenger and install Palringo. Works very nice

- Collapse -
Any other suggestions?

OK so I have uninstalled Windows Live Essentials and turned off password protected sharing. I am now able to logon into my PC and I see my partition structure.

But when I try to access shared folders, it asks me for Net user id and password again! So I type in my PC account's user name and empty password and I still get Logon Fail.

What should I do now?

- Collapse -
Try the usual.

If you are on some other PC logged on as "hangin81" then your SERVER PC must have an account called "hangin81" and the same password for this to work easily.

You didn't tell the forum about the accounts you used.

- Collapse -
Nice Fix

I messed around with all sorts of things, removing Windows Live fixed it !, thanks !

- Collapse -
Asus o'play crashed windows 7 start up

The Windows live fix worked great - for a day. After that my Windows 7 desktop computer would not start up. The only thing that fixed the problem was start up in safe mode and remove the software and then computer started fine. I then updated the ASUS media player online but have not reinstalled the software yet to see if that fixed the problem

- Collapse -
LOG on to OPlayer

Thaks a lot for the help regarding "log on error to OPlayer"
I just installed the Windows Live and then i got the error. No it is uinstalled and everything works just fine.
Only one thing, I have still password protected sharing turned ON, and no problem.

I just wonder why it really is nesseserry to have an account with the name OPlayer and password to use the mediaplayer. But I know, it is a must!
I also have another mediaplayer, WDTV Live. No problem with this in any way, only it cant play .iso files.
Well thanks again for the exelent helping hand, xiotion!

- Collapse -
Any similar solution for MacBook Pro ( 10.8.2)

I am facing exactly same issue;only difference is I am using MacBook Pro ( running 10.8.2 OS) in
stead of Window machine.

Please let me know if anybody has the solution.


- Collapse -
I am facing similar problem with my MacBook Air and ASUS

I am having similar set-up like mentioned by 'snagglepuss' - MacBook Pro running version 10.8.3 and ASUS o!play Air. So far , I have tried following steps:

1) Created user id and password in mac.
2) Given the shared folder all permission for the new user id
3) enabled SMB

When I login to my mac from ASUS, I can go till the folder. But, when I try to get inside the folder, I get the window to enter 'net user id, password' . Whatever uid I try , it fails and I am NOT able to go inside the folder to play the files.

Please help.


- Collapse -
Final Fix To Get Into Folders

The final windows solution for those who followed the above steps, found a way to get past the first password request and are now getting a second one in the actual folder they are trying to use. You simply need to go back on your computer, right click the folder you are trying to access on the O!Play Air, click "Share With" then "Specific People" then from the drop down box select "Everyone" Then click "Add". Finally click "Share" at the bottom and you are done. Reset your O!Play Air and it should work no problem.

Mac users need to do a similar method, I don't have a mac so I can't tell you how. You simply need to get into the network option of the folder and allow full access to it so the O!Play Air understands there are no restrictions to the folders.

CNET Forums

Forum Info