General discussion

printer spool WONT work

I have tried-- msconfig, services tab, make sure Print Spooler has a checkmark--and--Go to start - my computer - c drive - Windows folder - system32 folder - spool folder - printers folder. Then delete the contents of the Printers folder.
Close that, then go to Start - Control Panel - Admin tools - Services - Scroll down to "Print Spooler" and open it and click on "start"

Discussion is locked
Follow
Reply to: printer spool WONT work
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: printer spool WONT work
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Please Try All Of These Steps...

First, please recognize that some users are seeing this issue after Windows Updates occur, especially after those times when large numbers of updates are released by Microsoft.. Still, the steps below seem to help most:

First, click on Start-Run (Start, then type "Run" in the "Search" window to bring up the Run box), then type: "services.msc", then press the "Enter" key.. Scroll down to and set the "Print Spooler" service to "Automatic" and "Start" it.. Maybe multiple times till it sticks.

Next, what has worked for me, is to delete the contents of the following folders, then restart the computer.:

C:\Windows\System32\spool\PRINTERS

and

C:\Windows\System32\spool\drivers

Once done, you may not have to reinstall the printers. Try disconnecting the local printer (unplugged the USB cable), wait a few seconds, and then reconnect it. If that doesn't fix the issue, you may need to reinstall the printers. Also, be sure to check the settings in the "services.msc" again, just to be sure it's still set to "Automatic" and the service is started.

And if that doesn't get it done, then try uninstalling the "XPS Printer Writer" in 'Devices and Printers' if it exists. You may need a separate tool such as the "XPS Removal Tool" by Rogosoft.

Hope this helps.

Grif

- Collapse -
Printer Spooler Error

Hi,

Go to Start / Run and type in "services.msc" without quotation marks, then press Enter or click OK.

In the window that opens (Services) look for "Print Spooler" on the rightRight-click "Print Spooler" and select "Properties".

Click on the "Recovery" tab and change all 3 drop-down boxes to "Restart The Service".

Make sure the 2 text boxes underneath say "1" in them.

Click Ok until you are back at the Services window, close it and you're good to go.

Go back into the properties of the "Print Spooler" tab and be sure to click Start to restart the Print Spooler service and it will restart the service immediately.

The Print spooler depends on the Remote Procedure Call (RPC) service. Is this service disabled? Go to services.msc look for RPC. Check state: Automatic get more help to fix Printer Spooler Error Hope this helps you.

CNET Forums