Mac OS forum

General discussion

Printer "disappears" when Ethernet becomes unconnected...

by timztoyz / October 20, 2006 12:27 AM PDT

As mentioned, a poltergeist unplugged the ethernet cable from my DSL modem and my Epson printer just disappeared from the system -- and now I can't get it back online. My system has been upgraded to OS 10.4.8. It's been so long since I set up the computer that I don't know what to do first -- when I go to System Preference and open Print & Fax, I get two empty windows with "No printer is selected" in the second window. Below, there's a line with "Selected Printer in Print Dialog: and the pull-down shows "Last Printer Used" (no other options). If I click on the "+" symbol, all I get is an eternal spinning of the cursor as it turns into a multi-colored umbrella. What am I doing wrong? I'd appreciate ANY help!!! Thanks!!!

Discussion is locked
You are posting a reply to: Printer "disappears" when Ethernet becomes unconnected...
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Printer "disappears" when Ethernet becomes unconnected...
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Print and Fax
by mrmacfixit Forum moderator / October 20, 2006 1:16 AM PDT

are not the place to go to set up a printer.
You need to be in the Applications/Utilities folder and looking for an app called Printer Setup Utility.
Launch it and see if there are any printers listed. If there are, great.
If not, click the + button at the top and wait until the system has finished searching for additional drivers. Your printer, if it is connected, switched on and has the required green "ready" light, should appear in the list.

If it doesn't, go over to the Epson site and download the current drivers for your printer. Load them and repeat the above. It might also be handy if you still had the instructions that came with the printer. This is not essential though.

Let us know how you get on

P

Collapse -
Still no #@!!%**() printer!!!
by timztoyz / October 26, 2006 3:44 PM PDT
In reply to: Print and Fax

I don't know what I'm doing wrong, but I still can't use my printer...

I went to the Epson website -- there aren't any drivers that are compatible with OS 10.4.8 -- the closest is for 10.3.6. I downloaded it and when it opened it was a workflow -- needless to say, it didn't help. When I try to add a printer, the only options I have are for the following:
Canon BJ Network
Epson AppleTalk
Epson Firewire
Epson TCP/IP
Epson USB
HP IP Printing
Lexmark Inkjet Networking

Clicking on any of the above choice makes no difference -- the ''add'' button never becomes available. I've sent an e-mail to Epson so maybe they can enlighten me -- I'll keep you posted.

Collapse -
Workflow
by mrmacfixit Forum moderator / October 26, 2006 10:43 PM PDT

If by that you mean the program that opened the file you downloaded from Epson was Automator, that would indicate that the incorrect file association was made by the System. This caused it to use the wrong program to attempt to open the file.
As you have never mentioned what sort of Epson printer you have, we cannot check to see where the problem may have occurred.
Most of the printer drivers available at the Epson site have the file extension of .dmg which do not open using Automator.
I would suggest that you download the driver again, and see if the file that you download looks like the file that you previously downloaded. If downloaded correctly, the file should create a Disk Image, looks like an HD, on the desktop. Opening the disk imaged reveals the Read Me and the Installer Application. All this is done automatically by Safari and the System.
If that did not happen in your case, or the file you downloaded did not have .dmg as an extension, download again. Avoid downloading the .HQX files.

P

Collapse -
Epson Stylus Photo 890
by timztoyz / October 27, 2006 12:02 AM PDT
In reply to: Workflow

Sorry about not identifying the printer previously...

Yes, Automator opened the file I downloaded from Epson but it was identified as a .dmg file after it downloaded to my desktop -- there wasn't a Read Me. I tried this while using Firefox, so I'll go back using Safari and see if that's successful.

Thanks again!

Collapse -
Hopeless in Dallas...Epson Stylus Photo 890 printer driver
by timztoyz / November 6, 2006 12:58 PM PST
In reply to: Epson Stylus Photo 890

I guess I must finally admit that senility has set in (I just turned 58 last week) because nothing I've tried has worked -- in fact, I've become even more confused with each attempt.

As you suggested, I downloaded the driver again (epson10506.sea.hqx -- despite your warning, I didn't have any option but to download the .hqx file. After downloading, the file didn't create a disk image or look like an HD on the desktop -- it opened as epson10506.sea. When I tried to open it, Script Editor opened and I got the following message: ''Open Dictionary. Unable to read the dictionary of the application or extension because it is not scriptable.'' Needless to say, that confused me even more!

I never could open the application to find the Read Me and Installer Application. Despite the number of times I tried this, the files I downloaded never had .dmg as an extension. I tried downloading the driver using Safari and Firefox without any luck.

I even called Epson Support and the rep that I reached raced through pretty much everything you've coverd above, thinking I didn't want to pay for support. I'm no further ahead than before I spoke to him. I'd even pay for a driver to be mailed to me on disk!!!

Any other suggestions, other than buying a new printer?

Collapse -
Opening .sea files
by mrmacfixit Forum moderator / November 6, 2006 8:48 PM PST

If you still have that file, single click on it and Get Info. (Apple key + I)
In there it will indicate what program you should use to open this type of file with. Currently it is set to Script Editor, for some reason, so you will need to change it to Stuffit Expander.
If you do not have Stuffitt Expander, go to http://www.apple.com/downloads/macosx/system_disk_utilities/stuffitexpander.html and download a copy.
Doing either of the above will allow you to open the .sea file.

Good luck.

P

Collapse -
File not compressed or encoded...
by timztoyz / November 6, 2006 9:27 PM PST
In reply to: Opening .sea files

I guess I'm not all that senile because I did get as far as using Get Info to determine what I should use to open epson10506.sea -- but Stuffit never was an option and that's where I went blank.
I followed your instructions and changed to Stuffitt Expander (Version 11.0), but then I got the following message: "The file epson10506.sea is not compressed or encoded. It is advised that you obtain further information about the contents of this file from the sender or provider of the file."
Does this mean that part of my problem has been a corrupted driver at the Epson site?
Thanks for all your assistance...

Collapse -
Looks like the wrong driver? Should be .dmg?
by R. Proffitt Forum moderator / November 7, 2006 2:50 AM PST
In reply to: Opening .sea files
Collapse -
I don't have an Intel-based Mac...
by timztoyz / November 7, 2006 4:32 AM PST

According to the Epson rep, that driver is only for Intel-based Macs and won't work on my older G5. Epson finally responded to my second e-mail and gave me detailed instructions requiring me to trash all current Epson folders and reload from my 10.4 installation disk. Seems like it might be easier to buy a new printer -- but not an Epson!

Collapse -
You beat me to that one
by mrmacfixit Forum moderator / November 7, 2006 4:38 AM PST

The trashing of, and reinstalling, the Epson print drivers is not that difficult. Problem is that the drivers are nearly all GIMP drivers and not from Epson.
As long as you have the installation DVD for your OS, a customized install for just the Epson print drives is fairly quick.
Epson are notorious for not bothering with Mac drivers because of the GIMP ones included with the OS.

I am also leaning toward any manufacturer other than Epson.

P

Collapse -
If only I can find my OS Install CD!
by timztoyz / November 7, 2006 7:16 AM PST

My mother raised me better but I haven't got a clue where my OS Install CD is. IF I can find it, it should be easy enough to get back online; if I can't, then I guess it's time to buy a new printer.

Thanks again for all your help!

Collapse -
Same problem with Epson CX660 on G4 Powerbook
by lalynne / November 15, 2006 5:57 AM PST

I have been going crazy trying to figure this problem out, but now after searching around and finding this, I think it must be some incompatability between the Epson downloads and some computers. My husband has a 17" Flat Panel iMac, running OS 10.4.8 and he is able to download the .sea files from Epson and Stuffit decompresses them with no problem.

I try to do it on my g4 powerbook, also running 10.4.8, and I am not able to decompress them. I have tried removing Epson from my system and reinstalling, I tried removing Stuffit 10 and 11 from my system and reinstalling each one then trying it... same problem. I tried the Get Info, and I also get the scripting error, the default app is Script Editor, and changing it to Stuffit does not work.

I initially started this because I am not able to scan to my computer using my CX600. I have an old HP Scanjet and that works fine, but the Epson CX660 gives me an error stating that the app is being used by another application, which it is not.

If anyone has any other answers, other than uninstalling, reinstalling and changing the default app to Stuffit, please let me know. I do have almost all of the Epson decompressed install files that I previously saved in a folder on my system, so I am able to run all of the updates other than the final one.

Collapse -
Epson CX6600
by mrmacfixit Forum moderator / November 15, 2006 8:36 PM PST

As you have noticed, all the drivers for this printer that work with OS 10.4.x end in .dmg

As far as I can see, the only one you may require, that ends in .sea, is the Copy Center Utility Patch.

If both the machines in your household can use the same internet connection, at the same time, then why not get him to pass the decompressed disk images to you via your home network.
Failing that, how about moving them from one machine to another, the decompressed files that is, by using a USB Thumb Drive (Flash Drive)
Once on your machine you can launch the Disk Image files (.dmg) and install them and then run the decompressed .sea file.

It does not solve the problem you have of not being able to decompress files correctly, but it is a work around that should solve your current dilemma.

Hope it helps


P
Post 14 of 14 | Previous Post

Collapse -
Just Rename It!
by frombosix / May 8, 2007 11:03 AM PDT

I was having this problem with a different application. The problem is that when you double-click an app it launches the Script Editor and displays the error 'Unable to read the dictionary of the application or extension because it is not scriptable.' All you have to do is 'Get Info' on the application in question and change the 'Name & Extension' section so it ends in '.app'. So, for example, an offending Epson utility downloads to the file 'epson11390.sea', which does not end in .app; just rename it to 'epson11390.app' and then it launches correctly.

Collapse -
Exactly which application will then open it?
by mrmacfixit Forum moderator / May 8, 2007 9:56 PM PDT
In reply to: Just Rename It!

Changing the extension of a file does not magically make it into something else.
A compressed archive is usually .sea or .sit, on a Mac, and requires a program like Stuffit Expander to open it.
Changing the extension from .sea or .sit to .app does not change the file in any way. It still requires a program like Stuffit Expander to open it and if that program is not part of your software ensemble, the file still remains unopened.

.app indicates that the file is actually a program (application) in itself


P

Collapse -
saved my night
by jlphotoguy / October 22, 2007 2:10 PM PDT
In reply to: Just Rename It!

thanks so much. I was having a devil of a time downloading printer profiles from Epson. Changed the .sea to .app as you suggested and worked perfectly. Thanks so much for posting the advice!

JL

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

CNET FORUMS TOP DISCUSSION

Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?