Peripherals forum

General discussion

Printer Disappeared!! Help!

So one day, I went to print a document, and I got the message "There was a problem printing. No printer could be found." I thought this was odd because my HP Deskjet 5740 has worked fine for about a year now. I went to printers/faxes in control panel, and there were none there, so I clicked the add printer button. That gave me an error saying "The print spool service is not running." Now, I went into services, and found print spool, and it indeed was stopped. I started it and it changed to started, however I get the same result. Every time I come back to the services menu, the print spool is stopped again. Any ideas? Thanks!!

Discussion is locked
You are posting a reply to: Printer Disappeared!! Help!
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Printer Disappeared!! Help!
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
restart and reinstall

In reply to: Printer Disappeared!! Help!

I would suggest complete reinstall of the printer.

1. Uninstall any software for the printer including anything in add/remove programs
2. Restart system.
3. Reinstall drivers and software for printer.

Collapse -
no luck

In reply to: restart and reinstall

no luck...

Collapse -
Happened to me

In reply to: no luck

This happened to me and I completely uninstalled all software, unplugged the printer from the outlet and the computer. It was like starting from scratch. I was able to get it running again, but it would happen again after a while. My only solution was to purchase a new printer.

Collapse -
A viable solution

In reply to: Printer Disappeared!! Help!

Hopefully the following helps. I had to home-grow my own solution because no one on the Net seemed to know how to fix it. Hopefully it helps someone else out there.

So you obviously know how to open up services. Good stuff. For everyone else out there, go to Start -> (All) Programs -> Administrative Tools -> Services. That's for Windows XP. Let me know if you have another version of Windows.

At the bottom of the window, you'll see two tabs - "Extended" and "Standard". Ensure that the "Extended" tab is selected. In the list of services, locate "Print Spooler" and click on it. Now, look just to the left of the list of services and you might see some blue text that says "Start Service". Try clicking this first. If it does start, you're done! Try printing something.

If the print spooler doesn't start, or you don't have the choice to "Start Service", you'll have to go a bit deeper. Back to the list, right click on "Print Spooler" and select "Properties". Select the tab that says "Dependencies". There will be two lists - the top one is system components on which the Print Spooler depends - it's 'dependencies', and the bottom is system components which depend on the Print Spooler. We're concerned with the top list of services.

The idea in summary is to ensure that any services that the "Print Spooler" depends on are started. Know how to do that? Then go nuts. Otherwise, follow along.

If there are any '+' signs next to a service, select it. You'll want to see all the levels of the "Print Spooler" dependencies - second-level dependencies are those that appeared under another service when you clicked on the '+' sign. Go back to the main list of services and locate those second-level dependencies in the list one by one. (You shouldn't have to close the "Print Spooler" properties window to go back to the main list.) When you've find a dependency in the main list, click on it. Do you see that blue "Start Service" text to the left? If so, click it. Hopefully it'll start. If you get an error, let me know.

You'll want to find and start those second level dependencies first. Then find and start the first level dependencies. Once all this is done, close the "Print Spooler" properties and locate "Print Spooler" in the main list again. Try to start it. Hopefully it'll start.

Didn't work? I've also heard people complain of getting the error you got when they had viruses - a Trojan in particular, so you might want to do a scan of your computer. There's lots of good, free anti-virus software out there - I personally use avast!.

I hope this can help.

-J

Collapse -
-J Thanks a Million....

In reply to: A viable solution

Had the same problem as the poster of this thread and your thorough and concise fix did it for me in a matter of seconds! Thanks for the help, I'm sure many others have been helped along as well, just wanted you to know it's very much appreciated.

-Ed

Collapse -
THANK YOU

In reply to: A viable solution

J - your answer5 helped me solve a real problem i was havng at work! Thank god their are posters out there like you! You rock and have officially made thenice list this year! Happy holidays and cheers mate!

Collapse -
Thanks a lot

In reply to: A viable solution

Hello,

Thank you so much. I thought it was registry problem and spend $20 on Reg Booster. Didn't fix the problem and wasted my money. I should have just donated $20. Thanks so much!!

Veronica

Collapse -
REBOOT FIRST!

In reply to: A viable solution

Great article and I also had success with the "cure", however, it didn't work the first time I tried but it DID work AFTER re-booting...

Regards...
dcobes

Collapse -
Thanks

In reply to: A viable solution

And yet another thanks for your solution. That printer disappearing act was killing me as was my previous solution - system restore.
Keep well,
Danny Charleston, SC

Collapse -
Starting the print spooler brought my printers back.

In reply to: A viable solution

Thanks! I went into services, told it to start, and voila! Printers!

Collapse -
How can you apply this to Vista

In reply to: A viable solution

It's great to see someone actually know what they are doing on these threads. However I have vista and the dependencies come up but when I click on them and they are blue there is no start service icons. I do not know if it is related but I am also having trouble when I try to copy and paste anything in word all of a sudden. Ran all the virus software and nothing comes up. This sent down after I printed a bunch of docs. Certainly appreciate any tips or help you could give.

Much Thanks!

Dave

Collapse -
Thank you!

In reply to: A viable solution

A reply like that brings back faith in the internet! No, seriously, much obliged - an accurate, useful and correct answer without a load of timewasting guff to wade through. Nice one.

Collapse -
Printer Disappeared Help

In reply to: Thank you!

Hi,

A corrupted driver can cause the network printer to disappear. A driver or software can get corrupted due to virus attack. You need to install a dependable antivirus in the system to resolve this issue. The antivirus can perform a system scan to check for virus in the files and folders saved in the computer.

Popular Forums

icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

SMART HOME

This one tip will help you sleep better tonight

A few seconds are all you need to get a better night's rest.