Networking & Wireless forum


Primary DNS server is not responding

by susya_1 / June 18, 2012 7:39 PM PDT

I am experiencing the problem described below.

I got an internet from provider (which is LAN cable sticking from the wall) - and it works fine when I connect via LAN cable - when I write the IP Address, Subnet Mask, Default Gateway, and DNS servers on the LAN adapter and create a PPPoE connection with username and password.
I want to do the same but wirelessly. I have an ASUS RT-N10 LX wi-fi router - and connected the cable from the provider to the WAN slot on the router. Then I have accessed the router from my laptop - and configured everything as it was on my laptop.

IP Adddress:
Default Gateway:

Wireless network works fine, the default gateway is pinging - but DNS servers are not accessible. As a result no internet connection available (
Moreover - when I want to ping the DNS (ping - I tries to get a response from other location (but no response from there)

Any feedback / hints / comments will be greatly appreciated! I have spent 2 days for it but in vain (((

Thanks in advance!

Discussion is locked
You are posting a reply to: Primary DNS server is not responding
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Primary DNS server is not responding
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Collapse -
Re: configuring
by Kees_B Forum moderator / June 18, 2012 8:14 PM PDT

I never needed to configure an IP-address for a wireless connection. The router gives them to the device if DHCP is enabled. And DHCP seems to be always enabled in all the PC's, laptops, iPods and smartphones I tried.
And, somehow, that automatic configuration makes the router both the gateway and the DNS-server.

But then, the modem does the logon with the ISP, so I don't have to configure pppOE either.

All I can ask: which of your devices has IP-address And which has If no such device exists, it can't be found, of course.


Collapse -
DNS server
by susya_1 / June 18, 2012 8:49 PM PDT
In reply to: Re: configuring

thanks for the answer, Kees!

I have no modem - as it is a high-speed ethernet connection (cable from the provider) - only thing i have i a socket in my wall to which I plug the cable. The question here is - why everything works fine when I plug physically by cable (DNS are pinging without any problem), and doen not work when over wi-fi???

And you are right, No my devices have addresses and

Collapse -
by susya_1 / June 18, 2012 8:51 PM PDT
In reply to: Re: configuring

and wi-fi per se works fine, laptop sees the network and connects to the wifi connection - but the router configuration is probably wrong

Collapse -
Laptop addresses.
by bill012 / June 18, 2012 10:14 PM PDT

Where did you get the ip block and the default gateway? Are these the same IP you used when you connected without the router ?

This is not your typical out of the box router config and the subnet mask is not what you typically see. It is completely correct but generally someone who understands how to do this would not post a question like this on this forum.

Your key problem is that your router is on the wrong subnet. What your PC calls the default gateway always needs to be your router.

The problem I suspect is the ISP is using the 192.168.xx.xx blocks of IP addresses which is also the most common ip addresses used by people in their house.

So to avoid this mess I would use one of the other private IP blocks. Set your router to use with a /24 mask ie on the LAN side. You should set up DHCP on the router to give out IP addresses in this range also or you could I guess hard code your PC to one like The default gateway would be and the DNS would be the and

Now if it is just the DNS server you can always try a public DNS server like

Collapse -
by susya_1 / June 20, 2012 8:36 PM PDT

I have spent 3 days trying to resolve this, and finally get it resolved.

What i did: listen to bill012's advice and changed the subnet + run the command line: netsh winsock reset.
Than made a trick!

Thanks bill012 and everyone!

Popular Forums
Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions


Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?