Question

Powerline adapter connectivity issues

I recently purchased a powerline adapter, specifically a TL-WPA4225 Kit. I installed it about 2 weeks ago and was very happy with it. It gave great Wifi in my flat and it had an ethernet port so i could connect it to my Laptop. It worked great, until last night. I was using my laptop when suddenly i couldn't acces web pages anymore or use anything that required internet. There was a yellow exclamation mark on my wifi icon. The powerline adapter shows that its no longer connected to a powerline network.

I tried pairing the adapter agains multiple times but it didn't work. The "TP-LINK-2C2112" is still amongst the networks that show up with a 5/5 bars of connection but when i try to connect it says it's limited. Same for the Ethernet option. It's not a PC problem i think cause my PS4 and PS3 can't connect anymore either.

Discussion is locked
Follow
Reply to: Powerline adapter connectivity issues
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Powerline adapter connectivity issues
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Clarification Request
I installed one of these

and had problems connecting too , than I found out that the transmitter and receiver needed to be on the same electrical circuit .
After that , everything was fine.

- Collapse -
Clarification Request
extra info

I used the Troubleshooter on both the ethernet and the wifi and for both it says that there isnt a valid IP configuration

- Collapse -
IP configuration.

Are you sure they are referring to the adapter? Manual say any thing about that? I thought basically it's just a cable. Live and learn.

- Collapse -
Answer
If your devices connections ok on the other end then...

the only conclusion is powerline adapter or the cable that connects powerline receiver to your device is bad.

CNET Forums