General discussion

Power Surge on Hub Port A USB device has exceeded the power

"Power Surge on Hub Port"..... "A USB device has exceeded the power limits of its hub port. For assisatance in solving this problem, click this message."

Saw this perplexing problem for the first time on a client's PC... Thought I would see if there was anything out there before I started troubleshooting. PC has been on a burn in test for several days. Solution to this problem is easy TURN OFF System Standby & DISABLE Hibernation in Control Panel - Power Options -on Power Scheme Tab set System Standby to NEVER - click Apply Then change to Hibernate Tab and Uncheck Enable Hibernation
Problem was on a Sony Viao PCV-RS310 aka PCV-2222 that was fine prior to Factory Restore and no USB devices were attached..... Problem has NOT re-appeared since and I did NOT try to change ANY of the USB settings suggested in the threads I found. So try this first before you start turning off warnings and changing drivers or registry settings.

Discussion is locked

Reply to: Power Surge on Hub Port A USB device has exceeded the power
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Power Surge on Hub Port A USB device has exceeded the power
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
- Collapse -
We've covered this
- Collapse -
You should read what you recommend before you reply

It is not ?WELL? covered I reviewed the suggestions in the thread & they are masks not fixes. Turning off valid warnings from windows, buying external hubs, downgrading USB 2.0 to USB 1.0, replacing power supplies and all of the other suggestions are wrong Bob. After 23 years in IT I think I would not waste my time to post a true solution in a forum only to be chided by a forum moderator. I resent your condescending response because you obviously did not bother to read my post or the posts in the thread you refer to. You were an active participant in the thread so you should have realized my post was not a repeat of any information contained in the 14 pages of discussion
The systems with the problem folks are asking about obviously can?t wake from hibernation & sleep properly and the USB ports are properly reporting a surge. The correct solution is to disable hibernation & sleep so the USB ports don?t take a shot every time the system wakes up!
Furthermore I challenge you to find the fix I posted someplace else Bob. I doubt you will find anything anywhere on the web mentioning it. Unless it is a forum that I just posted to submitting the same details I sent you. Furthermore if you even bothered to read the posts in the link you sent me you would have seen that Disabling hibernation and sleep is not mentioned a single time.
Additionally after reading ALL of the some 200 posts you refer to, I saw you several times encouraging people to do a bunch of useless gyrations like applying patches and buying new parts or telling them they have bad hardware. When all they had to do was disable hibernation & sleep.

- Collapse -
Well covered.

Yes I've heard the argument that the fixes are masks and not fixes.

The sad truth is that the real fix is to fix the hardware and driver. But most companies will not do that so we are left with the disable and then the USB port comes back to some usable state.

Why play the Don Quixote part here? That is, I know your stance and wish you well.

- Collapse -
Power Surge on hub port

I've been searching for a solution to this problem but as a computer novice I cant make sense of the responses! I hope you can help me. I don't have a Power Option on my control panel. I'm using a Dell PC - Dimension 5100. I got the message when I tried to connect my camera to the PC and again when I used my memory stick. The USB port therefore seems to not be working at all. Can anyone help me?

- Collapse -
If we set aside

Or go for something that helps put the USB back into operation we have the long discussion at;forums06 and many suggestions.

I find turning off the notification does return the USB to operation but this will never placate those that want a "true fix." For that the makers have to issue new hardware, BIOS and drivers. (good luck?)


- Collapse -
Happy to help

Just email me xijilia @ (my response will come from another email account because I don't want to post my details here. In case you don't know there should be no spaces before & after the @ in the email address I gave you)
I don't feel like bickering with the moderator of this forum over this issue further. Drop me a note and I can fix it for you if you want N/C just a random act of kindness.

- Collapse -
No bikering.

I was sharing we've discussed this before and there are solutions that get the USB working again.

HOWEVER once in a while someone wants the "true fix" which means you get the makers and driver writers to correct the root cause.

I am more than willing to discuss this in deep detail. And if you want to truly give the forum the kindness you say you have, all you need to do is share how you are solving it.

- Collapse -
Is Alan Funt in the house? You have got to be joking!

A quote from your last post as a reminder?

?And if you want to truly give the forum the kindness you say you have, all you need to do is share how you are solving it.?

I see 3 options here Bob:
1: You are schizophrenic
2: You are trying to be annoying & difficult
3: You just do not read things posted in this forum.


You scoffed at it and pointed me to a useless link saying this was well covered ? I disputed you and you called me Don Quixote.

You have refused to acknowledge a proper resolution that I provided to this forum , even though the symptoms make perfect sense. Any professional worth their weight in salt should remember that a large percentage of older systems could never properly manage waking from hibernation & sleep without causing a barrage of strange problems. It should always be the first option to disable before crippling other system settings & devices.

I posted here because I saw people struggling with something so simple and attempted to save someone aggravation and instead I have spent more time exchanging non pleasantries with you than I did fixing my clients PC and posting what I found to be the fix. A fix that is mentioned NOWHERE on any forum!

Whatever! I?m SO done with this ridiculous nonsense & this thread. If someone needs help with this they can email me I will help them. If they feel like it they can post here and report back to you.

I kindly posted the fix for you in my first 2 posts. While it may not fix EVERY USB Surge problem, it is the fix for a Sony Viao PCV-RS310 aka PCV-2222 that was fine prior to Factory Restore and no has USB devices attached when the message appears.


- Collapse -
Sorry to have upset you.

I know you meant well but that's not the only fix and sadly it doesn't always work. Thanks for bringing it up and I apologize.

- Collapse -

Hi I also have the same problem with the loptop I'm currently fixing.. And I have fix it hope this one help you out... First I would like to tell you this, all USB port have some bandwidth or something like power limits and it is shared to all USB ports that you have it also shared by the CD/DVD-roms attached to it..Note this is a loptop and not Desktop comp... By unplugging some of the devices may help solved the power allocations on each USB devices... I am using Dell loptop (Latitude Cpx)with WinXP SP2... This solvd the issue.. But this is not just the fix of this kind of problem.. This is just a minor fix... A major fix is to recalibrate the usb port like rewiring it.. Or pull it off the board then solder it again with soldering iron.. But just be careful on soldering it again be sure to put it the right way or exactly the way it used to be because it will make things worst if you make it grounded.. I did this to some USB port that I fix... Because some loptops that I have fixed has a broken usb port or it's unusable anymore so I pulled some usb port to another loptop that has been junked and replace the other.

- Collapse -
power surge on hub port

Glad disabling hibernation & sleep worked for you. I tried it, and it didn't work for me! I don't understand why so many people have this problem and no one has the solution to fix it.

- Collapse -
See post 2 above.

I've solved this too many times with the advice in the link in post 2.

HOWEVER. There are folk that strongly disagree with the known fixes. They want some other fix such as a corrected motherboard or driver. Sadly I have yet to see that happen.

I have subscribed in case you reply.

- Collapse -
Been there, done that

I was going to do what you said but when I went to do it, it was already done. standby on never and no check in hibernation box. It still does it and it doesn't matter which USB port I use. Any other suggestions?

- Collapse -
See post 2.

It refers to the longer list of solutions. Including unpopular ones. I see you tried the hibernation one but not the others.

- Collapse -
Flash Your BIOS

Motherboard: Gigabyte GA-Z77X-UD5H.
Recently I had "Power Surge on Hub Port A USB device has exceeded the power" issue. Solution for me was to flash BIOS from version F4 to the latest F14. This is easy procedure even for begginers thanks to Q-flash. Read motherboard manual for procedure steps.

CNET Forums

Forum Info