"To me this proved conclusively thet the internet connection was waking the pc fron stanby ."

While the detail in your post is lacking my only guess is that in your BIOS you need to disable WOL or Wake On Lan.

Bob