Mac Desktops forum

General discussion

Power Mac G5 - Can't see new hard drive, just installed

by trublood00800 / August 21, 2009 2:24 AM PDT

I have a (2005) Mac G5 and I just installed a new Western General 1Tb hard drive (SATA 7200 3.5) in it, I was running Tiger OS prior to the hard drive going bad. When I boot using the OS disk and pull up disk utility, I can't see the new hard drive so I can mount. Before I bought the new hard drive, I had the machine tested @ the genius bar and they assured me my h/d went bad and everything else was functioning ok. Is there a step I'm missing? Any help would be appreciated.

Discussion is locked
You are posting a reply to: Power Mac G5 - Can't see new hard drive, just installed
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Power Mac G5 - Can't see new hard drive, just installed
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Motherboard firmware doesnt support 1Tb
by trublood00800 / August 21, 2009 6:30 AM PDT

I found out that the firmware on late 2004 G5 models don't support drives larger than 250G.

Collapse -
by blutic / August 21, 2009 12:23 PM PDT

I have a dual processor G5 ordered 2003 and it is now supporting a 1TB drive in bay. I think perhaps you might check that you are getting power to drive. There are two connections to drive. One is the power. Other is data.

Collapse -
power connector on the drive
by trublood00800 / August 26, 2009 10:04 PM PDT
In reply to: Reply

Hey Blutic, How do you confirm the power is up on the power connector?

Collapse -
by blutic / August 27, 2009 12:02 AM PDT

It should become active as soon as power is connected. How did it go? It should showup on the desktop as the primary drive does. Then you can format it.

Collapse -
by mrmacfixit Forum moderator / August 27, 2009 10:39 AM PDT
In reply to: reply

drives that require formatting do not show up on the desktop until they have been initialized.

there will be no power on the drive power cord until the ON button is pushed.

With the cover removed, you should be able to hear the drive spin up.


Collapse -
formating after locating
by blutic / August 27, 2009 12:33 PM PDT
In reply to: Sometimes,

Correct me on this if I am incorrect, but drive should show up under menu-Apple > about this mac> more info>serial-ATA Then format drive from startup with system disk?

Collapse -
Yep, it should show up there
by mrmacfixit Forum moderator / August 27, 2009 9:59 PM PDT

but to do that with this particular drive, you would have to be booted from another drive anyway.


Collapse -
Power Mac g5 limited to 150 MB/sec
by ptilotus / March 20, 2010 7:57 AM PDT

I had the same issue when I installed a Western Digital Caviar Black WD1002FAEX (1TB) on my wife's Power Mac G5. Turns out that the G5 can only handle a SATA rate of 150 MB/sec. The WD1002FAEX has that rate disabled by default, therefore it can't be seen unless you enable the 150 MB/sec rate on the disk. One does this by jumpering pins 5-6. After I did that, the G5 saw the disk and handled it just fine. No firmware update required.

Biggest problem I had was that the bare drive came with no jumpers, and I had a heck of a time finding a jumper that was the right size for this drive (most of the ones in my junk box were too loose and just fell off).

Collapse -
Solved! Western Digital Caviar Black in PowerMac G5
by mstroven / June 20, 2010 1:50 PM PDT

THANK YOU! Who would have thought that the new drive wouldn't "auto-fallback" to the 150MB/s rate.... jumpering these pins got me up and running. Thanks again

Collapse -
Power Mac g5 limited to 150 MB/sec
by EleetPCs / June 3, 2011 9:34 AM PDT

Jumping my 1TB Caviar Black worked perfectly. My G5 started up with no problems. Thank you for the help.

Collapse -
Where did you get the jumpers?
by jettylex / July 29, 2012 5:47 AM PDT

Where did you end up getting the correct jumpers for the WD1002FAEX? I have the same issue. Almost returned it until I saw this posting. Thx!

Collapse -
I get mine off old drives.
by R. Proffitt Forum moderator / July 29, 2012 6:22 AM PDT

Computer shops, amazon, etc. It's a dime part but you pay more if you don't head to a shop and ask for one.

Collapse -
by GaryGrenier9 / November 19, 2012 10:49 PM PST

That did it for me, as well!

Collapse -
Cant See New HDD
by inbryomusic / June 22, 2013 10:21 PM PDT

Hello everyone

Im having the same issue "powermac early 2005 G5" but with a 320GB WD blue, i have tried the pins i've tried to plug on both bays, i can hear the HDD and still the tower does not see the HDD, my previous HDD crashed but the computer still see the old HDD and it shows on the boot page with the circular arrow and the right pointing arrow, but my new WD HDD does not show no matter what..... any ideas??

Collapse -
Re: new hard drive
by Kees_B Forum moderator / June 22, 2013 10:30 PM PDT
In reply to: Cant See New HDD

Just asking:
- Is this new hard drive already partitioned?
- What file system does/do the partition(s) have?


Popular Forums
Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions


Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?