I switched over to "movie" mode and turned the brightness down to 50. The brightness is at 45 in "standard" so that's not what was causing it... I've been hyper-futzing with the settings the past few days adjusting for every different movie. Well, I found a setting that doesn't do that I don't care how but here it is for anyone interested. *watching Pan's Labyrinth on Blu-Ray, these settings give a nice dark shadows while showing great detail in addition to eliminating the flashing:

fix: problem:

Mode: Movie Standard
Cell light: 7 4
Contrast: 65 95
Brightness: 50 45
Tint G/R: G54/R46 G50/R50
Black tone: off off
Dynamic contrast: off off
Gamma: 0 0
Color space: auto native
Edge enhancement: off off
Color tone: Warm2 normal
Picture size: 16:9 16:9
Digital NR: off off

What could be the actual fix for this dark screen flashing issue?