Browsers, E-mail, & Web Apps forum

General discussion

Popup Blocker: Can not override it

by wftaylor / October 25, 2004 1:13 PM PDT

I am running Windows XP, Service Pack 2, and use the Internet Explorer browser. A couple of weeks ago, I was no longer able to override the popup blocker to view blocked popups that were of interest to me. I went into Tools, Internet Options and disabled the popup blocker, but it had no effect. I am not really sure that the popup blocker is the real problem. Recently, I was on the Investor's Business Daily page and brought up a stock chart. I wanted to bring up a weekly chart and placed my cursor over the link. I noticed that at the bottom left hand side of my browser screen, the words "Javascript:toggle mode()" appeared. I clicked on the link, the chart appeared for about one second and then disappeared. I thought it was a popup problem, but it may be a Javascript problem. I went on Java/Sun site and dowloaded the lasted version of Java, but it did not correct the problem. So I don't know if it is a popup problem or a Java problem, or both. Does anyone have any suggestions as to how to troubleshoot this problem?

Discussion is locked
You are posting a reply to: Popup Blocker: Can not override it
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Popup Blocker: Can not override it
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Perhaps your ''saga'' is described . . .
by Cursorcowboy / October 26, 2004 12:03 AM PDT
A couple of weeks ago, I was no longer able to override the popup blocker to view blocked popups that were of interest to me. I went into Tools, Internet Options and disabled the popup blocker, but it had no effect. I am not really sure that the popup blocker is the real problem.

The article [Q843015] explains that after you install SP2, pop-up windows may still appear, even though the default Pop-up Blocker feature is turned on, may occur for the following reasons, and discusses a method for resolving the issues:

? You click a link that opens a pop-up window.

? The Web site where the pop-up window originates is either in the Trusted sites Web content zone or the Local intranet Web content zone. Because Web sites in these zones are considered safe, their pop-up windows are never blocked.

? The pop-up window is opened by software that is running on the computer.

? The pop-up window is opened by ActiveX controls that are enabled from a Web site.

Note: Please review, "Block Pop-up Windows with Internet Explorer" and "How to configure the Pop-up Blocker in Internet Explorer (Q843016)."
Collapse -
Re: Perhaps your ''saga'' is described . . .
by wftaylor / October 26, 2004 1:04 AM PDT

The problem is not that popups still occur. The problem is that I can't override popup blocker to view the popups that I want to see. And disabling popup blocker does not cure the problem. Popups are still being blocked.

Collapse -
(NT) (NT) "That's true" but did you note what the article says?
by Cursorcowboy / October 26, 2004 2:27 AM PDT
Collapse -
Re: (NT)
by wftaylor / October 26, 2004 2:59 AM PDT

I read the articles you referenced before I responded and just read them again. I really appreciate your help, but I don't know what you trying to get me to see. Everything I do to try to view the popup, from trying to override the popup blocker with the control key, from adding sites to the "allowed sites" box, to turning off popup blocker doesn't work. Plus I have run Lavasoft's Adaware 6 and Spybot to try to find any problems that way. The articles say that when you intentionally click on a link that opens a popup, it will open...but it doesn't. So what in the articles guides me to the problem of being unable to open certain popups or to troubleshoot the problem?

Collapse -
Okay. Method #1 describes removing.
by Cursorcowboy / October 26, 2004 4:05 AM PDT
In reply to: Re: (NT)

Reverse the process of removing and Add sites instead to those zones. Also see the second reference; "If you want to see pop-up windows from a specific Web site, type the address (or URL) of the site in the "Address of Web site to allow" box, and then click Add (click to see a screen shot)."

Collapse -
Re: Okay. Method #1 describes removing.
by wftaylor / October 26, 2004 5:28 AM PDT

I did this last night and it didn't work. I added a site, restarted the computer, checked to be sure it was still added, then went to the site, clicked on a link that would show a popup chart and something blocked it. It showed for about a second and then disappeared, just like it did before I added the site to the Trusted Sites box.

I don't know if something other than Internet Explorer is blocking the popups or not. No adjustment I make to Internet Explorer affects the problem.

I previously installed Google's toolbar, which included a popup blocker. I thought this might be the problem (ie some kind of conflict with IE), so I uninstalled Google's toolbar, but it didn't change anything. On my wife's computer, I have both Internet Explorer (with popup blocker) and Google (with popup blocker) installed. I can disable the popup blocker in both and I can see the chart (the link I described above) fine. It is not blocked. So it doesn't appear that Google is the problem...but then I don't know what is.

Collapse -
Another thought and my last -- Firewall
by Cursorcowboy / October 26, 2004 9:15 PM PDT

1. Windows Security Center is a category listed in the Control Panel and the centralized location in WinXP SP2 that monitors the status of three major security functions in the background:

? The firewall

? Automatic Updates

? Virus detection.

2. By default, Windows checks to make sure that Automatic Updates is set to download and install security and other important updates automatically, and if turned off or if it is not set to the highest setting, Security Center provides recommendations to turn it on or to adjust Automatic Updates. If it detects a problem with any one of these, it displays an icon and balloon message in the notification area "Your computer might be at risk" (click to see a screen shot), [Q875349].

a. HKLM\SOFTWARE\Microsoft\Security Center - a DWORD value:

? AntiVirusDisableNotify -- default numeric zero with possable values of a zero or one.

? FirewallDisableNotify -- ditto above

? UpdatesDisableNotify -- ditto above

b. Administrative Templates \System\ SecurityCenter

? Turn on SecurityCenter (computers in Windows domain only) -- default not configured but possible values are On and Off.

3. Supplemental reading:

a. "Frequently asked questions about Windows Security Center (Q883792)."

b. "How to configure the Windows Firewall feature in Windows XP Service Pack 2(875356)."

c. "Troubleshooting Windows Firewall settings in Windows XP Service Pack 2 (Q875357)."

d. "How to use the Security Alert dialog box in Windows XP Service Pack 2 (Q875353)."

Collapse -
by wftaylor / October 26, 2004 11:03 PM PDT

Dear Cursorcowboy,

I will look into your suggestions concerning the Security Center this evening. I want to thank you for your thoughts and suggestions. You've spent quite a bit of time on this and I appreciate it.

Collapse -
Inability to override Popup Blocker still not resolved
by wftaylor / October 27, 2004 1:08 PM PDT
In reply to: Thanks

If anyone is reading this discussion, I still do not have a solution to my problem. That is, I can not view popups that are being blocked, either by Internet Explorer's popup blocker or by some other source on my computer unknown to me. And when I click on a link that is supposed to open in another window, it appears for about one second and then disappears (ie is blocked). If anyone has any suggestions as to how to further troubleshoot this problem, I would appreciate hearing it.

Collapse -
Re: Inability to override Popup Blocker still not resolved
by Cursorcowboy / October 27, 2004 9:54 PM PDT
And when I click on a link that is supposed to open in another window, it appears for about one second and then disappears (ie is blocked).

1. Download and use "IEFix" - a general purpose fix for Internet Explorer (Win 98/ME/2000/XP):

a. Registers Urlmon.dll, Mshtml.dll, Actxprxy.dll, Oleaut32.dll, Shell32.dll, Shdocvw.dll, [Q281679].

b. Refreshes Internet Explorer using IE.INF method. Notes:

(1) "Unable to Install Internet Explorer 6 on Windows XP (Q304872)"

(2) "How to Reinstall or Repair Internet Explorer and Outlook Express in Windows XP (Q318378)"

c. Initiates "SFC /Scannow" (Win2K&XP), [Q310747].

2. The article [Q154036] describes the step-by-step procedure for troubleshooting problems with Active Content in IE such as ActiveX scripts, ActiveX controls, and Java programs when you are unable to load a particular Web page.

3. Supplemental:

a. "A New IE Window Does Not Always Open When You Click Hyperlinks (Q272415)."

Note: The purpose of this article is to point out a common error in HTML coding which is not an IE issue.

b. "OLEXP: How to Configure OE to Open Links in E-mail Messages in a New Window (Q256953)."
Collapse -
Re: Inability to override Popup Blocker still not resolved
by jjmac2003 / December 3, 2004 7:25 PM PST

Hope you've already resolved the problem by now. If not, you may want to try to disable the popup blockers in all places - besides the one option you can choose in the ie "tool" menu, there are possible other ones. I had the same problems as you described (that's why I found your posting), and it turned out that the popup blocker needed to be disabled in all three places (in my case):

1) in ie tool menu, make sure the popup blocker is turned off;
2) in ie tool menu, select "Internet options", security panel (choose approriate zone), customer level, under "misc", check the box in front of "disable" regarding "use popup blockers";
3)on the Yahoo tool bar (with a big Y! sign on it), find the "popup blocker" button (in my case, it's right next to the "search Web" button, and turn it off.

In my case, I didn't find #3 until I spent a lot of time and struggled to find a solution on this issue. After I implemented #3, the problem was resolved completely. I hope the same will work for you too. Good luck! If you have more tool bars (such as Google), then you may need to check all of them.

Collapse -
jjmac2003: Still can not find problem
by wftaylor / December 4, 2004 1:27 AM PST

I appreciate your suggestions. I had already tried your numbers 1 and 2. At your suggestion, I also checked my version of Yahoo, and did not find a popup blocker installed. I have never "consciously" installed it and couldn't find it if it got installed with some other 'stuff'. I previously had the Google tool bar with it's popup blocker installed and I disabled the popup blocker and then subsequently uninstalled the tool bar, but neither action resolved the problem. I even uninstalled IE Service Pack 2 and reinstalled it, but it did not produce a fix.

I tried the things suggested by Cursor Cowboy, as best I could, but nothing resolved the problem

I have a second computer connected to the internet which is running Internet Explorer and the Google tool bar, both with popup blockers running, and I do not experience the problem (inability to open certain links) on that computer. I have tried to compare it's settings with the problem computer and can't find the difference.

Finally, in frustration, I downloaded the Mozilla Firefox browser and it works fine. I like IE, but can't resolve the problem with it, so I have stopped using it, except for my email.

Again, thanks for your suggestions, and if anything else comes to mind, let me know

Collapse -
Re: jjmac2003: Still can not find problem
by jjmac2003 / December 6, 2004 4:03 PM PST

A few days ago, one of my friends also encountered the similar problem. My experience of resolving the problem didn't work for him either. However, we wound up finding a way that resolved his problem. It turned out his problem was related to third-party browser extensions (add-ons). After uncheck the box "enable third-party browser extensions", his problem was resolved. See the article below for more details:

Third-party browser extensions

Some third-party browser extensions and add-ons may interfere with how Internet Explorer views certain Web pages. To turn off these extensions, follow these steps:

1. Open Internet Explorer, click Tools then Internet Options.
2. Click the Advanced tab.
3. Click to clear the Enable third-party browser extensions (requires restart) check box.
4. Click Apply.
5. Click Ok.
6. Start Internet Explorer, and then try to reproduce the issue.

If your problem is resolved after the above steps, you may want to determine which add-on programs really caused the problem. See below:

1. Open Internet Explorer, click on Tools then Internet Options.
2. Click the Advanced tab.
3. Click to select the Enable third-party browser extensions (requires restart) check box.
4. Click Apply.
5. Click the Programs tab.
6. Click Manage Add-ons.
7. Click Add-ons that have been used by Internet Explorer.
8. Select all but the first of the add-on check boxes that are installed.
9. Click Disable.
10. Click OK.
11. Start Internet Explorer, and then try to reproduce the issue.

If the problem does not occur, select the next Add-on check box in the list, and then try to reproduce the problem. Select each check box in turn until you determine which add-on is causing the problem. When you have determined this add-on, you may either disable this particular program, or contact the software manufacturer for information about updates for the add-on.

Hope this will offer you some useful ideas. Good luck!

Collapse -
Windows XP, Service Pack 2 problems
by elinpelin / January 3, 2005 11:53 PM PST
Collapse -
Service Pack 2
by wftaylor / January 4, 2005 1:17 AM PST

Thanks for the lead. I will check it out. So far, I can't even find the problem and switching browsers to Mozilla's Firefox has been the only solution. But it has been a good solution as I like it better than Internet Explorer anyway.

Collapse -
I have a similar problem
by fweiner / February 24, 2005 5:26 AM PST
In reply to: Service Pack 2

Have you determined what causes your problem? Any information appreciated. I tried all of the posted suggestions with no success. This is so frustrating since I must use IE to run certain activex programs. My problems started after installing the Microsoft Antispy software and running the malicious software defender posted on their site. There is nothing I can do to bring up a link in a new window.

Collapse -
Similar Problem
by wftaylor / February 24, 2005 9:44 AM PST

Sorry, but I never found a solution to the problem other than to switch to the Firefox Broswer which incidently works fine. I tried most all of the suggestions, including uninstalling and reinstalling Internet Exporer and Service Pack 2 and nothing helped. I suspected that another program may have had a pop-up blocker that was causing the problem, but I could never find it. I do know one drastic solution that will solve it and that is to reformat the hard drive and start over, but that is a lot of work and since Firefox worked, I didn't take that alternative. Plus there was always the chance that I would unkowningly install again whatever program was causing the problem and be right back in the soup again. I suppose though that I could have discovered this by reinstalling my software one program at a time and testing Internet Explorer after each install to make sure it was still working. Good luck!!

Popular Forums
Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions


Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?