Windows Legacy OS forum

General discussion

plug and play fails to install flash drive

by eclectoman / December 9, 2009 9:31 AM PST

Dell Latitude d531
AMD Turion 64 mobile TK-55
2 Gig ram

Flash drive: Patriot XT 8 Gig

Bought the flash drive and took it to the office....dumped some files on it....worked perfectly. Brought it home and plugged it into the Dell.

"Found new hardware" balloon pops up, then the "Found New Hardware" wizard runs. As this is plug and play this shouldn't happen, but it obviously couldn't find the drivers.

Tried pointing the wizard to all the locations I could think of, including my XP cd and directories in C:\windows where other drivers sit. When I pointed it to c:\windows\system32\drivers it said nothing there even though that's where the drivers are for all the entries in device manager under USB Controllers.

No luck.

Have tried sticking the flash in my powered hub and in both USB ports with the hub unplugged.

External hard drive running through the hub works fine.

Bought a Western Digital external hard drive....same story. WD tech support told me the drive was defective and had me take it back.

Windows sees "Patriot Memory" in device manager but it has the yellow ! and ?. Right clicking on the device then properties shows "This device is not configured correctly. (Code 1)"

Clicking on driver details brings a popup that says "no driver files are required or have been loaded for this device."

Patriot tech support basically says "It ain't our problem" which is sort of rude but probably true as the flash works fine on another computer.

I've caused google to overheat looking for solutions. Seems to be a fairly common problem but none of the solutions I've tried have helped.

Let me know if I can supply any more information.

Thanks in advance.

Discussion is locked
You are posting a reply to: plug and play fails to install flash drive
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: plug and play fails to install flash drive
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
2 issues.
by R. Proffitt Forum moderator / December 10, 2009 12:08 AM PST

No story about how the OS was installed but there are issues you need to address.

1. XP and drive support over 127GB. This was addressed in SP1.
2. XP and large flash drives. LINKS ABOUT!

The issues can be as simple as XP was installed but not the machine's drivers or Service Packs and finding a way to install FAT32X support.

But your story is too light to offer more.
Collapse -
I'll try Dell support
by eclectoman / December 10, 2009 2:48 AM PST
In reply to: 2 issues.

Thanks for the link to Dell. I'll try some of their updates when I get home tonight.

I tried the suggested Google search but didn't see much that seemed related to my problem or that I understood. Was there something specific you found that I should look at?

XP came factory installed. I've been updating regularly and have SP3 installed. In the back of my mind I'm wondering if that could be the problem, as my external hard drives were, I'm pretty sure, installed before SP3. They work fine.

Too light? Please let me know what other details I can add.

Collapse -
problem solved
by eclectoman / December 11, 2009 8:53 AM PST
In reply to: I'll try Dell support

Ran Dell diagnostics....problems on the hard drive. Ran chkdsk (took forever)and it repaired restored the hd. Plugged in the flash drive and it worked like a champ.

Apparently, the corrupted sectors on my hard drive happened to be those that windows needed to find the drivers to install the flash drive.

Popular Forums
Computer Help 51,912 discussions
Computer Newbies 10,498 discussions
Laptops 20,411 discussions
Security 30,882 discussions
TVs & Home Theaters 21,253 discussions
Windows 10 1,672 discussions
Phones 16,494 discussions
Windows 7 7,855 discussions
Networking & Wireless 15,504 discussions


The most beautiful phone ever has one wildly annoying issue

The Samsung Galaxy S8's fast speeds and fantastic curved screen make it a top phone for 2017, but the annoying fingerprint reader could sour your experience.