I have a Mac pro computer and a new Samsung LN40C630 TV. I hooked up my computer to the TV using a DVI to HDMI cable and I'm not getting great results. Initially the Mac Pro set the image for overscan. If I turn off overscan the image is quite a bit smaller than it should be on screen. Is there a trick to getting this to work?