Headphones & Mp3 Players forum

General discussion


by _Fatal_ / May 3, 2007 9:50 AM PDT

Hey guys.

I have purchased a 6GB philips GoGear mp3 player. and whenevr i turn it on it displays the error message "Please Connet Device To PC" I thought okay then.. Sounds simple. But no... It doesnt recognise it. Im going on holiday tommorrow and i need help! fast. Not in up 4 bussiness days like philips support.

Regards. Fatal

Discussion is locked
You are posting a reply to: PHILIPS HDD1620/05 ERROR MESSAGE.
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: PHILIPS HDD1620/05 ERROR MESSAGE.
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Popular Forums
Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions


Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?