Computer Help forum

General discussion

PC won't finish loading OS

My 8 year old PC has a fault. I have used the recovery CD about 20 times over the last few years but this time it won't complete. I often get to the stage of removing the CD, but during the setup, the system stalls.

Pc is an IBM Netvista 2194/18A 733mgh with 512mb ram

Sometimes it won't turn on at all and if I wait a few hours it will. Sometimes it completes the re-install of windows, but it's in safe graphics mode. I can access the control panel but can't change the screen resolution.

I did a surface scan and it found one bad sector . As I had two hard drives in the machine, I took out the old hard drive and made the newer, WD400, the master. I attempted to reload via the recovery disc and got all the same symptoms, right up to the safe graphics mode, including a few times when it wouldn't start and I left it for a few hours, then it would start and continue trying to install.

I flashed the BIOS, just in case it was corrupted in some way

I ran a linux os (Ubuntu) from a CD which worked fine. Including correct screen resolution. I choose to install that system and it loaded everything off the disc, then it stalled at 15%

The system ran for over 2 hours doing the surface scan and over an hour using the Ubuntu CD- which sort of suggests this problem is not heat / time related.

The new hard drive eliminates a faulty HD problem

The correct screen res of Ubuntu eliminates any graphics problem (it has a SIS 630 graphics, whatever that is)

I really would like to keep this old Pc working and fixing it increases my limited knowledge of how they work. I have no data in the PC to worry about.

Something is faulty somewhere, I hope someone here can give me a few clues.

Discussion is locked
You are posting a reply to: PC won't finish loading OS
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: PC won't finish loading OS
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
The power up issue points to motherboard, power supply or...

In reply to: PC won't finish loading OS

Something REALLY CHEAP. The CMOS battery. Try a new one.

Collapse -
cmos battery

In reply to: The power up issue points to motherboard, power supply or...

Thanks, I saw that battery on the motherboard, I'll replace it today and report back

Collapse -
no luck

In reply to: cmos battery

I replaced the battery but no change in my problem

I tried to install the Linux ubuntu OS, it went right through to 100% completed then stalled -

I decided to abort installing the linux which is totally new to me and instead use the known recovery disc and re-install windows.

I restarted with the recovery CD inserted and was told two partitions had to be moved, I assume from the failed ubuntu install.

The install went as normal up to the time to remove the CD. The system restarted and stopped with an error message ERROR 22.

I switched off and began again with the recovery disc. Everything went the same right up to the ERROR 22 message. At that point there didn't seem to be anything I could do.

I decided to format the drive, hoping to return it to out of the box condition. The format appeared to be successful.

BUT, now when I switch on, I get a message
followed by
at this point there is no further activity.

I have a feeling that GRUB is part of the ubuntu os, I think I saw it mentioned on screen during the ubuntu install.

I'm not sure what to do now, (though shooting myself or the machine has crossed my mind)

Please can anyone tell me exactly what is operating when there is no windows? I assume there is a DOS OS running, is that part of the BIOS or separate?

Thanks to anyone who takes to trouble to try and help me.

Collapse -
I see this as a choice of

In reply to: no luck

Repair or not repair. There's obviously a fault in the basic parts that are needed to power up. These are motherboard and the PSU. You took the cheapest possible part off the list so the power supply is next. We can however cheat a little here by DOWNSIZING the machine. Let's say you added a hard disk a few years ago. Let's unplug that and the DVDROM drive you added. Also that 3D video card that replaced the onboard video.

Lighten the load?

Collapse -
Are we on the wrong track?

In reply to: I see this as a choice of

Hi Bob,

There's no dvd drive, no video card, and now only the one hard drive -so we're looking at a very basic PC tthat came with a cd burner - no dvd.

I ask, 'Are we on the wrong track'? because when I did the surface scan disc, the machine ran correctly for a few hours. I'm no computer genius but I have a good mechanical knowledge and I get the feeling this is a software glitch not hardware.

OK, I know that's not very technical, but I have a good track record with my hunches on things mechanical.

Currently my problem is that I have upset the basic operating system so that I can't even get my recovery disc to work.

Can you tell me what system is running before windows is loaded - is it a DOS system and is it in the BIOS?

How do I reset that all to original, factory condition?

Did Formatting the hard drive return it to out of the box condition?

Collapse -
If it was the OS...

In reply to: Are we on the wrong track?

Then it would not have any power up issues. So I don't feel we are on the wrong track. I may be off a little by suggesting removal of parts that are not in the machine but I am copying from prior suggestions to save me typing a custom answer. Many need help so I cut corners.

The idea is the same. Unplug what you can. Even that CDROM drive to lighten the load to give a clue it's the PSU. And even if it ran for hours the issue is the startup not once it's running. I'm going to decline writing at length why a power supply may have a hard time starting yet run forever once it's on.

Collapse -
I see what you're saying

In reply to: If it was the OS...

Ok, thanks, I see what you're saying.

I can unplug the Cd drive - but then will have no way to load windows back onto the pc and currently I appear to have upset the basic operating system that gets it all started.

I'd like to explain the problem again here, in case I have missed something important.

For a while the PC has shown evidence of a problem or virus, I run NO virus checkers, firewalls etc on it, for 2 reasons - it makes it faster and if it gets infected I just use the recovery disc and reset everything (it's not my main PC which does have anti virus and firewalls etc).

The problem showed up by seeming to have very low memory. It has 512mb RAM and has usually been very good. The recent result would be after an hour or so, either locking up so that the mouse wouldn't move or it would automatically close all open browser windows. A restart always fixed the problem and it would then begin to show it was running out of memory in exactly the same way and another restart would fix it again.

Eventually I decided it was time to use the recovery disc again - but this time it wouldn't install properly and after trying to install perhaps 2-3-4 times it would show a black screen and restarting would not help, but waiting many hours- usually overnight, would then allow it to startup and I would try using the recovery disc again - sometimes it would install to something that looked like safe mode, the lowest screen res which was not changeable. When it did that it continued running but I couldn't find a way to get it out of that mode.

I then tried to install ubuntu, in case my recovery disc is faulty.

Having similar problems installing ubuntu at least suggested that the discs are OK and that it's the PC.

If it's a power supply/motherboard problem then it looks as if sometimes it's heat related - whats my next step?

I do think I have to get the BIOS or whatever the basic internal system is, working again because I can?t check anything with this GRUB message holding things up.

I appreciate your help Bob, I?ll try not to be a PITA

Collapse -
Not a PITA.

In reply to: I see what you're saying

"Having similar problems installing ubuntu at least suggested that the discs are OK and that it's the PC.

If it's a power supply/motherboard problem then it looks as if sometimes it's heat related - whats my next step?"

Let me pare it down to the above.
-> If it's heat related, removing the case cover usually gives us a clue since it will run longer.

But it's not a matter of running longer from what I read but even starting from cold. This pointed me to the usual MB or PSU fault. The CMOS battery can stop a machine from starting and being so cheap I go for that first. Next is the PSU since it is the next cheapest part. The mainboard would usually mean its cheaper to replace the machine.

Tell me if I misread the non-starting issue as not a hardware issue but the OS didn't load. I reread the post and it looked as if the machine wouldn't turn on.

Try the cover off test.

Collapse -
It turns on OK

In reply to: Not a PITA.

"Tell me if I misread the non-starting issue as not a hardware issue but the OS didn't load. I reread the post and it looked as if the machine wouldn't turn on.

Try the cover off test."

The machine always turns on.
At first I couldn?t get the OS to complete loading, now I?m stopped with an error message before even getting to the loading of the OS ? most likely my fault for swapping to linux and back to windows- the PC is confused.
The case has been off ever since I swapped the hard drives when the original HD had a bad sector, which I thought might be the problem.

When the machine locks up/freezes, or gives black screen on startup, the fan and HD are still spinning and the green power light is on, which is what makes me think it's a software problem.

I live in tropical Cairns; room temp when I am testing is 23-26C. Lowest temp overnight was about 20C, we've just started getting cooler weather, last nights min was 18C

I'm sorry if my first post gave the impression the machine is switching off, that's not the case and I really think this is a glitch in the software at base level. Of course I suppose that glitch could be caused by a hardware problem - but I would like to try and at least get back to when I had it running in what looked like safe mode - I could then let it run for a couple of hours and prove/disprove the heat related theory

I have reset the cmos. On startup I see several lines of normal start up things then it still gives this message -
followed by
at this point there is no further activity - I left it running for 2 hours yesterday to make sure.

How do I reset the basic operating system ? Flash the bios

Collapse -
OK, I did misread this.

In reply to: It turns on OK

Loading the OS is done per the makers instructions. In a nutshell for the Windows RETAIL CD I just remove all the partitions from the hard disk by booting my XP SP2 CD and using the installer to do that. No need for me to detail this as it's all over the internet.

Remember to unplug those USB printers and such since during install Windows is not ready to handle that.

Collapse -
What's before the OS

In reply to: OK, I did misread this.

My windows ME is on the IBM Recovery Disc, of which I have made a copy to check it was all readable.

My problem now is that the PC is stopping with the GRUB error message before getting to the loading of the Recovery Disc

Should I flash the Bios again? I did it before attempting installing the Linux OS

Or how do I reset whatever is operating on startup before the Recovery Disc is recognised? This is where I have always thought the problem was.

Collapse -
No need to flash the BIOS. Now that I know the OS...

In reply to: What's before the OS

Since it's not XP we have to fix the MBR ourselves. Here's how.

Go get the DOS BOOT DISKETTE from The Windows ME one will do fine. Boot to the A:\> prompt and then type...


This will rewrite the boot record. Now run FDISK and remove the partitions that you made with Linux then try the restore CDs again.

-> Sorry but I only know what you reveal here. Those words in red are there so we save having to ask the usual questions.

Collapse -
will try boot disc again

In reply to: PC won't finish loading OS

Sorry about that, I thought I had mentioned it was ME, I?ve re read my first post and see I didn?t.

The boot disc from is already sitting in A Drive!! I downloaded it and tried to restore the MBR before coming on this forum, it didn?t help the problem at all ? but I haven?t used it since ? thanks, I?ll report back, hopefully with good news.

BTW I found out about the above from a Google search which pointed to this forum. The post was so helpful I decided to try and enlist some help here myself.

Collapse -
Going Backwards

In reply to: PC won't finish loading OS

I can't get the PC to recognise the floppy.

On startup it either ends up with the GRUB message or it says "primary IDE channel 80 conductor cable mot installed"

I've tried both the boot disc and also the flash BIOS disc and neither are recognised- I get an error message telling me the floppy is not working - I've tried changing the setting in the F1 startup menu to boot up with floppy enabled and disabled, with no luck.

Are we looking at a computer meltdown here or is it just me stuffing things up?

I've checked that all cables are connected, of course and given them all a wiggle and a push.

I ggogled GRUB and it is a linux thing as I thought and resides on the MBR.

I'm going to insert the linux CD again - the program runs off the CD amd also has the option to instal. I'll see first if I can run off the CD, if soo maybe I can change the MBR etc from there.

Collapse -
No luck

In reply to: PC won't finish loading OS

With the cmos setup utility 'boot up floppy' set to enabled, the system stops with error message "no 80 conductor cable installed" I also got a floppy error message perhaps because there was no floppy inserted ""662 Floppy Disk(s) Fail (80)

With the CMOS setup utility boot up floppy disk set to disabled the PC begins to fire up and halts with the GRUB 1.5 now loading, but there is no activity

The CD drive had the ubuntu disc in but it was never activated by the PC - it hadn't got that far I suppose.

It would seem that the MBR needs to be reset to get rid of the ubuntu/linux GRUB system trying to start, but now that it won't recognise the floppy I'm unsure how to proceed.

Collapse -
3 parts to make a floppy work.

In reply to: No luck

1. Floppy cable.
2. Floppy drive (connected proper.)
3. Motherboard.

There's not much else here to do. If this has failed then we are at an impasse.

Collapse -
The Rock and The Hard Place

In reply to: 3 parts to make a floppy work.

Thats where I'm stuck.

I doubt the floppy suddenly became faulty, more likely it's part of the Linux instal that is hanging everything up.

I videoed the start up (2.4mb)-
it shows the IBM logo, then some other startup info including the IDE 80 not connected signal, then all goes black and the GRUB message appears. I don't know if that will suggest any other ideas to you?

What I want to do is remove all traces of Linux from the MDR. If there was any way to interupt the load and force it to read the floppy, that would be good.

I can use F1 and change the CMOS. I've tried resetting defaults and I've tried telling it to boot from floppy but it gives me the error message as mentioned previously.

One other thing - the power switch is now just a switch - the computer shuts down on the click and I don't have to hold the button in for 5 seconds. I assume that shows how little of the startup system is working?

If you have no more ideas, my next plan is to go to the Linux forum and see if they can help. I see on Google that the Grub 1.5 loading is a familiar problem, but the solutions I read all needed a knowledge of Linux programming.

Collapse -
Part do fail.

In reply to: The Rock and The Hard Place

You have no less than 2 boot errors prior to the OS loading so it's not the OS or boot sector at fault.

-> Not all machines can be fixed at home. It may be time?

Collapse -

In reply to: Part do fail.

Thanks for your help Bob, it does look like some professional help is needed.


Popular Forums

Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions


This one tip will help you sleep better tonight

A few seconds are all you need to get a better night's rest.