First, navigate to this page:
http://www.outlook-tips.net/howto/oltoday.htm

Note towards the bottom of the page it lists "custom url". You'll see "outlook.htm" is standard.
("outlook3.htm" is summer)

You don't need to mess with the registry if your problem is the same as mine, however I wanted you to see where the "code" I'm about to give you comes from.

Open Outlook and open the folder view. Right click on "Outlook Today - [Personal Folders]"
Left click on "Properties for Outlook Today"

Left click on "Home Page" tab. Scroll to the end of the home page URL. Mine indicated "outlook.htm" even though all my registry entries showed "outlook3.htm"

Change "outlook.htm" to "outlook3.htm" Click "Apply"

In case you accidentally mess it up...
My "Home Page" address now reads (all on one line):
res://C:\Program Files\Microsoft Office\Office\1033\outlwvw.dll\outlook3.htm

This fixed the problem for me. Hope it works for you.

Incidentally, I'm running Windows XP Pro & Office XP Pro (which is Outlook 2002)