Networking & Wireless forum

General discussion

NVIDIA nForce MCP problems

NVIDIA nForce MCP problems

I have a big problem. I'm trying to connect to the internet by using ethernet instead of USB.
I got all the drivers for my ethernet card and everything is looking great.

But then I get this crap about having limited to no connectivity. I try to repair this by clicking "Repair."
After about 5 minutes it says that it cannot fix the problem because it cannot renew my IP address.

I tryed releasing and renewing my IP address by using the IPCONFIG commands. Again, no luck. I got this error message:

" An error occurred while renewing interface Local Area Connection 2 : unable to contact your DHCP server. Request has timed out."

And now I'm here asking for help.
If anyone can help it would be greatly appreciated.
Thanks

Discussion is locked
You are posting a reply to: NVIDIA nForce MCP problems
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: NVIDIA nForce MCP problems
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Re: NVIDIA nForce MCP problems

In reply to: NVIDIA nForce MCP problems

Here's the deal. Around here, PCI network cards on sale are 4.99 or less. Even daily prices are under 9.99. While it would be nice to get your onboard card to work proper if that is the issue, I always pull out a network card and use that to see if this is the issue.

Sometimes you have to bow to the reality that a cheap fix is the way out. Also, a so-so ethernet cable can cause this or a failing port on the router or a router that needs a firmware update. Given today's bargain prices, support seems non-existant.

Bob

Collapse -
NVIDIA nForce MCP Network Controller

In reply to: NVIDIA nForce MCP problems

I have had almost exactly the problem you describe. The network controller keeps grabbing an invalid IP address and cannot connect to my broadband ISP (RCN). RCN tech support believes it is a compatability issue with this particular network controller. The PC mfr. (emachines) says they've never heard of such an issue and that I should try another ISP. (Gee, thanks.)

I think I'll go with installing a new network card. Did you try that (as recommended to you back in November)? Did it work?

Thanks.

Collapse -
Me too!!

In reply to: NVIDIA nForce MCP problems

I'm having the same problem with my ethernet card, I keep getting an incorrect IP address of 169.254.0.0, are you getting the same incorrect IP? I think the MAC address is having a problem, because it's not showing a Physical Address, it's displaying 00-00-00-00-00-00 for a Physical Address, (which is the MAC address for the ethernet card). If you have found a solution for this problem, could you please share the solution, I'd really appreciate it. The only way I can connect to the internet right now is to have a connection to the ethernet card from a Linksys NR041 router, which I don't like, 'cause I can't send or receive files with friends because of the firewall in the router, and I can't figure out how to disable the firewall in this router... If anyone can be of some help with that, I'd really appreciate that as well. The only reason I can get a connection with the ethernet card from the router, is because the connection is using the MAC address of the router to obtain a valid IP address.

I would appreciate some input on both of these matters, whatever they may be... Happy

John @ John-Kupel@nycap.rr.com

Collapse -
Me too!

In reply to: Me too!!

I installed my old 3com NIC in the new machine and got a connection. (I think I had the same or similar invalid IP number coming up. It began with 169.) eMachines sent me a generic network interface card (D-Link by Realtek), but it didn't work either. I guess my ISP tech support was right: it's a compatability problem with the cable modem they supplied. If I ever switch ISP's I will try the nvidia controller again. Until then, I'll just stick with what works. So I suggest trying another network card. I've been told Linksys and Netgear usually work with my particular ISP (RCN), but 3com also works. Hope this helps.

Collapse -
Nvidia Nforce network probs

In reply to: Me too!

just to back up the last post. I had intermittant connection problems using this controller always thinking that my ISP was the problem, ringing up having my connection tested... When it was working it was on fire (not literally!), but i became so annoyed with being disconnected every hour or so or not being able to connect at startup, i bought a seperate pci network card. Although noticably slower i haven't had a disconnection or non connection on startup since. So much for onboard controllers!!!

Collapse -
get a router.

In reply to: Nvidia Nforce network probs

Get a router/switch properly solve most of the problems.

Collapse -
Router?

In reply to: get a router.

Wouldn't this slow my connection down further, runscape?

Collapse -
nVidia nForce Networking (or should it be Notworking!)

In reply to: Nvidia Nforce network probs

Hi,
Its good to see that other people are seeing the same problem. I am running a ShuttleX 85G - Onboard enet - It works fine when its locked to 10FD, run at anything else and it falls over. Its not the switch (Cisco), its the adapter...
What do nVidia have to say about this I wonder...

Collapse -
disable checksum offload

In reply to: NVIDIA nForce MCP problems

My problem was whenever i tried to receive some big files (more than 500mb) over ftp or lan my network connection completly hang up.
After two clean installs of windows, one visit at the computer retailer etc i found first solution - as told in yours thread - unpluging power suplly from computer.
Today after some extensive search over the web i found the better solution:
- disable chechsum offload (go to device manager, find networking controler, click properties, it is on the advanced tab) - to this moments it is working fine (i just transported 4gb fil from one computer to another)
1. i'm not sure this will solve yours problems but i'm searching web for solutions of my problems for one week, and found there many different problems (as yours) which can be solved by unpluging power suplly. As I think this problems are not just with nvidia4 chipset but also with 3 and maybe even some other chipset
2. if you need more information about checksum offload use google and you will find some microsoft articles about it and many threads

Collapse -
checksum

In reply to: disable checksum offload

Haveing same prob went to device manager found networking controler clicked on props on advanced tab no chechsum ?

Popular Forums

icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

SMART HOME

This one tip will help you sleep better tonight

A few seconds are all you need to get a better night's rest.