General discussion

Number keypad problem

After a reformat and installation of XP_SP2 I have the same problem on two new keyboards. A new bog standard UK keyboard with the number keypad on the right
= "Standard 101/102-Key or Microsoft Natural PS/2 Keyboard", and another new usb wireless keyboard of similar layout, = "Logitech HID-Compliant Keyboard". The NUM Lock key is on at boot up but the number keys will not work. If I take the NUM key off the alternative keys do work! I have tried setting XP to 'English keyboard' and 'English extended keyboard" neither make any difference. I feel some system file is missing on boot up. Help would be welcome to solve this annoying problem.

Discussion is locked
Follow
Reply to: Number keypad problem
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Number keypad problem
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Did you try the numlock on/off option?

Type XP NUMLOCK BOOT OPTION into google.com to find out how to set XP to set this at boot but most of the time this happens when you install a keyboard driver or enhancer. Fix? Don't use such or ask the keyboard maker for a fixed driver.

Bob

- Collapse -
Num lock itself not a problem

The NUMLOCK key works and I can lock/unlock the Num pad. The numbers, however, do not work as intended, when the NUMLOCK is on. I would dearly like to have this option to work. (The Logitek software lets me see on screen when certain keys are set as well as extended function keys.
Your help most welcom

- Collapse -
Sorry, I can't fix Logitech's buggy drivers.

All I can note is I don't use them and don't run into this issue on machines I don't install them.

This issue is for you and Logitech to resolve.

Bob

- Collapse -
do you have logitech setpoint installed?

Because if you do, that might be the problem. I just received a logitech bluetooth mouse for Christmas and when I installed setpoint the mouse stopped working. But when I uninstalled it everything worked perfectly again.

- Collapse -
I'm confused.

It seems you haven't taken Bob's advice any further, but I'm still confused about the problem.

On my keyboard, with the Number Lock engaged, the number keypad becomes a navigation keypad, eg the 8 key is the Up arrow key, the 6 key is the Right arrow key, etc.

But with the number lock dis-engaged, the number pad becomes a....... number pad.

Is that not happening to your keyboard?

Mark

By the way, look inside your BIOS for Number Lock options.

- Collapse -
Num Lock

OK I unstalled the USB keyboard and replaced with bog standard, XP chose the drivers, but got same problem, I guess something must me missing in XP.

My nums lock works the other way, ON for NUMBERS< except I don't get them.

If I use the Logitech software I get extra keys and a screen warning that the NUM LOCK is ON or OFF. Both bits of hardware have worked before my reformat, that's why I suspect some software is missing.

- Collapse -
Since you use the logitech software, all bets are off. link
http://support.microsoft.com/kb/826127 describes a bug Microsoft only fixes when a person encounters it. Yes, such things do happen in XP as well.

"Drivers associated with Compaq's multimedia keyboard features are inadvertently addressing the Kinesis keyboard's memory chip. There are several ways to solve the problem."
As an example there are numerous issues with such things.

Tell me what's in this registry key.

http://www.microsoft.com/technet/prodtechnol/windows2000serv/reskit/regentry/34674.mspx?mfr=true

Yes, same key for XP.

Bob
- Collapse -
its not the software

there is something in windows called stickykeys.
click somewhere on te desktop and press the shift key 5 times. yes 5.
all gamers know about stickey keys!!

anyway pressing shift 5 times turns stickeykeys off same with with 5 times turns it on.

go into the settings. takes you to an accessibility options page. in there i am sure you can fix your numberkeys problem!
its happend to me many times before.

basically you want to disable stickey keys on the keyboard tab. Happy

hope this helps

- Collapse -
humm

could be related to the account not sharing the same settings or sharing the same files as the other uses in the account settings.
maybe there is a program conflict. IE antivirus software
or svchost stops responding when closing program files.

- Collapse -
Sticky keys AV conflict?

Thanks for that suggestion, all seems ok, I like the idea of a beep when caps lock or num lock is set otherwise everything is off.
Checked the logon accounts, only one is set as admin. I am running AVG as A.Virus, and have both Firefox (default) and IE. Do you think there are any conflicts there?

- Collapse -
check accessibility

I had the same problem.
go to accessibility options
go to tab MOUSE
uncheck the Use MouseKeys
push ok
now your problem is fixed
the keypad wil work normal again.

CNET Forums