Question

Not Able To Access IIS Web Server Externally

For 4 days, I have been trying to get my IIS web server to work! I am able to access the website internally through the internal static ip address 192.###.#.201 from different devices on the network. I have setup port forwarding on my Verizon router to forward all incoming requests from the external public to the internal port 80 on the Windows 10 desktop where my IIS server is sitting. I have completely turned off all firewall settings and anti-virus applications/processes on my Windows 10. Even after having all these doors being opened, still every time I access the website through the url http://public-ip-address:port# I got the "This site can't be reached" message. I tried to open the url with both IE and Chrome browsers. But none of them work. From the public, I have no problem accessing other web servers which are connected to the same Verizon router that send and receive communication through port 80. So, clearly there is either something wrong with my Windows 10 or the setup of my IIS server. Or it could be that the router has trouble forwarding the port. I am just guessing. I don't know. It has been 4 days and countless hours, but I am still not able to find any clue to why this is happening. Could someone who has been through similar situation help me out?! Thank you for all of your help!

Discussion is locked
Answer
Follow
Reply to: Not Able To Access IIS Web Server Externally
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Not Able To Access IIS Web Server Externally
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Answer
A few questions.
- Collapse -
Reply

1. Are you trying that on your LAN? If so, that's not always supported with all routers.

Reply: I am able to access it from LAN. The problem is that I CANNOT access it from WAN.

2. You can't use port 80. Read from https://www.google.com/search?q=Does+Verizon+block+port+80%3F&gl=US

Reply: That Google thread is wrong. Because I am now having two webservers running on port 80, and I can access them with no problem from WAN.

- Collapse -
Then the problem is elsewhere.

Repeat what works. I can't guess what the issue is with your new setup since your old setup works.

As to the access it from WAN, that needs more definition. I had a client that didn't understand their router did not redirect their external IP request back to them. I showed them the site worked on my phone (not using their network) and let me be clear, I do not offer a fix when the WAN request doesn't redirect. That's very hit and miss on routers so when that happens you find the owner/client reluctant to change routers so you know to close the call.

- Collapse -
Let me expand a little.

1. If you are on your LAN for Internet access it's iffy if you can put your public IP and port and the router work correctly. It's so iffy that I no longer consider this viable. For my test I use my phone that is NOT on the network where the server lives. I test it using my phone's cellular data connection.

2. You mention you have two other sites up. Since we can only redirect one port 80, how do you get more than one?

3. Also, since http is pretty dead, how did you handle https on port 443?

- Collapse -
RE: Proffitt

1. If you are on your LAN for Internet access it's iffy if you can put your public IP and port and the router work correctly. It's so iffy that I no longer consider this viable. For my test I use my phone that is NOT on the network where the server lives. I test it using my phone's cellular data connection.

RE:
Why it is iffy if I am on my LAN and able to access the IIS website with the public IP address and port?
I did try using the cellular data connection from my Samsung Galaxy to access the IIS website. But I got the "Page cannot be displayed" message.

2. You mention you have two other sites up. Since we can only redirect one port 80, how do you get more than one?

I went into the Port Forwarding section of my Verizon router setting, and I saw two separate Port Forwarding settings, both were forwarding TCP port 80 to the public. These are not HTTPS port binding. They are just the HTTP websites on my home surveillance camera systems.

3. Also, since http is pretty dead, how did you handle https on port 443?

These hidden camera system websites do not use HTTPS. So if you type HTTPS://RouterPublicIPaddress:Port# into the URL box of the browser it will automatically be converted over to HTTP.

- Collapse -
Sorry

1. But to get into item 1 we would be in a classroom where I show it working and not. This is where I'll share how I test and never enter into the tar pit that this is.

2. You mentioned other web sites are up. Then you mention the HTTP of your security system. A port forward can only do the forward ONCE for each port number so if you use port 80 for your cameras, then you can't forward to your IIS server.

I consider this case explained at this point. You can only forward to one IP.

- Collapse -
Question

I might have understood port forwarding incorrectly.
Below are settings from the port forwarding page on my Verizon router.
I am able to access both of these websites at the same time from the browser.
Do these settings mean that both port 80 on my hidden cameras are being forwarded to the public by my router at the same time?

Networked Computer / Device-------Applications & Ports Forwarded

TT522PW-PRO-----------UPnP IGD TCP 8150
192.xxx.x.xxx:80-----------TCP Any -> 8150

PLC-128SPW--------------UPnP IGD TCP 8151
192.xxx.x.xxx:80-----------TCP Any -> 8151

Post was last edited on June 24, 2019 6:25 PM PDT

- Collapse -
That's good to know.

Since the first post you wrote you forwarded port 80. After all this you are forwarding not 80 but 8150 and 8151 which means my first reply about blocking does not apply.

Since I can't know what you were doing and take your word as-is then we have a mess on our hands.

It also means that we can't put the external IP into a web browser and have it work. We would need to add the port modifier to the URL for this to work. Which I saw no sign of the modifier in the previous posts.

Example URL: http://10.0.0.99:8150 (for TT522PS-PRO)

Change the IP to your external IP as required.

Post was last edited on June 24, 2019 9:35 AM PDT

- Collapse -
Why not use Port 80?

Just forward Port 80 to 80 of the IIS server like everyone else.

- Collapse -
I did that too

Post was last edited on June 24, 2019 3:35 PM PDT

- Collapse -
And let's not forget that...

http:\\internet.ip\ doesn't always work on the LAN.

I hate to write this but close to a dozen times I've been on a call about that. So I pull out my phone, use it's cellular network and it works. At that point we close the call as not one person wanted it fixed if it meant getting a router that allowed this.

- Collapse -
Problem Solved!!!

Problem finally solved after 8 days with countless debugging hours!!!

The key word is "Any"!

Thank you R. Proffitt for sticking around to help me out!!

Networked Computer / Device........Applications & Ports Forwarded
192.xxx.x.xxx:80........................................Destination Ports 8156
.......................................................................TCP Any -> 80

Post was last edited on June 24, 2019 6:31 PM PDT

CNET Forums