Cameras forum

General discussion

No usb port found

by karma / November 5, 2004 10:10 AM PST

After trying numerous times to connect my digital camera (olympus) to my computer to download photos...all I get are error messages that the usb for the camera can't be found. Olympus claims it's a microsoft problem...Microsoft claims it's a Dell problem. Dell doesn't know what my problem is. Anyone with any experience hooking a usb from camera to PC and actually getting it to work would be a great help.

Discussion is locked
You are posting a reply to: No usb port found
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: No usb port found
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Re: No usb port found
by R. Proffitt Forum moderator / November 5, 2004 10:21 AM PST
In reply to: No usb port found

If you can't find such on your machine, then it's either disabled, the BIOS is out of date, the OS doesn't support your USB (Examples abound!) or other.

I cut my time loss by adding an USB PCI card.

More clues at


Collapse -
no USB found
by exiler / December 24, 2004 12:10 AM PST
In reply to: No usb port found

I also have a problem tranferring from my Olympus
digital camera. I hope some one will be able to help.
I am working on Windows XP SP1. When I first tried to
transfer pictures from my Olympus when the computer
was new,the pictures transferred through the USB port
with no problem.
I then added a printer to the USB port and worked fine.
I added a Zip drive to the other USB Port and that also worked fine.
When I went to transfer pictures again, I had to disconnect the Zip drive from the usb port and connect
the camera to the port. It would not work. I checked
device manager and it did not list the camera in that port but the Zip drive,even though I had disconnected the device. I restarted the computer with the camera
connected to the USB port and still it did not work.
Device Manager still listed the Zip drive in that USB
Port. The transfer worked fine before I used the USB ports. It seems that it always recognizes the Zip Drive
and not the camera.
The Camera and drivers are listed in device manager but
not in the USB Port.
Anyone,please help.

Popular Forums
Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions


Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?