Question

No sound when using rx580 8gb hdmi to tv

I am trying to get audio through HDMI to a Samsung TV.

PC parts:
AMD Ryzen 5 2nd Gen 3400G
MSI Radeon RX580 8Gb
MSI Carbon x370 Gaming Pro (BIOS up to date)
16Gb RAM
Windows 10 x64 - 1909 (up to date)
Adrenalin 2019 Edition 19.9.2(WHQL) also try with Adrenalin 2019 Edition 19.11.3


Here are the details and issue:

Without GPU: If I use integrated graphics rx vega 11, the sound works fine hdmi to TV.
With GPU: If I connect hdmi to tv, video works fine but no audio, I have try both hdmi ports on rx580.
I have tried with both drivers, using DDU to switch between drivers.
With GPU: If I go to the sound icon, I can only see Digital Audio(S/PDF), I cannot see the TV listed as an option for audio output.
Without GPU: If I use the integrated graphics, If I go to the sound icon, I can see the TV as default and the Digital Audio(S/PDF).
I have another rx580, and the same issue with both cards.
With GPU: If I plug an USB headset, audio works fine through USB.
With GPU: if I go to device manager, under Sound..., there is only 1 device listed.
When I go to Radeon settings, System, Software: AMD Audio Driver Version: 10.0.1.12

Initially Y built the PC with all the parts listed, when I notice that there was no audio,
I uninstall the GPU and use integrated and the sound worked without GPU.
I then went to safe mode, use DDU, uninstall drivers and shut down, I reinstall the GPU but same issue, no audio.

Any help will be greatly appreciated!

Post was last edited on November 30, 2019 5:48 PM PST

Discussion is locked

Answer
Follow
Reply to: No sound when using rx580 8gb hdmi to tv
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: No sound when using rx580 8gb hdmi to tv
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Answer
Remember I only supply new ideas.
- Collapse -
No luck

It did not worked.

Here are some things that I have tried:
Downgraded BIOS 2 versions,
CPU stop working,
used and an old CPU (AMD A8),
Thee was sound coming from the GPU,
upgraded BIOS 1 version,
Still using A8, there is sound in GPU,
Switch back to Ryzen 5,
Won't boot (MOBO is from 2017ish and CPU from 2019, there are some know issues)
Switch back to A8, upgraded to latest BIOS,
Again no sound.
I need the lastest BIOS because it works with ryzen 5 but it cause problems with GPU.

- Collapse -
Sounds (pun not intended)

As if you need to clarify if this works with the motherboard maker.

Remember we can't change CPUs and run the same install of Windows. Windows tailors itself to the system so if you swap CPUs etc, you have to deal with the motherboard drivers.

CNET Forums

Forum Info