Question

No image on screen and no USB power after booting.

I turned off my PC during a Snow Storm because the power was flickering. My PC came out of sleep state and then I turned it OFF, all was good untill the next day when I powered it up, the processor fan, all case fans, power supply and videocard fans were all running, the HHD LED was working, the motherboard LED was On but there was no display on my monitor and no power to the keyboard, mouse and WI-FI USB dongle. even the front USB ports are not working. Is it my motherboard that is fried? I have Windows 10 64 bits and a MSI 970 Gaming motherboard.

Discussion is locked
Follow
Reply to: No image on screen and no USB power after booting.
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: No image on screen and no USB power after booting.
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Answer
Sounds like a hung boot.

There are many steps to booting. Did you manage to get to the BIOS?

What can you unplug?

- Collapse -
can't get to the BIOS

because I have no image on the monitor

- Collapse -
So the dead PC?

Google The Dead PC
or Troubleshooting The Dead PC

And you find the usual advice. In short you downsize it till it works and if not you start with just the motherboard and PSU on cardboard and test for power up. Add one part at a time till you find the issue. Of course you know what to expect from the machine with so few parts.

OK, that's that angle.

You didn't reveal much about the PC or story. At years old I would write about popping a new CMOS battery in there. There are folk that ask me how to test the common CR2032 and frankly I never do that. Why? Watch this to see what a proper test entails. For me, I pay the dollar.

- Collapse -
Answer
unplug the computer for an hour

then try again. The PSU might have flipped a reset inside and unplugging will speed it's reset.

- Collapse -
almost there!

Thanks for your tip, I unplugged the power supply and removed the battery and waited a few hours. Now the PC boots and I see Something on the monitor screen but Windows won't boot, it brings me to a blue screen saying Your computer has a problem and must reboot, maybe the boot sector of Windows is corrupt.......at least it booted.

- Collapse -
do you have a windows install disc?
- Collapse -
Yes I have a recovery disk but,

the repair utility won't work, command prompt to fix the boot sector won't work so I thought about reinstalling Windows but the option where you keep all your files and programs.

- Collapse -
be careful

If you could use a boot disc with a file manager and back up your personal files first, that would be safest. I'm wondering if the drive may have a problem. Look at the drive, see who the maker is, then go to that drive manufacturer site and get their diagnostic software, usually bootable from a CD or DVD. It can check the drive, just to make sure a reinstall won't go badly. If the diagnostic software shows a problem with the drive, then replace it, install your windows to that. You can later use an USB device that will allow you to "slave" the drive and pull your data off it, since it will bypass the boot sector, often allowing full access to the failing drive.

- Collapse -
forgot to mention

that my Windows is installed on two Sata-3 hard drive in RAID 0, all my files are on different hard drives so I can reformat without losing anything but Windows and my programs. What I don't understand is that I can see all my HHD in the BIOS and in the RAID configuration window I see my RAID 0 and it says fonctional. When I try to recover Windows from the bootable repair disk it says that a media driver is needed, when I point to a USB drive with the RAID drivers it says that it's not the files needed???

- Collapse -
Just a note about this.

I missed what changed to get you to the BIOS where you couldn't before.

As to the wrong drivers on USB some machines demand I put these on CD since the ports need drivers too. Painful machine. As you did install Windows before you have to recall how you did that and repeat. If this was setup by Dell or such, they usually don't tell you what they did.

But the message is typical and only means we're back to the maker for how to make that stick or CD and what goes there.

- Collapse -
Answer
I am desparate

Since I could not boot to Windows 10 I decided to format and reinstall Windows in new. I deleted my RAID Array and set it again, created a bootable Windows installation USB drive. When I get to the page where you select the partition where you want Windows to be installed I see my HD, click on it and click on Next but it always says: ''We haven't been able to create a partition, nor locate an existing partition'' what should I do?

- Collapse -
This one is special.

To install W10 to drives on a RAID system requires the maker to tell how. There is no unified general answer to this one. Some require setup in a RAID BIOS, others have you put drivers on CD/floppy or other. It's all over the map.

Sorry you've been working at this so long courrielbidon, but you may want to move off RAID if reinstalls are too difficult.

- Collapse -
Starting to see some light

So after restarting my PC 100 times and trying all kind of things I was finally able to install Windows in RAID0 mode, I had to disconnect my two storage drives, they were the ones interfering. after doing Windows updates I decided to reconnect my two storage drives and after booting I got a blue screen, in the BIOS only one storage drive is shown so there may be a dead SATA port. I will try to plug the drive on another port and see what's going on.

- Collapse -
Answer
Problem solved

The problem is a dead SATA port on the motherboard, I hard to switch one storage hard drive to another port, I canceled one of my DVD drive but anyways I don't use them very often anymore Wink now my Windows boots fine and I see all my drives. So I guess I reinstalled Windows for nothing since it was a dead port I could have just unplugged the faulty drive and my Windows would have booted fine! thank you all for your precious helps and support.

- Collapse -
Great

A problem I heard for the first time. who knows how much more different things we'll see with these computers. Happy

CNET Forums