Windows Legacy OS forum

General discussion

No Desktop Icons or toolbar

by ib3ck / April 5, 2009 2:12 PM PDT

Hi. Im new here =]

My desktop computer is a windows xp and i turned it on recently and the desktop icons and toolbar are gone.

i looked around a lot of forums(including this one)


they told me to run explorer.exe through the task manager but it says it cant find it.

others said reformat, we dont have the windows xp disk, and i doubt we even own it any more.

So, are there anymore solutions?

Discussion is locked
You are posting a reply to: No Desktop Icons or toolbar
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: No Desktop Icons or toolbar
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Do this
by Techie_Master / April 5, 2009 8:57 PM PDT

1. When you boot your computer click on blank screen ALT+CTRL+DELETE button,if you get the task manger window, create the new task , type explorer.exe and enter.

2. Boot you computer in Safe mode and scan your computer by using malwarebytes.

3. Repair your XP for Windows XP CD.

Collapse -
No Desktop Icons or toolbar
by ukdback / September 20, 2009 3:45 AM PDT

Similar problem. Whilst updating Flash stuff(I think it was) my computer closed and rebooted itself since when (2 weeks ago) I have had no icons, taskbar, start button or anything else apart from the wallpaper. Right-clicking achieves nothing. I am coping using task manager to open files but miss the ease of shortcuts, search and control panel which I don't know how to get to. If I go to Windows and try to open explorer.exe it says 'Cannot access; you may not have permission'. Running XP on a HP Pavilion 754n, no rescue CD available.

Collapse -
Tried Using System Restore Like This..?
by Grif Thomas Forum moderator / September 20, 2009 5:02 AM PDT

A couple of ways to get there.. First, press the "Windows key" which is between the "Ctrl" and the "Alt" key in the lower part of your keyboard. The windows start menu should show up from you need to use your mouse to select "All Programs-Accessories-System Tools-System Restore.. Once the System Restore window loads, select "Restore my computer to an earlier time", click "Next", and at the next "Calendar" windows, choose a bold date which is before the problem occurred.. Click "Next", then follow the prompts to restore the computer to a time when things were good.

If the Windows key doesn't get it done in "normal" Windows, then restart the computer into Safe Mode and see if the taskbar or the Windows Key works there.

Hope this helps.

Grif

Collapse -
Tried Using System Restore Like This..?
by ukdback / September 21, 2009 2:41 AM PDT

Many thanks for taking the time to reply to my problem. I did try System Restore when it first happened. Just got a null response, don't remember the exact wording. Tried several different dates too.
Also tried several times a Safe Mode startup. After lots of scrolling referring to multi-disk partition files I end up with a C: prompt headed CMD.exe but can't get beyond that.
Also tried a regedit 'fix' which I read on another Help site but that didn't work.
Finally tried the suggestion above about opening a notebook file but couldn't fully understand how to save a *.scf file and what to do with it after that!
Oh well, thank god for Task Manager at least. Maybe I just need to buy a new XP disk and re-install.

Collapse -
ANY Symantec, Norton, Mcafee or other titles?
by R. Proffitt Forum moderator / September 21, 2009 2:54 AM PDT

Symantec and other suites now turn on "product protection" or similar names that disables System Restore. It's a shame each of these companies don't warn owners about it but without fail, 100% of the time I get a "you got to be kidding me" reply when I show this to them.

-> Google about it -> http://www.google.com/search?hl=en&source=hp&q=Norton+System+Restore
Bob

Collapse -
ANY Symantec, Norton, Mcafee or other titles?
by ukdback / September 21, 2009 5:35 PM PDT

Very interesting and alarming info. However, I don't have any Norton or whatever stuff running. I retried System Restore using dates going back prior to my problem and as far back as July. No error messages when the program apparently ran and rebooted but still came up with a blank screen.

Collapse -
Are you " ib3ck"?
by R. Proffitt Forum moderator / September 21, 2009 8:57 PM PDT

The idea presented applies to the OP or original poster. If you have a problem to solve, and if you are not " ib3ck " then you should start your own discussion.

The System Restore (SR) failures are caused by many things. Spybot can be included on this list but here's the deal. I sometimes need a hijackthis log to find what interferes. You would know what each entry on that log does or else you can't be sure.
Bob

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

CNET FORUMS TOP DISCUSSION

Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?