General discussion

no copying/moving data from my external hard drive

Hey there, I'm new here
so, I have this problem with my external hard drive, I can't copy or move some data from it to any computer, and some other data just won't have any problem wih this process
I'be been told to change the cable, I changed it and the results are the same, I've tried to do Error-Checking but it takes a lot of time and at last the explorer restart itself and all the work goes away
my hard drive is Western Digital My Passport Essential 500GB
I really need a solution, cause it's getting really annoying, and if there is no solution, is there anyway that I can move my Data through any possible way?

Discussion is locked
Reply
Follow
Reply to: no copying/moving data from my external hard drive
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: no copying/moving data from my external hard drive
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Any error messages?

If you see any Access Denied error messages, use your search engine to look up Taking Ownership.

Mark

- Collapse -
reply..

there are no Access Denied messages
I can access the data, the problem is when I want to move or copy them
it stucks in the process, and then shows a message that says Try Again

- Collapse -
What message?

You didn't say the Full Error Message.

Mark

- Collapse -
Re: messages

Can you tell more?

1. Never MOVE (that implies a delete), only COPY?
2. How do you copy (copy/paste, drag and drop, copy command from command prompt). Try all three. Do all fail with the same message? What exact message?
3. What is 'error checking'? How exactly did you do it (with or without surface check)? What has Explorer to do with error checking? What exactly does "all the work goes away" mean?
4. What kind of data you can't move? If, for example, it's a Word document and you can access it, then you should be able to open it in Word and save it on your internal drive. That's the same as making a copy.
5. Can you burn that stubborn data to a DVD-RW, than copy back to your internal disk?
6. Does it happen also if you try the same on another PC (friend, family, work)?

Kees

- Collapse -
sorry for taking too long time to reply

1: I can't move or copy, I can delete normally.

2: I tried all the three ways, and all of them fails! as of copy/paste & drag and drop, in the pasting process it stucks in the middle of the process, hangs for sometime then it asks me to either try again or to cancel the process. As of copying from command prompt it shows this message "data error cyclic redundancy check".

3: I used error checking when I right click on the hard drive then Properties then the Tools tab, then there is the option to check the hard drive for errors, and then I check the two options (A: Automatically fix file system errors, B: Scan for and attempt recovery of bad sectors). I did that twice, I started the process maybe on 7:30 am, and then I checked it on 5:00 pm and it hasn't finished yet, however I let it working, and it took a lot of time when it was processing through files, I mean at 5 pm it was 423 processed, then maybe after 1 hour it went to the next file (424 files processed), although some files didn't take too much time. Then maybe on 11:00 pm the explorer showed an error message and it asked me to restart, so I restarted it, and then all the error checking working just went away!

4: Media data (movies and music), photos and text files don't have any problem.

5: I haven't tried that actually, I will try it.

6: Yes, it happens on every other PC I tried

Anyway, I googled my problem, and I found this post on another forum, it's pretty much the same problem except for that my hard drive is always detected from any PC.
http://www.techsupportforum.com/hardware-support/hard-drive-support/45879-wd-external-hard-drive-problem.html

- Collapse -
even the DVD-RW wouldn't work

I've just finished burning the DVD-RW and in the DVD burner it showed the same error as Command Prompt; "Data error (cyclic redundancy check)"
the files can be copied to the intenral hard drive, but they don't work properly.
Please tell me what to, I'm desperate! Sad

- Collapse -
Re: getting data back

It seems the files or the drive are corrupted. I don't expect Bob's Linux suggestion (see below) to work, but it's worth a try. Count yourself lucky if it works.

All you can do if that fails also: find your credit card and contact www.drivesavers.com. It won't be free, and the result can't be guaranteed. It depends on both the data and how desparate you are if it's worth the money.

My 3 tips for the owners of an external disk:

1. NEVER use an external disk as the only storage for files. Such disks are UNRELIABLE. Always keep another copy (or two!) at some other place.
2. If you're sure you don't want to change the file (such as music) set it read-only.
3. Be sure the disk has a NTFS filesystem, not a FAT32 one, if you only want to use it on PC's with Windows XP or higher.

In this case, it seems you didn't realise how useful rule #1 is.

Kees

- Collapse -
much appreciate your help

Thanks a lot for your advices, wish I knew them before :/
Anyway, I guess I'll be going to repair it at some computer shop, let's hope they can repair it Sad
And again I really appreciate your help, I'll let you know when it's fixed (fingers crossed)

- Collapse -
Time to skip Windows.

Since the copies (of what?) seem to be corrupted after a copy (until this works DO NOT MOVE FILES!) it is time to boot up Linux and try a copy there. Here's an article about this with no need for linux knowledge or skills.

http://www.howtogeek.com/howto/windows-vista/use-ubuntu-live-cd-to-backup-files-from-your-dead-windows-computer/ covers the easy version as well as what to do if the drives do not open.

Armed with this I would copy files off the drive to my NTFS C DRIVE and then exit Ubuntu, boot Windows and see what happens.
Bob

- Collapse -
re:

I will try that later, that seems a lot of time, but I hope it will work, thanks for your help!

- Collapse -
Try using dropbox for storage

My hard drive is Western Digital My passport essential 1 TB and also has the same problem. Recently I tried to upload my files which can't be copied to dropbox storage. The files will be restored as the way before it corrupted. Problems fixed. You can try this.

- Collapse -
Did you get a fix to this?

I have the EXACT sames external hard drive and I am having the EXACT same problem. Frankly, I have 185 GB of data on this thing and I have to start burning disks??

- Collapse -
Possible USB3 problem

I have the same problem when i decided to move one of my HDD from internal to an external USB3 HDD. The hard drive itself i believe is not corrupted because it was working fine in the laptop and starting to suck when copying after i starting connecting it via USB3.
So it should work with SATA cable. The problem maybe is caused by USB3 drivers, but i cant be sure about that. Just know that USB3 drivers for my laptop were a mess and i didn't fined an alternative for them.

- Collapse -
Use SHAREit

I encountered this same problem and came to this site as well as other sites but could not find anything that worked. Later on I figured that if the problem is only copying, i.e it is still possible to "explore" the external hard drive, then why not try to transfer them wirelessly since the problem could be with the usb cable.

So I installed Lenovo's SHAREit on both my laptop and a friend's laptop. Then plugged the external hard drive into my friend's laptop, navigated to where the files I wanted were, "drag-and-dropped" them into SHAREit then sent them to my laptop.

It worked for me. I also noticed that when I later plugged the external hard drive to a laptop running Windows 8, it brought up the message that says something like "there is a problem with this drive, scan to fix it". I did the "scan to fix"thing and when the process was done, the problem was gone. No more refusing to copy or move from the external hard drive.

dwinTembo from Malawi

- Collapse -
Help copying/cutting FROM Western Digital hard drive

Hi. I bought a Western Digital 1TB hard drive two years ago with the idea that I could use it to store and share my photos...had NO END of problems with it and after countless hours on the phone with WD reps, I couldn't solve the sharing problem (WD Reps: "Well, THAT'S strange; it shouldn't be doing that...").

So, now I'm trying to copy/cut my photos FROM the WD drive, but it doesn't seem to want to do that and my WD support has run out. I've tried "copy" by right-clicking in the HD, but there is no paste function. I've tried CTRLX/CTRLC and get no paste function.

Can anyone give any advice on how I can copy/cut my pics FROM my WD hard drive onto another drive, please?

Thanks a lot,
Laura

- Collapse -
To Laura

You've buried your new plea under a 7 year old post. If the replies don't help, start a new discussion.

There are many ways to copy files from one drive to another. Open 2 File Explorer Windows and click+drag from one to another and we have the command line COPY command. Some folk do not want to read web pages on command line use so you advise them to take it to a repair shop to copy the files there. Usually a tech will be versed in the command line.

- Collapse -
If it is happening with every external devices like pd,hdd

Some of antivirus programs like in my case "Quick heal" have settings to provide read only access of external devices.

So try disabling your anti virus. Also in case of Quick heal, the settings are under (External drivers and devices -> Data theft protection.)

Hope it helps.

- Collapse -
Try this

I had the same issue , After searching a lot nothing worked for me but when I tried to connect my HDD to a USB 2.0 port instead of a 3.1, it worked !

- Collapse -
Solution : might help

Hi,
Though posting late but, these copy errors occurs due to errors with the file system of the external device, most likely you plug the external HDD to windows 7 or preferably Windows 10 and just go to device properties - tools - and select and run scan and repair, once completed again try copying your files, and i bet it should work, enjoy !!
Please give your feedback, thank you

- Collapse -
Try this!

My problem turns out a corrupted teracopy software. So i remove the program and let Windows 10 handle the copy paste function. Works with me

- Collapse -
Problem for my hard drive

My problem is with my hard drive that cant paste whatever I copy to it...Cant someone tell me or advice what should I do to my hard drive...

The reason is my hard drive is problem but I tried to format it and after all it not respond

- Collapse -
Re: problem with hard drive

It looks like you need a new hard drive.
What does Windows disk management tell about it?

CNET Forums