Samsung forum

General discussion

No audio after firmware upgrade on BDP1600

by cubitri / September 5, 2009 8:17 PM PDT

I upgrade my BDP1600 to the latest firmware yesterday. The upgrade went smoothly and the player power off by itself after completion. Last night when I try to play a DVD there was no audio. I tried another DVD with same result. Streaming from Netflix also has no audio.

Anyone has same issue after upgrade or know how to get audio back?

Discussion is locked
You are posting a reply to: No audio after firmware upgrade on BDP1600
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: No audio after firmware upgrade on BDP1600
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
No audio after firmware upgrade on BDP1600
by Samsung_HD_Tech Samsung staff / September 6, 2009 2:33 AM PDT


When performance of Firmware update, it can be pretty common for the Firmware to reset the unt back to "out of the box" default settings. Have you tried going into the setup menu to see if the audio output settings are the same?


Collapse -
Possible No Audio Fix
by Robert.Baggett / December 15, 2009 12:05 AM PST

I originally bought this bluray player for my father back on father's day. Never really had an issue until recently. He started experiencing the same issues you had with no audio coming from any of the features that this player offered (Bluray discs, Neflix, Pandora, or YouTube). I asked him if he had updated the firmware recently but he said no. I tried messing with the cables, player audio settings, and having the machine look for new firmware but none of it seemed to help.

After exhausting all those options, I decided to unplug the device and see if that would help. It did. Give that a try if you haven't done so already.

The firmware I have on my machine is BEv2.05_091015A_XAA. Hope this helps.

Collapse -
Totally worked
by jhbovee / March 14, 2012 11:54 AM PDT
In reply to: Possible No Audio Fix

Had the exact same problem with Samsung BD-P1600 Bluray player. Suddenly no sound from dvd or Netflix. Thought it might be the cable, but then I found this post and tried unplugging the unit. Voila! Thanks ever so much - my headache has disappeared.

Popular Forums
Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions


Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?