Windows Legacy OS forum

General discussion

NIC not so nice

by karpat / March 16, 2009 7:45 AM PDT

I installed Ubuntu 8.1 as a second os on my xp system. Asus p4pe Socket 478 Pentium 4 which is my motherboard has build in Realtek rtc 8137 family pci fast ethernet nic.

If I boot into the Ubuntu os I have internet which is Comcast cable. If I reboot into xp I do not have internet connection. While in xp if I go to device manager it shows the nic card working. When the nic device is working there is a small green light that is on at the back of the computer where the RJ-45 plugs in. This light is on when I'm booted into Ubuntu but it is out when I boot into xp.

I have voice over internet phone service which is working fine and I'm typing this on my wifes computer which is working fine on the internet connection.

I've tried uninstalling Ubuntu but this did not fix the problem. I used my back up system to reinstall my c drive but the problem has not gone away. I've now reformatted my c drive and did a new intall of xp but this did not correct the problem.

Ubuntu forum, Asus forum have not been able to help.

Thanks for looking at this problem.

Patrick

Discussion is locked
You are posting a reply to: NIC not so nice
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: NIC not so nice
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
And You Installed The Ethernet Driver For XP?
by Grif Thomas Forum moderator / March 17, 2009 7:44 AM PDT
In reply to: NIC not so nice

The XP installation CD doesn't provide such drivers.

Hope this hopes.

Grif

Collapse -
Nic not so nice
by karpat / March 17, 2009 9:41 AM PDT

I had the latest drives for my motherboard installed when this happened. Keep in mind that the ethernet device is built in on this motherboard. It is the Realtek RTC 8137 NIC.

Collapse -
Reinstall MB drivers
by ramusson / March 17, 2009 12:25 PM PDT
In reply to: Nic not so nice

I'd suggest that you re install the MB drivers again.

But before that check whether the LAN card is Enabled ( Start - Settings - Network Connections )

Incidentally, Ubuntu is not likely to be the culprit!

Ramesh

Collapse -
enabled or not
by karpat / March 17, 2009 6:17 PM PDT
In reply to: Reinstall MB drivers

The Lan card is enabled if I've booted from Ubuntu, if I boot into XP the Lan card is not enabled.

Collapse -
Enabled?
by ramusson / March 18, 2009 12:41 AM PDT
In reply to: enabled or not

Go to Control Panel -> Network Connections.
Check if the "Local Area Connection" is Enabled or not.

Ramesh

Collapse -
NIC not so nice
by karpat / March 18, 2009 6:28 AM PDT
In reply to: Enabled?

If I boot in Ubuntu it is enabled but if I reboot in XP it is not.

Collapse -
(NT) (NT) Enable it.
by ramusson / March 18, 2009 11:57 AM PDT
In reply to: NIC not so nice
Collapse -
NIC not so nice
by karpat / March 18, 2009 5:16 PM PDT
In reply to: (NT) Enable it.

It is and has been enabled but when I click on the network connections it says the cable is unplugged but it is not.

Collapse -
Next ...
by ramusson / March 19, 2009 1:08 AM PDT
In reply to: NIC not so nice

Open Network Connections
Right Click on Local Area Connection -> Properties
Highlight Internet Protocol (TCP/IP) -> Properties

What does it say?

Is "Obtain an IP address automatically" ticked?

Ramesh

Collapse -
NIC not so nice
by karpat / March 19, 2009 6:15 AM PDT
In reply to: Next ...

Yes Obtain an IP address is and was Automatically Ticked.

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

FALL TV PREMIERES

Your favorite shows are back!

Don’t miss your dramas, sitcoms and reality shows. Find out when and where they’re airing!