Yes, you need NFC and Android version 4.4 or higher.

Kees