Windows Legacy OS forum

General discussion

New HD isn't recognized by windows XP?

by Amickracing / September 14, 2004 6:42 AM PDT

I'm running windows XP. I currently have 2 HD's run off the motherboard, and I added an additional one via a card that plugs into the motherboard and runs IDE hard drives. Everything worked great, except I ran out of space. So I bought one more hard drive (western digital 160gig) and installed it. I got it formatted and it worked fine. I added it to the same "channel" of the IDE card that ran my other hard drive, just used a cable that has 2 connectors on it. Well I fought and fought and it only wants to show one of the hard drives in windows, but during bootup the computer shows it see's them both, and so does the device manager in windows, just doesn't show up in my computer or explore.

I've adjusted the jumpers and it didn't help any (tried one master one slave, both slaves). I got it working somehow for a couple days, but today I resarted (1st time since they worked) and now one of the drives is gone again. They are all formated to the NFTS format too. I don't have any devices turned off, and I'm logging in under the same (and only) username in XP.

Hopefully that made sense, if there any further questions you have to help me I just ask away. Thanks in advance for the help ladies and gents, I really appreciate it!

Discussion is locked
You are posting a reply to: New HD isn't recognized by windows XP?
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: New HD isn't recognized by windows XP?
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Re: New HD isn't recognized by windows XP?
by Amickracing / September 14, 2004 6:51 AM PDT

Sorry for the double post, but I need to reword something. I have all the drives enabled, but the hard drive that isn't working, in the device manager it's just a grey blank where you could choose enable or disable.

Thanks

Collapse -
WAG,
by FrankQTran / September 14, 2004 7:09 AM PDT

On every IDE channel, you can have 1 (one) master and 1 (one) slave. And I am not talking about SCSI.

During the bootup time it a BIOS detected your disks. So, it didn't mean the hard disks have been configurated correctly.

If I read your thread correctly, you already has 3 hard disks installed. The newest drive (fourth) can be set as master or slave depending on the existing third drive on that IDE channel. BUT, beware of the partition. Only 1 (one) primary partition can be seted "ACTIVE". Otherwise, Windows will confuse....

In otherwords, make sure the latest drive isn't have any "ACTIVE" partition on it.

Regards,

Collapse -
Re: New HD isn't recognized by windows XP?
by billzhills / September 14, 2004 7:27 AM PDT

Some thoughts

PCI IDE card ...
Drivers installed? One or two channels? Brand?
-------------------
New Drive....
As mentioned does new drive have active partition?
Formatted as an extended partitions w/logical drives?
------------------

Will the system support that many drives?
BIOS - Power Supply - Case size for heat removal
-------------------

Do you have a good back up? H/Ds' are temp. storage.
-------------------


Bill
.

Collapse -
Re: New HD isn't recognized by windows XP?
by Amickracing / September 14, 2004 8:52 AM PDT

On all of my hard drives, I only have one partition set as active (the one the OS is on), the rest are storage only.

One pair of hard drives that goes to the IDE channel on the motherboard, one is master and one is slave. And I have the same setup on the 2 hard drives that go to the IDE card that is plugged into the PCI slot.

The IDE card is a Silicon Image Sil 0680 ATA/133 controller. I have the proper drives installed (came on a floppy disk). I haven't checked the net for updates yet because the card worked before, so I was hoping the drivers were ok.

Not sure if the system is designed for that many hard drives, but I don't really see why not, afterall it did work for a few days. The case has plenty of room in it, and should do a good job removing heat, but I'm probably going to add one more fan soon because there's one place left for one, and it can't hurt... the powersupply is plenty big too.

I've snooped through BIOS and didn't see anything set wrong, plus I also figured it must be right since during boot when it's the IDE cards turn to load it says searching, then gives a list of all channels and on 2 of them shows the proper hard drives like it should.

What really confuses me is if I open device manager, and go to disk drives I see 4 hard drives (which is right), but in my computer, I only see 3 of them. There are no yellow question marks by anything in device manager either. When I click on properties of that hard drive in device manager it says this device is working properly, the only difference is the enable or disable window is greyed out.

Thanks again, I think we are on the right track.
Lynn

Collapse -
Just curiosity...
by FrankQTran / September 14, 2004 9:25 AM PDT
"...One pair of hard drives that goes to the IDE channel on the motherboard, one is master and one is slave. And I have the same setup on the 2 hard drives that go to the IDE card that is plugged into the PCI slot."

Is that mean you motherboard only has 1 IDE slot?

Can you temporaly remove the first and second drive from the IDE slot and plug in the third and fourth drive into that IDE slot. Boot with any bootable floppy and run the DOS command FDISK /STATUS to see if they are recognized in DOS (even if you formatted them with NTFS).

If you do have 2 IDE slot, try to use that slot on the third and fourth drive to see if it works then we can't blame on the bad PCI card.

Regards,
Collapse -
Re: Just curiosity...
by Amickracing / September 14, 2004 10:42 AM PDT
In reply to: Just curiosity...

Ok, I unhooked the CDrom's from the 2nd IDE chanel and hooked the hard drives to that one (one master, one slave), and they showed up in my computer.

So I turned everything off and hooked up the CDrom's to the IDE card and they were recognized by bios as it booted. Once XP was done loading I opened my computer and all the hard drives and both CD roms showed up. Then a message flashed down by the clock (didn't get a chance to read it) and the 2 CDrom's disapeared from the list in my computer.

I hooked the CDroms back up to the 2nd IDE port on the motherboard, and the hard drives back to the card, and went into the configuration of the IDE card during bootup and set the master as the 1st hard drive (that was the only thing I could do in that config part), and started windows... same deal, it still doesn't show the one hard drive. But if I unplug the power to the hard drive that does show up and bootup, I can see the other hard drive. It really seems like XP just doesn't like that many drives or something. I just can't figure out why it shows them, then they dissapear like that.

Also to answer something in a previous post, I do have the important stuff backed up on CD's, the stuff on the hard drives is mainly stuff I can live with out if need be.

Collapse -
Another WAG...
by FrankQTran / September 14, 2004 2:13 PM PDT
In reply to: Re: Just curiosity...

I haven't use those "RAID type" card for a long time. I use either Firewire or USB now to extended my devices.

The only thing I can think is that possible you installed SP2 into your XP system? If that the case then you might need to contact the PCI card manufacture for a fix.

Regards,

Collapse -
Try this
by Merl Priester / September 15, 2004 7:52 AM PDT
In reply to: Another WAG...

That card supports 4 drives, 2 on each channel.
But it may not be working correctly, windows drivers may not be happy either. (use the default Windows IDE drivers)

Try putting each drive on a different cable on the
SIL PCI card. It has 2 IDE connectore, use both.

Collapse -
Re: New HD isn't recognized by windows XP?
by mjs474 / September 15, 2004 8:25 AM PDT

I am having a similar problem. I have four Maxtor Ultra 133 7200 rpm, smb cashe' hard drives, 1) 80 GB system drive, and 1) 200 GB both running off of the ATA IDE channel of my motherboard. I also installed a Maxtor Ultra ATA PCI Controller card that will support 4 more ATA devices. I installed the drivers for the Ultra ATA Controller Card with approved XP drivers, it is detected in my boot up and in my device manager. However, when I connected the ribbon cable from the two 200 GB hard drives to the Ultra ATA PCI card, the drives were detected as unknown devices. The drives were formated in XP NTSF format. Should I also run the Maxtor "Max Blast" hard drive installation CD?

Collapse -
You should have your own discussion.
by R. Proffitt Forum moderator / September 15, 2004 8:37 AM PDT

Here's why. With those over 137 GB drives, there is an issue and risk if you have just XP and not XP SP1. An OS reinstall of "XP" without the SP1 has resulted in the over 137 GB drive data vanishing.

Just so you know.

Bob

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

CNET FORUMS TOP DISCUSSION

Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?